Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old April 1, 2018, 10:57 AM
Rookie
 
Join Date: Mar 2009
Location: London, ON
Posts: 30
Default Dedicated GPU Usage Issue

Recently I've noticed that games are not using my graphics card like they used to. Rather it's only at a small percent (50-75) or not at all. The games I specifically notice it in are BF1 and League of Legends. Drivers are updated, system power settings are fine, bios hasn't changed, windows recognizes the card and other games utilize it normally (Fortnite). As of right now, the only solution I seem to be able to get, is a restart.

Any ideas?

Specs:

Windows 10 Pro 64
i7 5930k @4Ghz
32GB RAM
MSI X99A SLI Plus
EVGA 1080 FTW
Reply With Quote
  #2 (permalink)  
Old April 1, 2018, 11:37 AM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 11,394
Default

Games are either GPU or CPU bound and rarely both. Neither of those games are very gpu intensive.
Reply With Quote
  #3 (permalink)  
Old April 1, 2018, 06:29 PM
Rookie
 
Join Date: Mar 2009
Location: London, ON
Posts: 30
Default

agreed, however, i notice because there is a huge frame drop. BF1 usually runs at 144, gpu around 90%... now it's 50-60 and 60% and LoL runs at 30fps... regularly 200+
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
SLI GTX 580's & GTX 480 Dedicated? TokeR Video Cards 8 July 13, 2011 12:24 PM
SC2 RAM usage Dar_ell Gaming 7 August 3, 2010 08:29 AM
Low GPU usage Lamb HardwareCanucks F@H Team 2 January 9, 2010 09:32 PM