Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old September 7, 2017, 06:40 PM
Rookie
 
Join Date: Dec 2010
Location: Ajax, Ontario
Posts: 27

My System Specs

Default Weird mouse 'skipping' problem...

So, this one might be a little strange, but today I've noticed my mouse deciding to 'skip' or seemingly lose tracking which is incredibly frustrating, annoying, and makes me miss clicking on stuff. As someone who works from their PC this is getting infuriating, and I don't know what's causing it.

Firstly, I have a little bit of a strange setup situation which might play into what's going on here. Last week I had to RMA my slightly well loved GTX 980ti for a loose fan that was rattling. I've also got an original Asus ROG Swift G-Sync monitor. During the RMA process, I've stolen a 'loaner' card from my brother's computer - an RX470 4gb (plays most things on low at 1440p so I can deal for a couple weeks).

I've got it hooked up to the g-sync monitor, and it runs at 120hz well. I haven't noticed the mouse skipping until this morning, but I feel like I should have if it was there before. Could this be an issue caused by using a g-sync monitor with a Radeon/Unsupported card? I've tried multiple mice - Mionix, Razer, No-Name and all have the same problem. I've even tried different USB ports but the issue persists. Drivers, software, all of it. Nothing stops this weird issue.

Any ideas?
Reply With Quote
  #2 (permalink)  
Old September 7, 2017, 11:51 PM
Hall Of Fame
 
Join Date: Aug 2011
Location: Vancouver, BC
Posts: 1,257
Default

No experience with G-Sync and the likes but I would start with checking if the card is sitting correctly and see if there are any kind of shortage inside the case. The second thing I would check is to see if the front USB plugs are causing issues where a broken / shorted front USB panel may be causing issues.
Reply With Quote
  #3 (permalink)  
Old September 8, 2017, 03:43 AM
Hall Of Fame
F@H
 
Join Date: Aug 2007
Location: Toronto, ON
Posts: 1,657

My System Specs

Default

Check your dpc latency. A while back the asus mobo monitoring software would make my dpc latency spike. Then later on my mouse actually died and would intermittently stop tracking mid swipe.
__________________
heatware
Reply With Quote
  #4 (permalink)  
Old September 8, 2017, 06:03 AM
Rookie
 
Join Date: Dec 2010
Location: Ajax, Ontario
Posts: 27

My System Specs

Default

Quote:
Originally Posted by zoob View Post
Check your dpc latency. A while back the asus mobo monitoring software would make my dpc latency spike. Then later on my mouse actually died and would intermittently stop tracking mid swipe.
How does one check dpc latency?

Also another strange thing - there isn't any mouse lag on the logon screen when I turn the PC on, only AFTER windows loads up. This is weird.
Reply With Quote
  #5 (permalink)  
Old September 8, 2017, 06:21 AM
Hall Of Fame
F@H
 
Join Date: Aug 2007
Location: Toronto, ON
Posts: 1,657

My System Specs

Default

Resplendence Software - LatencyMon: suitability checker for real-time audio and other tasks

Try using msconfig and disable all of the unnecessary stuff in your startup. Probably some monitoring software causing your problem.
__________________
heatware
Reply With Quote
  #6 (permalink)  
Old September 8, 2017, 06:30 AM
Lysrin's Avatar
Hall Of Fame
 
Join Date: Mar 2014
Location: Nova Scotia
Posts: 3,058

My System Specs

Default

I would wonder about video drivers too. You said you tried them but switching from NVIDIA to AMD can cause issues if one or the other isn't completely cleaned up properly. There is an app called DDU I believe that could help make sure everything is cleaned up before you put the ones on for RX470. Worth a shot. I recently had mouse ghosting and issues on the Linux PC that in the end were desktop environment and driver related. In that case I had problems when running the monitor off DisplayPort but not VGA. Switching things up with desktop environment and drivers cleaned everything up on DisplayPort. Linux example, but you never know.
Reply With Quote
  #7 (permalink)  
Old September 8, 2017, 06:51 AM
Rookie
 
Join Date: Dec 2010
Location: Ajax, Ontario
Posts: 27

My System Specs

Default

Quote:
Originally Posted by Lysrin View Post
I would wonder about video drivers too. You said you tried them but switching from NVIDIA to AMD can cause issues if one or the other isn't completely cleaned up properly. There is an app called DDU I believe that could help make sure everything is cleaned up before you put the ones on for RX470. Worth a shot. I recently had mouse ghosting and issues on the Linux PC that in the end were desktop environment and driver related. In that case I had problems when running the monitor off DisplayPort but not VGA. Switching things up with desktop environment and drivers cleaned everything up on DisplayPort. Linux example, but you never know.
I actually used DDU to strip the NVIDIA driver off in the first place so the rx470 is running on a clean driver.....which is really weird also.

I think we'll have to wait for my 980ti to get back to see if its a driver issue with AMD cards.
Reply With Quote
  #8 (permalink)  
Old September 8, 2017, 04:16 PM
KaptCrunch's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Ontario
Posts: 4,018
Default

CHECK motherboard firmware and drivers (usb) to your model and revision of MB
Reply With Quote
  #9 (permalink)  
Old September 8, 2017, 05:15 PM
Shadowmeph's Avatar
Hall Of Fame
F@H
 
Join Date: Oct 2007
Posts: 4,069

My System Specs

Default

Quote:
Originally Posted by KaptCrunch View Post
CHECK motherboard firmware and drivers (usb) to your model and revision of MB
I agree I had same problem with my FAv mouse tried everything aftert doing above it seemed to fix the problem but then a month later mouse died not sure if above fixed it or if it was just coincidence
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird restart problem bf3... danmitch1 Troubleshooting 72 April 12, 2012 02:37 PM
Weird HDD problem NineLives Storage 4 August 23, 2011 07:51 PM
Weird problem JerryZ CPU's and Motherboards 6 July 8, 2010 09:28 PM
Weird problem with Crysis! Need help!! esperasoppa Gaming 10 December 18, 2009 07:24 AM
Weird problem Kilauea Networking 16 August 21, 2008 09:35 AM