Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old March 12, 2017, 09:47 PM
Hall Of Fame
 
Join Date: Aug 2011
Location: Vancouver, BC
Posts: 1,232
Default AMD 7970 Temps and PCI-E Speed

I had a situation where my video card suddenly show some horizontal line artifacts on the DP port while the HDMI display looked fine. I checked the temps in HW Monitor and it's showing 60C during regular use (just coding) with a room temp around 22C. AMD setting is also saying it's running as PCI-E x8 instead of x16. My mobo is a Gigabyte Z68X-UD4 B3.
Reply With Quote
  #2 (permalink)  
Old March 12, 2017, 10:15 PM
MAC's Avatar
MAC MAC is offline
Associate Review Editor
 
Join Date: Nov 2006
Location: Montreal
Posts: 1,145
Default

Not sure about your artifact issue, but if you open up CPU-Z and go to the Mainboard tab, at the bottom you can double check to see what your current PCI-E "Link Width" is.
Reply With Quote
  #3 (permalink)  
Old March 12, 2017, 10:17 PM
Hall Of Fame
 
Join Date: Aug 2011
Location: Vancouver, BC
Posts: 1,232
Default

It's showing Link Width of x8 and Max Supported of x16. I also Googled around and it seems that USB 3.0 turbo mode may be cutting it down to x8.

Update: well turning USB 3.0 turbo to off did the trick. Back up to x16. After the reboot, GPU temps back to 40C but I disabled multi-monitors as well.

Last edited by moocow; March 12, 2017 at 10:25 PM.
Reply With Quote
  #4 (permalink)  
Old March 12, 2017, 11:21 PM
Bond007's Avatar
Hall Of Fame
 
Join Date: Jun 2009
Location: Nova Scotia
Posts: 4,905

My System Specs

Default

Quote:
Originally Posted by moocow View Post
It's showing Link Width of x8 and Max Supported of x16. I also Googled around and it seems that USB 3.0 turbo mode may be cutting it down to x8.

Update: well turning USB 3.0 turbo to off did the trick. Back up to x16. After the reboot, GPU temps back to 40C but I disabled multi-monitors as well.
Glad to hear you got the pcie slot issue sorted.

Multi-monitor will be the reason for the temps. My 280X is the same way.

When setup for multi-monitor the VRAM runs full speed and the core does downclock, but not as lot as single monitor. For my 280X I think the core goes down to 300mhz idle single monitor vs 500mhz multi-monitor. Vram idle single monitor goes down to 150mhz, but multimonitor it stays pegged at 1500mhz.
__________________
Desktop: Arc Midi R2, Z77-D3H, 3770@4.1ghz with Zalman Optima Cooler, 4x4gb ram, EVGA GTX 1070 Ti SC, Bitfenix Fury 750w, WD Black 1TB, MX500 500gb
Away from home: Lenovo Legion Y530, 16gb, i7 8750H, GTX1050Ti
Reply With Quote
  #5 (permalink)  
Old March 12, 2017, 11:38 PM
Hall Of Fame
 
Join Date: Aug 2011
Location: Vancouver, BC
Posts: 1,232
Default

Thanks for confirming the behavior Bond. On a related note, when I'm running on multi-monitor mode, I noticed my other monitors on HDMI (HDMI to DVI cable) and DVI have a flicker / vertical tearing once in a while. I checked the refresh rates for all 3 monitors are the same (60) but they run at different resolution because all 3 are different size. Any idea?
Reply With Quote
  #6 (permalink)  
Old March 13, 2017, 09:25 AM
Hall Of Fame
 
Join Date: Oct 2009
Location: Ontario
Posts: 1,085

My System Specs

Default

I vaguely recall something along the lines of AMD having that flicker/tearing issue when in multi-monitor mode when using different connectors between the monitors. Don't think you'll be able to get away from that one.
__________________

Reply With Quote
  #7 (permalink)  
Old March 13, 2017, 01:10 PM
Hall Of Fame
 
Join Date: Aug 2011
Location: Vancouver, BC
Posts: 1,232
Default

Well until I get a job, buy a place, replacing all my monitors will not happen.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
7970 100% Fan Speed On Boot, No Display JoeOnePack Video Cards 9 February 28, 2014 12:00 PM
[FS] SOLD! 2- 7970 DUAL X OC's or trade for your reference 7970 Squeetard Buy/Sell & Trade 6 October 7, 2013 08:28 AM
[WTT] XFX 7970 DD for a reference 7970 mojojj Buy/Sell & Trade 0 March 14, 2013 03:20 PM
Fan speed after long idle on Sapphire 7970 486 Video Cards 7 February 9, 2012 07:19 PM