Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old February 22, 2017, 11:26 AM
Rookie
 
Join Date: Feb 2017
Posts: 2
Question ASRock Z270 Supercarrier - blackscreen 09/d0, how to switch to backup BIOS?

I have an ASRock Z270 Supercarrier and used the Internet Flash utility in UEFI setup to upgrade the BIOS from 1.10 to 1.11. The upgrade process completed successfully and no errors were reported. However, when the computer rebooted with the new BIOS, it just hung with a blackscreen. I have rebooted the system over 20 times, with the same result. The boot process runs for about 15 seconds, the Dr. Debug LED settles on 09 or d0, and remains in that hung state.

According to the manual, "after several failed boot attempts, the backup BIOS will take over" -- but this doesn't seem to be happening. It still boots from the active BIOS (BIOS_A_LED is on). I also tried unplugging the computer and depressing the clear CMOS button for over 10 seconds, but that didn't seem to have any affect.

Is there any way that I can force a switch to BIOS B, or alternatively, downgrade BIOS A back to 1.10? The motherboard was working fine with 1.10 before I upgraded it to 1.11.
Reply With Quote
  #2 (permalink)  
Old February 22, 2017, 12:30 PM
Hall Of Fame
 
Join Date: Oct 2009
Location: Ontario
Posts: 1,085

My System Specs

Default

Try this:

1) Turn off computer
2) Disconnect power cord from PSU
3) Remove the CMOS battery for 15 seconds, then put back in.

You can then reconnect the cord and turn the computer on. I have found that the clear CMOS button does not always successfully clear all settings as it should.

It looks like the battery is underneath the first slot, so you might have to remove your GPU to get to it.
__________________

Reply With Quote
  #3 (permalink)  
Old February 23, 2017, 07:50 PM
Rookie
 
Join Date: Feb 2017
Posts: 2
Default Problem solved

Good news -- I removed all but one of my RAM cards and was able to boot up with BIOS A. I attached a FAT32 USB stick with the 1.10 BIOS file and used the UEFI Instant Flash tool to successfully downgrade BIOS A. I then added back my other RAM cards and successfully booted the system just like it was before. Problem solved!

Last edited by kartik_subbarao; February 23, 2017 at 07:56 PM.
Reply With Quote
Reply


Tags
asrock , bios , bios crash , z270

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
ASRock Fatal1ty Z270 Gaming K6 Review COMMENT THREAD SKYMTL CPU's and Motherboards 0 January 3, 2017 04:31 PM
Random blackscreen crashes to bios yoyoguy Troubleshooting 3 August 14, 2016 10:31 AM
OC'ing Happiness: AsRock p45r2000 Bios electronique Overclocking, Tweaking and Benchmarking 21 September 17, 2008 04:10 PM