Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #31 (permalink)  
Old July 9, 2016, 06:43 PM
MVP
 
Join Date: Nov 2007
Location: North Shore
Posts: 398

My System Specs

Default

Quote:
Originally Posted by Pabz0r545 View Post
Replaced the battery again and it didn't work. Looks like I'll have to try a new PSU on payday. It's gotta be the problem. and if it is I am never buying another Silverstone product in my life.
Too bad you don't live nearby I'd lend you a spare
Reply With Quote
  #32 (permalink)  
Old July 10, 2016, 06:48 AM
maverick_brent's Avatar
Allstar
 
Join Date: Jun 2008
Location: Nova Scotia
Posts: 515

My System Specs

Default

Quote:
Originally Posted by Pabz0r545 View Post
Replaced the battery again and it didn't work. Looks like I'll have to try a new PSU on payday. It's gotta be the problem. and if it is I am never buying another Silverstone product in my life.


hmm something you could check is to remove the internals from the case, and run it on a wooden table. you could perhaps have a short somewheres.
Reply With Quote
  #33 (permalink)  
Old July 10, 2016, 08:18 AM
Hall Of Fame
 
Join Date: May 2011
Location: Calgary
Posts: 2,752

My System Specs

Default

It's normal for some lights to be on even when the computer is off. Generally there's an led on the mobo that stays on until the psu is switched off.
__________________
__________________________________________________ __________
"Lesson's cost money... good ones costs lots" -Tony Beets (gold rush)
__________________________________________________ __________
Mah Rig now
Mah Rig before
My stuff for sale.
Reply With Quote
  #34 (permalink)  
Old July 26, 2016, 03:07 PM
"Quote This..."
F@H
 
Join Date: Nov 2007
Location: Hell
Posts: 4,014
Default

Had the same issue, new power supply fixed it.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Any reason why a PSU would not spin some case fans? bonanza2000 Power Supplies 6 November 3, 2013 07:35 AM
New build, won't boot, fans spin slightly HighEntropy Troubleshooting 28 September 5, 2011 04:53 PM
Spin down fans completely on VGA coolers lKashl Overclocking, Tweaking and Benchmarking 9 July 8, 2011 05:12 PM
2 of 3 pci ports stop boot up NoKlu Troubleshooting 2 October 2, 2009 10:51 PM
Fans Spin, Won't POST or Beep Scart Troubleshooting 11 July 29, 2008 03:42 PM