Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #221 (permalink)  
Old January 9, 2014, 08:14 PM
Fortier's Avatar
Rookie
 
Join Date: Jan 2014
Location: Medicine Hat, AB
Posts: 26

My System Specs

Default

Company Name: MSI Product: Gaming Laptop
Warranty Period: 2 year
Date purchased: Jan 2012
Date RMAed: Jan 2014
Where it was sent to: Canada, BC, Vancouver
Ease of RMA: 9
Any extra fees?: No
Wait time: 7 days
Details: Laptop was a few days from being out of warranty, RMA was easy and got it back in 7 days Satisfaction: 10
Reply With Quote
  #222 (permalink)  
Old January 9, 2014, 08:18 PM
Fortier's Avatar
Rookie
 
Join Date: Jan 2014
Location: Medicine Hat, AB
Posts: 26

My System Specs

Default

Company Name: EVGA
Product: 780 GTX
Warranty Period: 3 year
Date purchased: Oct 2013
Date RMAed: Jan 2014
Where it was sent to: US
Ease of RMA: 4
Any extra fees?: Yes, so much so that I decided against it
Wait time: Never completed
Details: Entered EVGA's step-up program, waited 3 months and then gave up as they were expecting way too much money for shipping costs
Satisfaction: 1
Reply With Quote
  #223 (permalink)  
Old January 16, 2014, 05:43 PM
b1lk1's Avatar
Hall Of Fame
 
Join Date: Feb 2007
Location: Lindsay, Ontario
Posts: 2,769

My System Specs

Default

Aros RMA + horrible experience.

They have had my tablet for 2 months, told me they were going to ship a replacement when they got more stock over a month ago. They do not answer emails anymore, have to call them tomorrow. This has been a very bad RMA for me.
__________________


Reply With Quote
  #224 (permalink)  
Old January 16, 2014, 05:47 PM
sswilson's Avatar
Moderator
F@H
 
Join Date: Dec 2006
Location: Moncton NB
Posts: 17,949

My System Specs

Default

Quote:
Originally Posted by b1lk1 View Post
Aros RMA + horrible experience.

They have had my tablet for 2 months, told me they were going to ship a replacement when they got more stock over a month ago. They do not answer emails anymore, have to call them tomorrow. This has been a very bad RMA for me.
Damn... is that the tablet your young lad bought?
__________________
ASUS ROG Strix Z370-G Gaming (WiFi AC) / i7 8700K / 2X 8G XPG Spectrix D40 (3000) / XFX XTR 750 / ASUS Strix GTX 1070ti
Lian-Li PC-011 Air (RGB) / Custom WC / Intel 730 Series 480GB SSD / Intel 760p 512GB NVMe / ASUS SWIFT PG279Q
Dell Optiplex 3020 / Intel Core i3 i3-4160 / EVGA GT 1030 SC / 6GB DDR3 / Samsung 850 EVO 500GB SSD/ Samsung 27" 1080p (Curved)
Dell G3 - i5 8300H / HP EX920 512GB NVME / 2X8GB HyperX Impact / 1TB SSHD / GTX 1050ti / N156HHE-GA1 120HZ Screen
Reply With Quote
  #225 (permalink)  
Old January 29, 2014, 12:59 PM
Top Prospect
 
Join Date: May 2010
Location: TO/RH/Markham
Posts: 244

My System Specs

Default

I see my rant was removed from my other thread. So I shall simply post the brief overview here, without the excessive $#@!%#@!.

Company Name: PowerColor
Product: Radeon HD7970 V3 (model #: ax7970 3gbd5-2dhv3)
Warranty Period: 2 Years
Date purchased: April 2013
Date RMAed: November 2013
Where it was sent to: US, California, City of Industry
Ease of RMA: Assuming 10 is most difficult, and 1 is least difficult. My difficult RMA was a 7.
Any extra fees?: Yes, $25 - $30 in shipping fees, to ship from Richmond Hill
Wait time: First time, 3 weeks (1 week to ship there, 1 week to process, 1 week to ship back)
Second time, 4 weeks (1 week to ship there, 2 weeks to process, 1 week to ship back)

Details: The first time around, registering and sending in the card for RMA was easy. However, it was until after I got my replacement card, that it became a painful process. They basically sent me a lemon for a replacement (i.e. I unboxed it, installed it, booted my rig, and then my screen was overwhelmed with thick vertical lines).

After calling them, they wanted me to test the card on another machine and send them pictures. I tested on two other machines, and took pictures. I sent them the results and they asked me to ship the replacement card back to them, but they did not want to cover the shipping fees, even though I was not at fault, and they're the ones who sent me a replacement lemon.

After 30 mins on the phone, they agreed to cover the shipping, as long as I shipped with the least expensive option with Canada Post, and included a copy of the shipping invoice in my package. I did all of that. When CanPost/USPS confirmed that they received the package, RMA services said they could not locate my parcel.

A couple days later, they said they found it. They said they tested it for two hours on one machine, and two hours on another, and found nothing wrong, thus negating the need to reimburse my shipping fees. What a load of horse-baloney, because I tested it on my colleague's rig and my friend's rig (so 3 very different system specs altogether) and got the same problems, and my old 6850 and the second replacement 7970 works perfect on my rig, so I know something was wrong with the card.

They said they could send me the exact same card back, or yet another replacement. So I settled for another replacement. Thank God this second replacement works perfect (btway, these are not BNIB cards, they're "replacement" cards).

To sum it up - sent me a replacement lemon; then asked me to test on multiple machines and take pictures; then initially didn't want to reimburse shipping fees for second RMA; then could not find my parcel; then said nothing wrong with the card; then said "no, we are not reimbursing you the shipping fees". If that's not a bad RMA experience, I don't know what is. I guess they could've screwed me even more, by not sending me a replacement at all.

Satisfaction: Assuming 10 is most satisfied, and 1 is least satisfied. My experience was 1.

*EDIT: I dug-up some emails. After I sent the pictures of the problem on my rig and my colleague's rig and my friend's rig, here's RMA Services' reply - "Thank you for your time in verifying that the card is the root of the problem. As soon as I receive the card, I will try to get this issue resolved as quickly as possible"...and they have the nerve to tell me that nothing was wrong with the card, just because their own testing did not yield the same results...

Last edited by cul8erppl; January 29, 2014 at 01:31 PM.
Reply With Quote
  #226 (permalink)  
Old January 30, 2014, 09:47 AM
Allstar
 
Join Date: Dec 2008
Location: Toronto
Posts: 593

My System Specs

Default

I do not like Power Color. I have their HD4850. I cannot do anything with it, and the fan whines like a jet engine. My latest is Gigabyte HD7950 which is really great.
Anyway, did you have problem from day one when you purchased it, and if so, why did you not send it back? Maybe PC's HD7970 does is not compatible with certain things, e.g. your mobo chipset?
Reply With Quote
  #227 (permalink)  
Old January 30, 2014, 04:43 PM
Top Prospect
 
Join Date: May 2010
Location: TO/RH/Markham
Posts: 244

My System Specs

Default

It worked fine for the first few months, then I started to notice artifacts in games, so I thought it was a driver problem and needed updating. However, the artifacts were especially noticeable when I moved to the official release of Catalyst 13.9. Could not even go thru several iterations of Heaven 4.0 without screen tearing and artifacts, and about 30 mins into games like Crysis 3, BF4, Payday, etc.

I know it was a problem with the card and not compatibility issues, because the 2nd replacement card that they sent me works fine now. Ran thru hours of Heaven, 3dMark, and 3dMark11 loops. Played countless hours of BF4 also, no problems, all on 13.9.
Reply With Quote
  #228 (permalink)  
Old February 3, 2014, 12:47 PM
b1lk1's Avatar
Hall Of Fame
 
Join Date: Feb 2007
Location: Lindsay, Ontario
Posts: 2,769

My System Specs

Default

Quote:
Originally Posted by sswilson View Post
Damn... is that the tablet your young lad bought?
Nah, this was Mama's tablet, gonna be my new tablet. They keep offering to ship a free replacement, now I just gotta get them to send it. They are even upgrading it to a Archos 101XS which is updated and far more useful. Now if I can just get them to actually send it.
__________________


Reply With Quote
  #229 (permalink)  
Old February 5, 2014, 05:48 PM
b1lk1's Avatar
Hall Of Fame
 
Join Date: Feb 2007
Location: Lindsay, Ontario
Posts: 2,769

My System Specs

Default Resolution

Archos has finally shipped me a new 101XS 16GB to replace the out of warranty 80 G9 Turbo 250GB. Took 3 months and 15 emails and 4 phone calls. I kept cool calm and collected, never once got upset or raised my voice. To say I got a free huge upgrade is an understatement.

Only cost for this was the price of shipping my tablet to them which was around $25. Archos did not charge me one cent.

Wouldn't call it a bad RMA experience, but it did require a long wait and lots of patience.
__________________


Reply With Quote
  #230 (permalink)  
Old February 12, 2014, 12:11 PM
sweenytodd's Avatar
MVP
F@H
 
Join Date: Jan 2014
Location: Kelowna, BC
Posts: 362
Default

Company Name: Newegg Canada
Product: Asus GeForce GTX 780 Ti DirectCU II OC
Warranty Period: 3 years
Date purchased: January 6, 2014
Date RMAed: January 25, 2014
Where it was sent to: Canada, Ontario, Mississauga
Ease of RMA: 10
Any extra fees?: No
Wait time: 4 business days, 7 business days with the shipping time
Details: RMA was easy on Newegg. Just call them to receive a shipping label if your product is defective
Satisfaction: 10

As of now, my replacement card still have coil whine. I will RMA it again soon.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Canadian EH? Supergrover Off Topic 13 June 10, 2008 12:05 PM
My Experience with Direct Canada spdracer Off Topic 7 December 31, 2007 01:41 PM
Poor 1st o/c experience leads me to build dedicated o/c rig, help decide donimo Overclocking, Tweaking and Benchmarking 18 December 13, 2007 09:43 PM
Anyone have experience with Intel server boards? Jack Rabbit CPU's and Motherboards 20 November 26, 2007 09:31 PM
Initial experience very poor, not impressed. Chrisahl Off Topic 13 August 2, 2007 12:09 PM