View Single Post
  #1 (permalink)  
Old September 24, 2013, 01:57 PM
10e's Avatar
10e 10e is offline
Allstar
F@H
 
Join Date: Jan 2008
Location: Markham, Ontario
Posts: 775

My System Specs

Default Troubles with Asus Micro ATX z87 boards - mostly a rant!

Man, my luck lately has been all BAD. Part venting, part story

Had a Z87 Gryphon board to go with my admittedly sub-par, de-lidded overclocking 4770k. I decided to get into case mods and water cooling simultaneously and I dremel'd/modified a nice little Cooler Master N200 to support a 240mm radiator at the top and "w(h)et my chops" with some water cooling. A little inside....I know. Goulet.

So paired up with a set of GTX Titans with Swiftech Komodo water blocks I installed the board, the chip, 16GB (4x4GB) of some nice low profile Corsair Vengeance 1600mhz DDR3 and a Corsair AX760i PSU with pretty red custom cables into the chassis and went to work putting in my mostly NCIX and DAZmode procured items into this little jewel of a case. WC loop leak tested and passed with flying colors for 24+ hours. I was happy with this because my nice EK supremacy water block also supported the "naked precise mounting" setup which allows the Water block to directly interface with the die. A harrowing process to ensure I didn't poke any mobo socket pins, but I did it perfectly though painstakingly.

All this, only to find out the second PCI-E x16 slot was dead. Components would get power but the motherboard would not see them. Went through the involved process of draining the loop, removing the motherboard and cards and test the board with an EVGA GTX 660 Ti. Same result. The second PCI-E slot was basically dead. Even the Northbridge area under the System agent section of the BIOS showed me nothing in this slot. Normally it should show x8 or x16 if no card is installed in the first slot.

Unfortunately for me the backplate on the EVGA 660 TI board clipped one of the (too) closely placed clips on the near side of the DIMM slot and cracked the corner of the second DIMM slot clip. I still went ahead and RMA'd the board to the local Asus warranty/repair centre, who is now in process of voiding my nice 5 year warranty for this unrelated small bit of damage that actually happened after finding the issue with the slot.

Even worse, I tried an Asus Maximus VI gene which was an unmitigated disaster. It worked for two reboots, and the board then died a red death with a 00 Q-code which means CPU or mobo dead. The CPU was fine, but the board was not. This wasn't that bad, because it was easily returned to the retail store under their RMA warranty.

What ticks me off is my Asus Maximus V Gene has been an amazing board, as has been my older LGA 1366 Rampage III Gene (and Extreme) board, as has been every Asus board I've ever had except an Asus P5B Wifi Deluxe, until now.

So now I have to go to the warranty centre and I know I won't be in a good mood having to try and plead my case to them, trying to prove that the board was pooched prior to clipping the clip.

Any advice?



No more Asus Micro-ATX boards for me. I've learned my lesson. Back to Gigabyte or MSI for now. Maybe ASrock, though I fear their stuff too.
__________________

Xeven: How about 10^8.450980400142567e-001 -as a possible replacement for "10e"

http://www.heatware.com/eval.php?id=71732
Reply With Quote