Go Back   Hardware Canucks > CASES & COOLING > Water Cooling

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old September 9, 2008, 11:03 PM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,604
Default Lian-Li PC-A70 + Water



Really didn't want to go down this road again, but got some nice free money recently and well:

Swiftech MCR220 Quiet Power Dual 120MM Water Cooling Radiator Black G1/4 Threaded
Note: This product cannot be exchanged. Final sale only. No returns or refunds.
Please read our Terms & Conditions of sale on Water cooling equipment
20089 1 $44.99 $44.99
Masterkleer Pvc Tubing 7/16IN ID 5/9IN OD 10 Feet
Note: This product cannot be exchanged. Final sale only. No returns or refunds.
Please read our Terms & Conditions of sale on Water cooling equipment
21318 1 $9.99 $9.99
Polypropylene Tee for Water Cooling T Line 1/2IN Barbs
Note: This product cannot be exchanged. Final sale only. No returns or refunds.
Please read our Terms & Conditions of sale on Water cooling equipment
19709 1 $2.99 $2.99
Pts Petra PT_NUKE Concentrated Biocide Water Additive for Water COOLING(10ML)
25454 1 $4.99 $4.99

Apogee GT Bowed (owned)
MCP350 w/ Petra Top (owned)
..

Pics will follow in the next few days.
Attached Images
 

Last edited by enaberif; September 21, 2008 at 12:41 PM.
Reply With Quote
  #2 (permalink)  
Old September 10, 2008, 05:19 AM
Hall Of Fame
 
Join Date: Feb 2008
Location: Calgary, AB
Posts: 3,344
Default

Hey Curt, if you haven't bought tubing yet, I can send you what's left of mine, could be close to 10 feet, for like $5. You sent me some, and I had little remaining. I also have a T I had bought from Home Depot, only used it once, its one like your going to buy.
Reply With Quote
  #3 (permalink)  
Old September 14, 2008, 07:34 PM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,604
Default

Water is installed, system is bled and quiet. Will be picking up another panaflo for the rad.

Will post pics once I replace my board. Plugged the rpm fan header for the pump into my cpu fan header and board goes *BLIP* and FF on the diag :(
Reply With Quote
  #4 (permalink)  
Old September 15, 2008, 08:15 AM
Hall Of Fame
 
Join Date: Feb 2008
Location: Calgary, AB
Posts: 3,344
Default

How could you even think of murdering your board, I have 2 panaflos sitting :p
Reply With Quote
  #5 (permalink)  
Old September 15, 2008, 08:21 AM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,604
Default

Quote:
Originally Posted by miggs78 View Post
How could you even think of murdering your board, I have 2 panaflos sitting :p
how was I supposed to know that would kill the board :(
Reply With Quote
  #6 (permalink)  
Old September 15, 2008, 08:22 AM
3.0charlie's Avatar
3.0 "I kill SR2's" Charlie
F@H
 
Join Date: May 2007
Location: Laval, QC
Posts: 9,643

My System Specs

Default

Quote:
Originally Posted by enaberif View Post
Will post pics once I replace my board. Plugged the rpm fan header for the pump into my cpu fan header and board goes *BLIP* and FF on the diag :(
That shouldn't have been a problem. Your new Biostar died because of that?
__________________
Hydro-Quebec is salivating...
Reply With Quote
  #7 (permalink)  
Old September 15, 2008, 08:25 AM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,604
Default

Quote:
Originally Posted by 3.0charlie View Post
That shouldn't have been a problem. Your new Biostar died because of that?
hahaha well it was the last thing I did before anything.

The pump works well but it was a used pump so its hard to say if anything might be wrong on that wire
Reply With Quote
  #8 (permalink)  
Old September 15, 2008, 10:39 AM
Hall Of Fame
 
Join Date: Feb 2008
Location: Calgary, AB
Posts: 3,344
Default

Quote:
Originally Posted by enaberif View Post
how was I supposed to know that would kill the board :(
Oh my Curt is going in flames, easy my friend.. Its ok, it happens.. Now just don't do that with the new board.. What kind of pump was it anyways..
Reply With Quote
  #9 (permalink)  
Old September 15, 2008, 10:42 AM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,604
Default

Quote:
Originally Posted by miggs78 View Post
Oh my Curt is going in flames, easy my friend.. Its ok, it happens.. Now just don't do that with the new board.. What kind of pump was it anyways..
mcp350.

the pump is great and is quiet and will be keeping it for sure.
Reply With Quote
  #10 (permalink)  
Old September 15, 2008, 10:54 AM
Hall Of Fame
 
Join Date: Feb 2008
Location: Calgary, AB
Posts: 3,344
Default

Yeah it sure is a very nice pump, but I'll still suggest you to use a 3pin to pin molex for the pump, I just don't find it safe to connect anything like a pump or high voltage equipment to the board, it shorts it out. I remember back in my old job, we did that, and the board was actually producing smoke, we turned it off, and as soon as we tried to power it, only this time accopanying the smoke was the board getting toast with fire.. luckily there wasn't much to destroy the whole board.

I guess you RMA'd it to NCIX, do you when your getting a new one, should be fairly quick though, as you live close to the shop right.
Reply With Quote
Reply


Thread Tools
Display Modes