Go Back   Hardware Canucks > CASES & COOLING > Water Cooling

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old August 24, 2008, 09:05 PM
Banned
 
Join Date: Jul 2008
Location: Edmonton
Posts: 240
Default Antec 900 Water cooled....but need help



system specs

QX6700 at stock

but im getting insanely high temps, like 40-45 idle, and 60-70 on load. what might be wrong?
Reply With Quote
  #2 (permalink)  
Old August 24, 2008, 09:47 PM
CanadaRox's Avatar
Allstar
F@H
 
Join Date: Feb 2008
Location: Scarborough (Toronto)
Posts: 614
Default

I'd put my money on two things. Either, the block has poor contact with the core, or that waterblock can't handle the heatload. I know the original version of the DD block (looks like you have that one) is known for performing poorly on quads so if a remount doesn't fix the temps, I think you may need a better waterblock.
__________________
Project: Black and White
i7 920 D0 | 3 x 2GB DDR3 | EVGA X58 SLI LE
XFX 4890 | Corsair HX750 | Corsair Obsidian
Reply With Quote
  #3 (permalink)  
Old August 24, 2008, 10:28 PM
Banned
 
Join Date: Jul 2008
Location: Edmonton
Posts: 240
Default

its a mc-tdx.
Reply With Quote
  #4 (permalink)  
Old August 25, 2008, 12:33 AM
MpG's Avatar
MpG MpG is offline
Hall Of Fame
 
Join Date: Aug 2007
Location: Kitchener, ON
Posts: 3,144
Default

Almost certainly has to be bad contact. Check your TIM, feel free to post a shot of the block lifted for others to critique.

Also: The MC-TDX is an impingement-style waterblock, so it needs the water to enter and exit the right way. You have the radiator after the CPU block in your loop, right? Because otherwise, you've got backwards flow through the block.
__________________
i7 2600K | ASUS Maximus IV GENE-Z | 580GTX | Corsair DDR3-2133
Reply With Quote
  #5 (permalink)  
Old August 25, 2008, 01:59 AM
Cptn Vortex's Avatar
Hall Of Fame
F@H
 
Join Date: May 2007
Location: Vancouver
Posts: 3,755
Default

Can I see a pic from the back of your case? I sure hope you have your fans on your RAD properly installed......
__________________
The Vortex H20

Coolermaster ATCS 840 w Window panel
MSI Z77A-GD65
Intel i7 3770K @ 4.6GHZ 1.28v
Galaxy GTX 680 @ 1241MHZ
8GB Mushkin Blackline 1600MHZ 9-9-9-24 1.5v
Asus Xonar Essence STX
OCZ Z-Series GOLD 850W
2 x 128GB Corsair Force GT SATA3 SSD RAID0 :)
Acheiva Shimian Q270 Lite 2560x1440

Benq W500 Pojector.

Watercooling:
EK Supreme HF, EK FC GTX 680 Block, MCR320+Gelid Silent 12 Push/Pull, DD Pump, EK Multioption 100ml Res, EK Coolstream XT 220 RAD Gelid Wings Push/Pull.
Reply With Quote
  #6 (permalink)  
Old August 25, 2008, 10:14 AM
Banned
 
Join Date: Jul 2008
Location: Edmonton
Posts: 240
Default

Quote:
Originally Posted by MpG View Post
Almost certainly has to be bad contact. Check your TIM, feel free to post a shot of the block lifted for others to critique.

Also: The MC-TDX is an impingement-style waterblock, so it needs the water to enter and exit the right way. You have the radiator after the CPU block in your loop, right? Because otherwise, you've got backwards flow through the block.
yes, i got the rad after the block

Quote:
Originally Posted by Cptn Vortex View Post
Can I see a pic from the back of your case? I sure hope you have your fans on your RAD properly installed......
lol, and vortex was right, my fans were facing the wrong direction..
now i fixed it, idles at 30-35, load at 49-54.

also, will getting the apogee gtz make a big difference?
Reply With Quote
  #7 (permalink)  
Old August 25, 2008, 11:01 AM
Cptn Vortex's Avatar
Hall Of Fame
F@H
 
Join Date: May 2007
Location: Vancouver
Posts: 3,755
Default

Thats more like it....hehe
__________________
The Vortex H20

Coolermaster ATCS 840 w Window panel
MSI Z77A-GD65
Intel i7 3770K @ 4.6GHZ 1.28v
Galaxy GTX 680 @ 1241MHZ
8GB Mushkin Blackline 1600MHZ 9-9-9-24 1.5v
Asus Xonar Essence STX
OCZ Z-Series GOLD 850W
2 x 128GB Corsair Force GT SATA3 SSD RAID0 :)
Acheiva Shimian Q270 Lite 2560x1440

Benq W500 Pojector.

Watercooling:
EK Supreme HF, EK FC GTX 680 Block, MCR320+Gelid Silent 12 Push/Pull, DD Pump, EK Multioption 100ml Res, EK Coolstream XT 220 RAD Gelid Wings Push/Pull.
Reply With Quote
  #8 (permalink)  
Old August 25, 2008, 12:19 PM
Hall Of Fame
 
Join Date: Feb 2008
Location: Calgary, AB
Posts: 3,344
Default

It makes me wonder if Vortex and company stopped helping us, we'd be screwed.. Damn wonder how vortex figured it out without looking at the rad and tell us the fans were probably wrong. Its obvious most of us thought it was block not making proper contact, when Vortex was in a world of his own lol!!..
Reply With Quote
  #9 (permalink)  
Old August 25, 2008, 01:26 PM
Cptn Vortex's Avatar
Hall Of Fame
F@H
 
Join Date: May 2007
Location: Vancouver
Posts: 3,755
Default

Heh, well I already went over every other option with Andrew Lol..... I couldnt think of any other explanation.
__________________
The Vortex H20

Coolermaster ATCS 840 w Window panel
MSI Z77A-GD65
Intel i7 3770K @ 4.6GHZ 1.28v
Galaxy GTX 680 @ 1241MHZ
8GB Mushkin Blackline 1600MHZ 9-9-9-24 1.5v
Asus Xonar Essence STX
OCZ Z-Series GOLD 850W
2 x 128GB Corsair Force GT SATA3 SSD RAID0 :)
Acheiva Shimian Q270 Lite 2560x1440

Benq W500 Pojector.

Watercooling:
EK Supreme HF, EK FC GTX 680 Block, MCR320+Gelid Silent 12 Push/Pull, DD Pump, EK Multioption 100ml Res, EK Coolstream XT 220 RAD Gelid Wings Push/Pull.
Reply With Quote
  #10 (permalink)  
Old August 25, 2008, 11:25 PM
Banned
 
Join Date: Jul 2008
Location: Edmonton
Posts: 240
Default

yea, lol. thanks vortex and everyone. got a GTZ today, gonna see if i get better temps
Reply With Quote
Reply


Thread Tools
Display Modes