Go Back   Hardware Canucks > CASES & COOLING > Water Cooling

    
Reply
 
LinkBack Thread Tools Display Modes
  #11 (permalink)  
Old April 3, 2013, 07:56 PM
Hall Of Fame
 
Join Date: May 2011
Location: Calgary
Posts: 1,382

My System Specs

Default

I think mine might have just been worn out and I got hosed (buyer beware) Normally you only see compression fittings (of ANY kind) leak when their is pressure on the side of the fitting basically causing the rubber ring to lift off slightly. Which is what lowfat was suggesting. Marks fitting may just be faulty too.
__________________
__________________________________________________ __________
"Lesson's cost money... good ones costs lots" -Tony Beets (gold rush)
__________________________________________________ __________
Mah Rig now
Mah Rig before
My stuff for sale.
Reply With Quote
  #12 (permalink)  
Old April 3, 2013, 08:13 PM
Mark's Avatar
Allstar
 
Join Date: Sep 2008
Location: Bolton, Ontario
Posts: 859
Default

No, I was testing it for my new build. Luckily , since I wouldn't want a leak on my new Titan.
__________________



CHEERS

Last edited by Mark; April 4, 2013 at 01:58 AM.
Reply With Quote
  #13 (permalink)  
Old April 4, 2013, 03:43 PM
stephengillon's Avatar
Rookie
 
Join Date: Mar 2013
Location: fort frances, on
Posts: 32

My System Specs

Default

Quote:
Originally Posted by Mark View Post
ek WATERCOOLANT is non conductive
doesnt stay that way for long, soon as it starts touching the rads and blocks it changes, no matter how clean.

plus any dies will make a bad mess.

i soaked a motherboard once, would not work anymore. cleaned it multiple times with 99.9 alcohol and after a few months it started working again. i think it was mostly the dye tho messing with the cpu socket.
Reply With Quote
  #14 (permalink)  
Old April 5, 2013, 06:46 AM
Mark's Avatar
Allstar
 
Join Date: Sep 2008
Location: Bolton, Ontario
Posts: 859
Default

Too bad Zerex Supercoolant is no longer available. I had a bottle for 6 years on all the water builds I did and never had a single issue with corrosion or algae growth and all I used was 4 cap fulls on my rigs. Danger Den use to sell 4oz bottles for $3.50.
__________________



CHEERS
Reply With Quote
  #15 (permalink)  
Old April 5, 2013, 12:22 PM
mataribot's Avatar
Top Prospect
 
Join Date: Oct 2010
Posts: 77
Default

In a typical loop, there is no need for anything but distilled and bio.
Reply With Quote
  #16 (permalink)  
Old April 5, 2013, 02:49 PM
Mark's Avatar
Allstar
 
Join Date: Sep 2008
Location: Bolton, Ontario
Posts: 859
Default

what type of bio have you used ?
__________________



CHEERS
Reply With Quote
  #17 (permalink)  
Old April 6, 2013, 09:12 AM
stephengillon's Avatar
Rookie
 
Join Date: Mar 2013
Location: fort frances, on
Posts: 32

My System Specs

Default

Daz protector, bottle is abit small but good for 1 system or two smaller loops
Reply With Quote
  #18 (permalink)  
Old April 11, 2013, 01:56 PM
Mark's Avatar
Allstar
 
Join Date: Sep 2008
Location: Bolton, Ontario
Posts: 859
Default

Just used some Distilled water and a small cap and a half of wetter coolant. That bottle will last me years.
__________________



CHEERS
Reply With Quote
  #19 (permalink)  
Old April 14, 2013, 08:15 AM
Dazmode's Avatar
Hall Of Fame
 
Join Date: Mar 2009
Location: Oakville
Posts: 1,695
Default

Bad rotary, replace it. It happens quite rarely, but it happens. This why you have to perform leak test (preferably with distilled water to reduce mess).
__________________
Venom Build: Caselabs SMH10, 3930k, 2x GTX680, MSI BigBangII, 8x Dominators, 2 x D5 , Quad Rad, Adaptec 7805, 4x WD Red, 2x Intel 510, Aquaero 5, 11x GT
Silent Sniper Build: Final Video, XSPC H1 Cube case, Supreme HF, 2xGTX470, GA G1 Sniper, Dominators, 2x Triple rad, Triebwerk Fans, 2x D5, Custom Sleeving
Orange Build: Final Video
HTPC Build: Final Video
Reply With Quote
  #20 (permalink)  
Old April 20, 2013, 11:14 AM
Mark's Avatar
Allstar
 
Join Date: Sep 2008
Location: Bolton, Ontario
Posts: 859
Default

It's not repairable. Called the company, sent pics and info and they never responded. I can deal with product problems but I cannot deal with companies that do not respond to issues.

Last time I order anything from Bitzpower.
__________________



CHEERS
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
FrozenQ res leak jibz Water Cooling 3 January 10, 2012 06:11 PM
EK multioption Res X2 leak mataribot Water Cooling 15 October 28, 2010 07:58 PM
Gamergrub Contest Leak ziikutv Rumor Mill 1 December 4, 2009 07:32 PM
i got a LEAK! kyle_L Water Cooling 9 May 1, 2009 05:10 AM
Leak in T-line Phobia Water Cooling 17 June 9, 2008 04:37 PM