Go Back   Hardware Canucks > CASES & COOLING > Water Cooling

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old April 19, 2011, 06:41 PM
Top Prospect
 
Join Date: Mar 2011
Posts: 106
Default Damn.. i am so lucky -_- (problem with rasa waterblock)

One of the cpu waterblock (XSPC rasa kit) mounting screws doesn't fit in any of the holes of the plate.

Any suggestion ?

Thanks,
Attached Images
   

Last edited by Rush; April 19, 2011 at 07:29 PM.
Reply With Quote
  #2 (permalink)  
Old April 20, 2011, 02:31 AM
Top Prospect
 
Join Date: Oct 2010
Location: Calgary
Posts: 150

My System Specs

Default

One suggestion Rush...send these photos to XSPC and have them send you a new set of mounting screws for the backplate.

Man; I've never seen one guy have so many (quality) issues with one kit, hope this ends well for you
__________________
" If I had a dollar for every time I heard "My God! He's covered in some sort of goo, " I'd be a rich man. "

Homer J. Simpson
Reply With Quote
  #3 (permalink)  
Old April 20, 2011, 06:26 AM
Top Prospect
 
Join Date: Mar 2011
Posts: 106
Default

Yeah that what i did, they gonna send me a set of mounting screws for the backplate. Oh man that doesn't count the problems i had with motherboard case standoffs lol one had not thread i had to go to a shop and get one.. combined with a plastic cap.. since the height was different. I just hope my system will start after i plug everything lol
Reply With Quote
  #4 (permalink)  
Old April 20, 2011, 03:10 PM
Banned
 
Join Date: Jul 2008
Location: Edmonton
Posts: 240
Default

mayb e its not going to :(
then u have to drain your loop and send it back in for RMA :(:(
Reply With Quote
  #5 (permalink)  
Old April 20, 2011, 03:43 PM
lowfat's Avatar
Moderator
 
Join Date: Feb 2007
Location: Grande Prairie, AB
Posts: 8,071

My System Specs

Default

You could always use a couple of zipties possibly in the meantime. Although the problems you are having w/ your block aren't anywhere what I went through w/ my Rasa. When I received mine it came w/ AMD mounting instead of Intel. Performance PC's mailed me Intel brackets but they forgot the main mounting plate. So they had to ship that out. It took over two months from the time I ordered it till I was able to use it.
__________________
Mael
Big Lian Li
Forever Alone
Reply With Quote
  #6 (permalink)  
Old April 26, 2011, 05:35 AM
Top Prospect
 
Join Date: Mar 2011
Posts: 106
Default

Update: got my replacement set from XSPC. Its alright now the screws fit perfectly lol was definitivly a problem with them.. so now i can finish my build. Hope no more problems to come.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
RASA 750 pump/res is rattling ? *updated* Rush Water Cooling 17 April 19, 2011 04:06 AM
Water block upgrade from XSPC RASA kit rugox Water Cooling 5 April 10, 2011 09:48 PM
Rasa 450 RS120 vs Rasa 750 RS240 Rush Water Cooling 8 March 29, 2011 11:28 AM
Some people are so lucky... Sushi Warrior Hockey 11 September 30, 2009 03:16 PM
Sometimes you just get lucky Nodscene O/S's, Drivers & General Software 3 August 18, 2009 01:39 PM