Go Back   Hardware Canucks > CASES & COOLING > Water Cooling

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old January 18, 2009, 09:04 AM
Sniper's Avatar
Allstar
 
Join Date: May 2008
Location: Halifax NS
Posts: 700
Default lol fried pump action.

So I had my pump running with my TO res only to see the center turning for shits & giggles. It's all set up & running on my desk then I smell smoke. I was like wtf! I look over & the pump is smoking from the base lol. Somehow water got into the base of it & fried the pump? No idea how or whatever but it was wet in there. Luckily it was only the spare I got off here. It will be replaced with a new mcp355 in the next week or so I think.
Reply With Quote
  #2 (permalink)  
Old January 18, 2009, 09:44 AM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,814

My System Specs

Default

Maybe the o-ring failed? Sucks none the less but at least it was only a spare.
Reply With Quote
  #3 (permalink)  
Old January 18, 2009, 11:29 AM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,472
Default

Quote:
Originally Posted by Sniper View Post
So I had my pump running with my TO res only to see the center turning for shits & giggles. It's all set up & running on my desk then I smell smoke. I was like wtf! I look over & the pump is smoking from the base lol. Somehow water got into the base of it & fried the pump? No idea how or whatever but it was wet in there. Luckily it was only the spare I got off here. It will be replaced with a new mcp355 in the next week or so I think.
I'm confused did you run it with or without water?

If it did have water sounds like a failed o-ring or improper install.
Reply With Quote
  #4 (permalink)  
Old January 18, 2009, 12:51 PM
Sniper's Avatar
Allstar
 
Join Date: May 2008
Location: Halifax NS
Posts: 700
Default

Kinda hard to screw up one of these pumps. It was just set up pn my desk running wasn't much to install lol. It was not run dry full & properly bled. Ah well I now have a $60 BitsPower res top lol.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
UPS in action Squeetard Off Topic 21 January 5, 2009 01:57 PM
Reboot = Fried Ram Evilyeti RAM 2 November 17, 2008 05:58 AM
Digital Democracy in Action sswilson Off Topic 17 July 15, 2008 07:40 AM
Act of War: Direct Action lcdguy Gaming 1 July 8, 2007 06:49 PM
Barcelona in Action Babrbarossa CPU's and Motherboards 1 May 11, 2007 01:20 PM