Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old August 31, 2008, 04:26 AM
Rookie
 
Join Date: Aug 2008
Posts: 40
Default pci express

Hello

I have just finished building my PC,when i tried to start nothing comes on the screnn although the lcd posters indicates "welcome".

The thing that i would like to ask is,if there is anything wrong with my graphics card.It is a pci express card on a pci express 2.0 slot.Is there anything wrong with it?

I will be getting my 280 gtx this monday and i hope this will work with my pci express 2.0 slot.

Please let me know if pci express can run in apci exprss 2.0 slot or not.

Mike
Reply With Quote
  #2 (permalink)  
Old August 31, 2008, 05:07 AM
sswilson's Avatar
Moderator
F@H
 
Join Date: Dec 2006
Location: Moncton NB
Posts: 16,850

My System Specs

Default

More info please....

Motherboard / GFX /PSU at the very least. :)
__________________
Gigabyte Z97N-WIFI / i7 4770K / 2X 8G Gskill 1866 Sniper / XFX XTR 750 / EVGA GTX 970 SSC ACX 2.0+
AZZA Titan 240 / Custom WC / Intel 730 Series 480GB SSD / Seagate Barracuda 1TB / Dell UltraSharp U2412M

Asrock AM1H-ITX / AM1 Athlon 5350 / 1X4G Gskill PC3-14900 / Intel 6235 Wi-Fi / 90W Targus Power Brick / Uncased 256GB Sandisk Z400S SSD / Mini-Box M350 / 24" Westinghouse L2410NM
Reply With Quote
  #3 (permalink)  
Old August 31, 2008, 07:05 AM
Dwayne's Avatar
Allstar
F@H
 
Join Date: Aug 2008
Location: Courtenay, BC
Posts: 747

My System Specs

Default

I am pretty sure the PCI Express 2.0 slots are backward compatible... only makes sense. You should post in the Troubleshooting forum, or better yet have a read of some of the threads on dead computer builds there... lots of good advice and happy computer builders when they find the connector they didn't install, or reseat the connections and it all works fine!

http://www.hardwarecanucks.com/forum...t-working.html

New build troubleshooting

Black screen !!! Need Help
__________________
Dwayne's Rig - Asus Prime Z370-A : i3 8100 : Corsair Vengeance 32 GB DDR4-3000 : Corsair RM650x PSU : Corsair H100i V2: Fractal Design Meshify C : EVGA GTX 1080 :
HTPC - GigaByte H67MA-UD2H : i3 2100 : 8 GB Mushkin Silverline Stiletto : Antec TruPower 550W : : Corsair H100 : Sapphire HD 6670 : Corsair 650D: Kingston 60 GB SSD Boot
Tablet - Samsung Tab A 10.1"
Wife's Rig - MSI GL72M 7RDX
Reply With Quote
  #4 (permalink)  
Old August 31, 2008, 08:02 AM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,890
Default

Quote:
Originally Posted by evzonas View Post
Hello

I have just finished building my PC,when i tried to start nothing comes on the screnn although the lcd posters indicates "welcome".

The thing that i would like to ask is,if there is anything wrong with my graphics card.It is a pci express card on a pci express 2.0 slot.Is there anything wrong with it?

I will be getting my 280 gtx this monday and i hope this will work with my pci express 2.0 slot.

Please let me know if pci express can run in apci exprss 2.0 slot or not.

Mike
Open motherboard box, take out manual, read manual then come back.
Reply With Quote
Reply


Thread Tools
Display Modes