Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old August 31, 2008, 04:26 AM
Rookie
 
Join Date: Aug 2008
Posts: 40
Default pci express

Hello

I have just finished building my PC,when i tried to start nothing comes on the screnn although the lcd posters indicates "welcome".

The thing that i would like to ask is,if there is anything wrong with my graphics card.It is a pci express card on a pci express 2.0 slot.Is there anything wrong with it?

I will be getting my 280 gtx this monday and i hope this will work with my pci express 2.0 slot.

Please let me know if pci express can run in apci exprss 2.0 slot or not.

Mike
Reply With Quote
  #2 (permalink)  
Old August 31, 2008, 05:07 AM
sswilson's Avatar
Moderator
F@H
 
Join Date: Dec 2006
Location: Moncton NB
Posts: 14,638

My System Specs

Default

More info please....

Motherboard / GFX /PSU at the very least. :)
__________________
MSI Z87I Gaming AC / i7 4770K / 2X 4G Gskill 1866 DDR3 / XFX XTR 750 / EVGA GTX 680 SC+ 2GB / Intel DC S3700 200G / random 160G Sata HDD
Inwin 904 / Swiftech MCP655-b / Alphacool NexXxos XT45 120 Rad / 2X Scythe GT AP-15 / EK Supreme HF / Dell UltraSharp U2412M

Asrock AM1H-ITX / AM1 Athlon 5350 / 2X4G Gskill PC3-14900 / Intel 6235 Wi-Fi / 90W Targus Power Brick / 320G Seagate Momentus / Mini-Box M350 / 1X 22" Dell IPS / 1X 22" HP
Reply With Quote
  #3 (permalink)  
Old August 31, 2008, 07:05 AM
Dwayne's Avatar
Allstar
F@H
 
Join Date: Aug 2008
Location: Courtenay, BC
Posts: 619

My System Specs

Default

I am pretty sure the PCI Express 2.0 slots are backward compatible... only makes sense. You should post in the Troubleshooting forum, or better yet have a read of some of the threads on dead computer builds there... lots of good advice and happy computer builders when they find the connector they didn't install, or reseat the connections and it all works fine!

http://www.hardwarecanucks.com/forum...t-working.html

New build troubleshooting

Black screen !!! Need Help
__________________
Dwayne's Rig - Asus P8Z77 : i7 3770k : Corsair Vengeance 8 GB DDR3-1600 : Corsair HX850W PSU : Corsair H100 : Corsair Obsidian 650D : eVGA GeForce GTX 680 Classy :
HTPC - GigaByte H67MA-UD2H : i3 2100 : 8 GB Mushkin Silverline Stiletto : Antec TruPower 550W : Sapphire HD 6670 : Nmedia HTPC 1000B : Kingston 60 GB SSD Boot
Netbook - Asus eee
Tablet - Asus eee Transformer
Wife's Rig - Lenovo Laptop
Reply With Quote
  #4 (permalink)  
Old August 31, 2008, 08:02 AM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,637
Default

Quote:
Originally Posted by evzonas View Post
Hello

I have just finished building my PC,when i tried to start nothing comes on the screnn although the lcd posters indicates "welcome".

The thing that i would like to ask is,if there is anything wrong with my graphics card.It is a pci express card on a pci express 2.0 slot.Is there anything wrong with it?

I will be getting my 280 gtx this monday and i hope this will work with my pci express 2.0 slot.

Please let me know if pci express can run in apci exprss 2.0 slot or not.

Mike
Open motherboard box, take out manual, read manual then come back.
Reply With Quote
Reply


Thread Tools
Display Modes