Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old June 9, 2008, 10:12 AM
encorp's Avatar
Hall Of Fame
F@H
 
Join Date: Apr 2008
Location: Toronto
Posts: 3,425

My System Specs

Default Best Drivers for 8800GT

What do you guys recommend as the best drivers for an 8800GT?

Are tweaked drivers better than recent beta etc?
__________________
DISCLAIMER: The views and opinions expressed in the immediately preceding post are those of encorp and do not reflect the views and/or opinions of family, friends, or anyone remotely associated with encorp unless explicitly stated. encorp does not make any warranty, express or implied, or assumes any liability or responsibility for the quality, factuality or use of information in the immediately preceding post.
Reply With Quote
  #2 (permalink)  
Old June 9, 2008, 01:09 PM
SKYMTL's Avatar
HardwareCanuck Review Editor
 
Join Date: Feb 2007
Location: Montreal
Posts: 11,651
Default

Latest WHQL have been working OK for me but they suck pretty hard in CoH DX10 and if you are using a GX2.
Reply With Quote
  #3 (permalink)  
Old June 9, 2008, 08:18 PM
CanadaRox's Avatar
Allstar
F@H
 
Join Date: Feb 2008
Location: Scarborough (Toronto)
Posts: 614
Default

I personally prefer the modified drivers from tweakforce.com. They will usually preform at least as well as the WHQL drivers, often better, and always have better image quality. I'm currently using their 169.61 drivers, but will be installing 175.63 when I get around to it. I've never had a problem with these drivers (excluding problems I've had with official, modded and beta drivers).
__________________
Project: Black and White
i7 920 D0 | 3 x 2GB DDR3 | EVGA X58 SLI LE
XFX 4890 | Corsair HX750 | Corsair Obsidian
Reply With Quote
  #4 (permalink)  
Old June 9, 2008, 10:28 PM
encorp's Avatar
Hall Of Fame
F@H
 
Join Date: Apr 2008
Location: Toronto
Posts: 3,425

My System Specs

Default

Thanks for the replies, I've used those modded drivers before - I just wasn't sure if they were really better lol!
__________________
DISCLAIMER: The views and opinions expressed in the immediately preceding post are those of encorp and do not reflect the views and/or opinions of family, friends, or anyone remotely associated with encorp unless explicitly stated. encorp does not make any warranty, express or implied, or assumes any liability or responsibility for the quality, factuality or use of information in the immediately preceding post.
Reply With Quote
  #5 (permalink)  
Old June 10, 2008, 10:45 PM
burebista's Avatar
Allstar
 
Join Date: Sep 2007
Location: Romania
Posts: 598

My System Specs

Default

I'm with Omega 169.25. Vista64 SP1, everything is fine.
Reply With Quote
Reply


Thread Tools
Display Modes