Go Back   Hardware Canucks > HARDWARE > Video Cards

LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old September 26, 2014, 05:24 PM
Join Date: Sep 2014
Posts: 3
Default Problem with my GPU

Hi guys!
I'm having trouble with my new GPU (R9 280x). Long story short. Last month I bought the GPU, but couldn't use it because I had a shitty PSU. So today I bought a new PSU (Antec High Current Gamer 750w) and I connected the new GPU. First boot is ok, used to have catalyst, so no big deal about drivers. But when I opened a game it crashed before it even started.
Then I restarted the PC, but I couldn't boot past windows 8 logo. When Windows 8 user password screen should come, my screens starts blinking.
I tried using the onboard gpu, and everything is fine. Tried uninstalling AMD drivers, but got same results. Don't know what else to try!
Reply With Quote
  #2 (permalink)  
Old September 26, 2014, 06:14 PM
TTC TTC is offline
Top Prospect
Join Date: Mar 2014
Posts: 139

You sure its seated correctly in the slot? You have both plugs in to power it?
Reply With Quote
  #3 (permalink)  
Old September 26, 2014, 06:42 PM
Bond007's Avatar
Hall Of Fame
Join Date: Jun 2009
Location: Down under
Posts: 3,699

My System Specs


Uninstall all video drivers, run driver sweeper to clean any remaining. Reinstall drivers.

Sounds like a driver issue.

Otherwise you could try a clean install of windows.
Desktop: Arc Midi R2, Z77-D3H, 3570K 1.09v/4.1ghz with Zalman Optima Cooler, Corsair Vengeance 2x4gb@1866mhz, XFX R9 280X DD, Bitfenix Fury 750w, WD Black 1TB, Intel 530 120GB
Away from home light Gamer: Acer Aspire 15.6", A8-3500m undervolt and OC to 2Ghz, 2x4gb Corsair Vengeance, Crucial M500 240gb
Reply With Quote
  #4 (permalink)  
Old September 26, 2014, 08:45 PM
Join Date: Sep 2014
Posts: 3

Solved! Was driver problem.. had to uninstall in safe mode, thx anyways for your help!
Reply With Quote

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Could a hardware problem cause a driver problem? LaughingCrow Troubleshooting 4 January 19, 2012 11:46 AM
Steam connection problem (Problem Fixed) great_big_abyss Gaming 3 January 10, 2012 05:37 PM
Hard drive problem or Windows 7 Problem?! aeminence New Builds 4 October 13, 2011 06:46 AM
could this be a game problem or a video driver problem? Shadowmeph Troubleshooting 4 December 17, 2010 07:01 AM
Hardware problem or HAL problem? andynerd Troubleshooting 1 March 7, 2009 09:03 PM