Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #21 (permalink)  
Old November 21, 2013, 10:17 AM
"Quote This..."
F@H
 
Join Date: Nov 2007
Location: Hell
Posts: 3,833
Default

Quote:
Originally Posted by enaberif View Post
lol why is this conversation still going? OP you screwed up and you want to blame EVGA? Shame shame.
This.

That said, I've had 2 evga rma's and they both were awful. I'll never own another evga product as well.
Reply With Quote
  #22 (permalink)  
Old November 21, 2013, 10:19 AM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,679
Default

Quote:
Originally Posted by Squeetard View Post
This.

That said, I've had 2 evga rma's and they both were awful. I'll never own another evga product as well.
I agree there are companies who will just give a bad experience regardless of circumstance. But when your at fault and your going to blame the company? Sheesh. You going to sue for hot coffee next?
Reply With Quote
  #23 (permalink)  
Old November 21, 2013, 03:42 PM
KaptCrunch's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Ontario
Posts: 2,970
Default a community advertisement not to get a head eche

Quote:
Originally Posted by enaberif View Post
lol why is this conversation still going? OP you screwed up and you want to blame EVGA? Shame shame.
heads up on bad move by me send all your cards back in factory condition to any manafactor

if lost screws send separate or individually wrapped not have issues

enaberif: that's what this thread about not like laugh @ a dumb move not blaming evga but something not right

draemn: you go claim for an car accident with no exterior damage, insurance will laugh
Reply With Quote
  #24 (permalink)  
Old November 21, 2013, 04:22 PM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,679
Default

Quote:
Originally Posted by KaptCrunch View Post
heads up on bad move by me send all your cards back in factory condition to any manafactor

if lost screws send separate or individually wrapped not have issues

enaberif: that's what this thread about not like laugh @ a dumb move not blaming evga but something not right

draemn: you go claim for an car accident with no exterior damage, insurance will laugh
Your thread title implies that EVGA screwed up somehow. The thread title should show that YOU screwed up by lack of due diligence.
Reply With Quote
  #25 (permalink)  
Old November 21, 2013, 06:15 PM
KaptCrunch's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Ontario
Posts: 2,970
Default

Quote:
Originally Posted by enaberif View Post
Your thread title implies that EVGA screwed up somehow. The thread title should show that YOU screwed up by lack of due diligence.
Reply With Quote
  #26 (permalink)  
Old November 21, 2013, 06:45 PM
Sagath's Avatar
Hall Of Fame
F@H
 
Join Date: Feb 2009
Location: Petawawa, ON
Posts: 2,589

My System Specs

Default

Quote:
Originally Posted by KaptCrunch View Post
Quote:
Originally Posted by enaberif View Post
Your thread title implies that EVGA screwed up somehow. The thread title should show that YOU screwed up by lack of due diligence.
Just because you made note that you packed it like a retard doesnt make it EVGA's fault that YOU PACKED IT BADLY.
__________________
Quote:
Originally Posted by Lpfan4ever View Post
AKG shot the hamsters, and then Perineum drove his Mustang with summer tires into the server.
My Disclaimer to any advice or comment I make;
Quote:
Originally Posted by CroSsFiRe2009 View Post
I'm a self certified whizbang repair technician with 20 years of professional bullshit so I don't know what I'm talking about
Reply With Quote
  #27 (permalink)  
Old November 21, 2013, 08:56 PM
KaptCrunch's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Ontario
Posts: 2,970
Default

would be more damage then 2 parts depic'd if was poorly packed ......where all the rubbing and scratching marks, the paste tells the story

notice gpu north side and south side ........now plot your flight path if parts moved , on heat sink south has excess and gpu has north , least on gpu south and north HS

Reply With Quote
  #28 (permalink)  
Old November 21, 2013, 09:58 PM
Hall Of Fame
 
Join Date: May 2011
Location: Calgary
Posts: 1,491

My System Specs

Default

dude even if the paste is somehow rubbed in a different area that means very little. That paste rubs off on anything instantly with very little effort.
It could have rubbed off just un wrapping it.
You probably shouldn't have shipped it with the heatsink just resting on the video card
You probably should have wrapped them separately
Vibrations could have easily knocked off one of those little resistors.
Pack your boxes like someone is gonna use it like a football or at the very least have the shipper put fragile stickers all over it.

Me I pack shit for punting from the 30 yard line and I have still had things destroyed and covered by shipping insurance. Go after the shipper not EVGA... simply unwrapping that video card would more than likely NOT cause any damage.

Pay the 45 dollars and chalk it up as a learning experience... nuff said.
__________________
__________________________________________________ __________
"Lesson's cost money... good ones costs lots" -Tony Beets (gold rush)
__________________________________________________ __________
Mah Rig now
Mah Rig before
My stuff for sale.
Reply With Quote
  #29 (permalink)  
Old November 21, 2013, 11:05 PM
sf101's Avatar
MVP
 
Join Date: Jun 2012
Posts: 327
Default

your fault . be happy it only cost 45$.

also when you remove a heatsink for waterblock's its quite easy to just screw the remaining screws back into the block so they don't get lost.

lesson learned for next time.

I also tend to wonder what the problem was with this card in the first place? perhaps the resistors were damaged before shipping?
__________________
My 5 Current Rigs-Guest-Main-Work/Spare-HTPC-Laptop
I7930@4.0GHz-Guest
3770K@ 4.8GHz -Main
2500k @ 4.7GHz -work/Spare
3570K @ 4.5 -HTPC
MSI GT70-2OC/770m-998/4800MHz -Laptop
SF101 HW BOT
GPU's ("xfire"2x XFX290X@1150/1500"EKWB"|GIGAOC7970WF3@1250/1850|Asus480GTX@900/2000|
2xEvga260Core216's SLI in HTPC-Retired gpu's 9600ati|9800proATI|8800GTS"320mb&640mb"
|8800GTX|9800GT|9800GX2
Reply With Quote
  #30 (permalink)  
Old November 22, 2013, 09:01 AM
"Quote This..."
F@H
 
Join Date: Nov 2007
Location: Hell
Posts: 3,833
Default

Quote:
Originally Posted by sf101 View Post

also when you remove a heatsink for waterblock's its quite easy to just screw the remaining screws back into the block so they don't get lost.
Common sense. I learned that in mechanics. Just too much extra work for some.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
This happen to anyone else? (directcanada) Jake_HT Off Topic 4 September 22, 2011 07:07 PM
if you happen to unfortunately be in the cdn area.. _dangtx_ Off Topic 17 August 28, 2010 08:25 PM
HST might not happen in BC... jcmaz Off Topic 32 May 31, 2010 10:23 PM
Why does this happen? appplejack RAM 3 December 21, 2008 07:43 AM
Did something happen to conky? sheepdogexpress Suggestions & Feedback 21 November 11, 2008 05:23 PM