Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old January 7, 2013, 02:48 PM
Top Prospect
 
Join Date: Nov 2011
Location: The netherlands
Posts: 52
Default Gtx 670 driver problem "Very strange"

Hello guys,

I got this weird problem what ive never had before with my earlier graphic cards...
but this is what the problem is...

I use the 306.97 drivers
now maybe you ask why arent you using the latest drivers for the gtx 670...
well thats the problem
there was a new driver 310.70 ... I installed it and then when I start my game Medal of Honor warfighter or battlefield 3 it crashes immediatly when I am in a server or when single player starts...
now you have the 310.90 drivers so I thought I give it another shot... because it is a newer one and then again the same problem...


but the strange thing was... I could play with those newer drivers the game assassins creed 3 what is very strange... I cant say its the game that makes this problem for me because a friend of my that lives far away so we cant switch gpu's ... but we have the same gpu ( GTX 670 ) and he has the latest drivers and for him it works all well


so whats this weird issue?

I changed the driver back to 306.97 and gaming goes FINE!!!

but still I want this solved.. do I need to go and send it back where I bought it or does anyone of you guys has a solution for this


I hope many responses


thank you
Reply With Quote
  #2 (permalink)  
Old January 7, 2013, 04:20 PM
BradM's Avatar
Rookie
 
Join Date: Aug 2012
Location: Peterborough Ontario
Posts: 34

My System Specs

Default

When you install new updates and go through that process do u click perform a clean installation of all the drivers, because sometimes if you don't do that it wont work, i have had problems where i couldn't use anything like the nvidia control panel or play games because i didn't do a clean installation process of the update. Thats the only thing i could think of, if thats not the problem maybe contact nvidia or who ever could help you.
Reply With Quote
  #3 (permalink)  
Old January 7, 2013, 04:33 PM
Sagath's Avatar
Hall Of Fame
F@H
 
Join Date: Feb 2009
Location: Petawawa, ON
Posts: 2,479

My System Specs

Default

The card does not appear broken since it is still playing some games fine and works with the 306.97 drivers, so sending it back will not fix the issues I suspect. This appears to be an updated driver issue of some sort. As the previous poster said, try and check "Clean Install" when putting the new drivers in. This should solve any issues.

If the clean install method doesnt work through the installer, try this:

1. Boot into safe-mode
2. Unninstall driver from device manager
3. Boot into Windows
4. Reinstall the new driver with "Clean Installation" checked.
__________________
Quote:
Originally Posted by Lpfan4ever View Post
AKG shot the hamsters, and then Perineum drove his Mustang with summer tires into the server.
My Disclaimer to any advice or comment I make;
Quote:
Originally Posted by CroSsFiRe2009 View Post
I'm a self certified whizbang repair technician with 20 years of professional bullshit so I don't know what I'm talking about
Reply With Quote
  #4 (permalink)  
Old January 7, 2013, 04:39 PM
Top Prospect
 
Join Date: Nov 2011
Location: The netherlands
Posts: 52
Default

Quote:
Originally Posted by Sagath View Post
The card does not appear broken since it is still playing some games fine and works with the 306.97 drivers, so sending it back will not fix the issues I suspect. This appears to be an updated driver issue of some sort. As the previous poster said, try and check "Clean Install" when putting the new drivers in. This should solve any issues.

If the clean install method doesnt work through the installer, try this:

1. Boot into safe-mode
2. Unninstall driver from device manager
3. Boot into Windows
4. Reinstall the new driver with "Clean Installation" checked.

im not sure if I have done CLEAN INSTAL but I don't think so, so I give it a try...
I let you guys know !


thanks
Reply With Quote
  #5 (permalink)  
Old January 7, 2013, 05:07 PM
Top Prospect
 
Join Date: Nov 2011
Location: The netherlands
Posts: 52
Default

Quote:
Originally Posted by Sagath View Post
The card does not appear broken since it is still playing some games fine and works with the 306.97 drivers, so sending it back will not fix the issues I suspect. This appears to be an updated driver issue of some sort. As the previous poster said, try and check "Clean Install" when putting the new drivers in. This should solve any issues.

If the clean install method doesnt work through the installer, try this:

1. Boot into safe-mode
2. Unninstall driver from device manager
3. Boot into Windows
4. Reinstall the new driver with "Clean Installation" checked.

I have tried it, NO SUCCES :(

also the save mode etc. removed EVERYTHING ...
Reply With Quote
  #6 (permalink)  
Old January 7, 2013, 05:29 PM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,575
Default

What board and power supply you using?
Reply With Quote
  #7 (permalink)  
Old January 7, 2013, 11:43 PM
Top Prospect
 
Join Date: Nov 2011
Location: The netherlands
Posts: 52
Default

Quote:
Originally Posted by enaberif View Post
What board and power supply you using?
MSI Gd55 z77 and ms-tech 750w... but that can't be the problem?
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why do people get "display driver stopped working..." ern88 Video Cards 21 January 8, 2014 07:04 AM
strange "all closed ports" problem CTA Troubleshooting 0 March 26, 2011 11:42 PM
HP Pavilion Laptop (stuck on "GPRS CARD-B" Driver..) GameOnTurtle O/S's, Drivers & General Software 3 October 14, 2010 11:08 AM
Strange "Copy Protection" problem Bullterrier Gaming 6 December 9, 2009 04:31 AM
"Display driver stopped responding and has recovered" (Epic Length) tehgooch Troubleshooting 10 May 9, 2008 05:34 AM