Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old December 10, 2012, 01:47 PM
Top Prospect
 
Join Date: Nov 2012
Location: Vancouver Island
Posts: 61

My System Specs

Default New 7970...already Dead? :angry2:

Like the title says, I believe I may have a faulty card.In firefall Sleeping Dogs and Dirt Showdown i see screen tearing and artifacts, and if I OC any farther then 1000 mhz on the gpu it crashes....memory can only go far as 1400 then crashing (975/1375 is stock). My specs are in my sig.
Reply With Quote
  #2 (permalink)  
Old December 10, 2012, 01:57 PM
SKYMTL's Avatar
HardwareCanuck Review Editor
 
Join Date: Feb 2007
Location: Montreal
Posts: 11,835
Default

Is it stable at stock speeds?
__________________
Reply With Quote
  #3 (permalink)  
Old December 10, 2012, 02:15 PM
Top Prospect
 
Join Date: Nov 2012
Location: Vancouver Island
Posts: 61

My System Specs

Default

stock is stable is in no crashes but the tearing and artifacts appear after about 30 minutes of gaming.Temps sit at max 71C but average at 68C
Reply With Quote
  #4 (permalink)  
Old December 10, 2012, 02:30 PM
dandelioneater's Avatar
Hall Of Fame
F@H
 
Join Date: Dec 2010
Location: Kelowna, BC
Posts: 1,114

My System Specs

Default

Have you tried enabling vsync in game to try and clear up the tearing? What games? Driver version?
__________________
Reply With Quote
  #5 (permalink)  
Old December 10, 2012, 02:42 PM
BeaverBender's Avatar
MVP
F@H
 
Join Date: Feb 2012
Location: Montreal
Posts: 260

My System Specs

Default

I'm wondering if there is a bad batch out there. A couple of my friends recently purchased 7970's and are having similar issues. What was the manufacturer?
__________________
Creationists make it sound like a ‘theory’ is something you dreamt up after being drunk all night — Isaac Asimov
All thinking men are atheists — Ernest Hemingway
Faith means not wanting to know what is true — Friedrich Nietzsche


Reply With Quote
  #6 (permalink)  
Old December 10, 2012, 03:00 PM
Rookie
 
Join Date: Dec 2012
Posts: 12
Default Usual driver thing!

Same happened with Skyrim (bad artifacts and tearing)until they released a driver update and work around for it.

My only complaint with ATI is this seems to be a constant, they seem to release cards prematuraly and give us users driver headaches. Other than that they're a great card.
Reply With Quote
  #7 (permalink)  
Old December 10, 2012, 03:18 PM
Top Prospect
 
Join Date: Nov 2012
Location: Vancouver Island
Posts: 61

My System Specs

Default

Xfx Double D driver version 12.10, happens in Sleeping Dogs ,Firefall and Dirt Showdown
Reply With Quote
  #8 (permalink)  
Old December 10, 2012, 03:27 PM
great_big_abyss's Avatar
Hall Of Fame
F@H
 
Join Date: Oct 2011
Location: Winnipeg
Posts: 2,210

My System Specs

Default

Upgrade to 12.11 beta

AMD Catalyst? 12.11 Beta Driver
__________________



HTPC: Z77A-G45; 3770K; Coolermaster GeminII; 2x4GB Kingston HyperX 1600Mhz; MSI R7-260X; 2x 128GB Crucial M4 SSD; 1TB WD Green, 2x 2TB WD Green; PC P&C 750W PS; Fractal Design Node 605;
Son's Rig: M5A97; 1055T; CNPS20LQ; 2x4GB Corsair Vengeance 1600Mhz; ASUS GTX650Ti Boost; 80GB Intel 520 SSD; 320GB WD Black HDD; SPI 700W; Bitfenix Shinobi;
Reply With Quote
  #9 (permalink)  
Old December 10, 2012, 03:52 PM
Top Prospect
 
Join Date: Nov 2012
Location: Vancouver Island
Posts: 61

My System Specs

Default

Funny thing is i had Beta 12.11 before and it was worse....with 12.10 i get 30minutes up to an hour before it tears and artifacts.
Reply With Quote
  #10 (permalink)  
Old December 10, 2012, 05:07 PM
sswilson's Avatar
Moderator
F@H
 
Join Date: Dec 2006
Location: Moncton NB
Posts: 14,793

My System Specs

Default

Quote:
Originally Posted by HoserEh View Post
Funny thing is i had Beta 12.11 before and it was worse....with 12.10 i get 30minutes up to an hour before it tears and artifacts.
Have you tried running some form of GPU stress test to see if you can reliably duplicate the issue? Furmark still works, but IIRC you have to chose a non-default test otherwise the driver recognises is as a stress test program and drops the power use down (that might only be with Nvidia though).

I had to do something similar with an old sapphire 1950pro. I had it down to where I could pretty well guarantee that the test would failr within a 5 minute window and when I presented my findings to the retailer they just replaced it straigtht out with one of the newer versions (improved VRM to prevent overheating issues, but Sapphire never admitted fault).
__________________
MSI Z87I Gaming AC / i7 4770K / 2X 8G Gskill 1866 Sniper / XFX XTR 750 / EVGA GTX 680 SC+ 2GB / Intel DC S3700 200G / Seagate Barracuda 1TB
Inwin 904 / Swiftech MCP655-b / Alphacool NexXxos XT45 120 Rad / 2X Scythe GT AP-15 / EK Supreme HF / Dell UltraSharp U2412M

Asrock AM1H-ITX / AM1 Athlon 5350 / 2X4G Gskill PC3-14900 / Intel 6235 Wi-Fi / 90W Targus Power Brick / 250G Samsung 840 Series SSD / Mini-Box M350 / 1X 22" Dell IPS / 1X 22" HP
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
4870 512, dead but not dead TerenceJ Video Cards 9 January 11, 2010 05:22 PM
680i DEAD DEAD DEAD sizerkozak CPU's and Motherboards 29 February 9, 2007 10:08 PM