Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Video Cards (http://www.hardwarecanucks.com/forum/video-cards/)
-   -   6670 Memory clock problems (http://www.hardwarecanucks.com/forum/video-cards/56934-6670-memory-clock-problems.html)

hiller741 September 26, 2012 07:20 AM

6670 Memory clock problems
 
After installing my 6670 (amd radeon powercolor HD 6670 2gb) I am having a memory clock problem, the default is set to 500Mhz instead of the "supposedly" 1000Mhz on the box, after even trying to add 100Mhz to it via CatalystControlCentre, I am having screen issues, please help me fix this. Also the benchmarks are really bad (400 points difference with 3D mark) compared to the ones on the actual reviews with benchmarks
http://i.imgur.com/ZZ00O.png

sswilson September 26, 2012 07:28 AM

Just a shot in the dark, but I'll bet it's normal and that what you're seeing recorded is similar to complaints that DDR was only running at half spec.

hiller741 September 26, 2012 07:48 AM

Quote:

Originally Posted by sswilson (Post 658032)
Just a shot in the dark, but I'll bet it's normal and that what you're seeing recorded is similar to complaints that DDR was only running at half spec.

Wouldn't it be strange that the benchmarks are remarkably lower than the benchmarks that are on review sites.

sswilson September 26, 2012 08:01 AM

Yeah, you're right, it looks like it should be reading 1K. What about power settings? Have you tried running a windowed stress test to see if it increases under load?

hiller741 September 26, 2012 08:08 AM

Quote:

Originally Posted by sswilson (Post 658042)
Yeah, you're right, it looks like it should be reading 1K. What about power settings? Have you tried running a windowed stress test to see if it increases under load?

I have heavily stressed it with Benchmark applications already, they don't show any change, I have already emailed AMD how long would a response even take?

sswilson September 26, 2012 08:10 AM

I doubt AMD is who you should be contacting. You should contact the manufacturer. (Powercolor)

hiller741 September 26, 2012 08:16 AM

Quote:

Originally Posted by sswilson (Post 658044)
I doubt AMD is who you should be contacting. You should contact the manufacturer. (Powercolor)

I also had another issue with crossfiring the 6670 with the APU, which also seemed to be very strange, I will just email them both I guess, thanks for helping me so far.

supaflyx3 September 26, 2012 08:26 AM

That's the correct speed you should be getting.

Bond007 September 26, 2012 12:46 PM

unfortunately I think you bought a 6670 with very low memory speed. Looking on newegg there is memory anywhere from ddr3 1000,1200,1333,1600, 1800mhz all the way to ddr5 1000mhz (4000effective). I would bet that if its reporting 500mhz you have a 1000mhz version (its actually 1000 effective because its ddr). The reviews you are reading probably have faster memory.

It would be a faster card if you had gone with a 1gb version, but with higher memory speeds (especially if it was gddr5)

terrybear September 26, 2012 05:59 PM

Quote:

Originally Posted by hiller741 (Post 658043)
I have heavily stressed it with Benchmark applications already, they don't show any change, I have already emailed AMD how long would a response even take?

Quote:

Originally Posted by sswilson (Post 658044)
I doubt AMD is who you should be contacting. You should contact the manufacturer. (Powercolor)

hiller, find my posting in this thread section about rma'ing 7870/7950 cards ..... I have included in the thread the contact info for the power color rep out in california ... he'll help you as the brief few e-mails i've had with him where very plesant. :thumb:


All times are GMT -7. The time now is 05:51 PM.