Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old September 9, 2012, 02:08 AM
Top Prospect
 
Join Date: Nov 2011
Posts: 222

My System Specs

Default RMA GPU, Use My Old One?

Hello everyone,

Recently my R7950 3GB OC Edition Graphics card went bad. I was wondering if while i rma this should i use my hd5670 from my old computer in the meantime or will there be compatibility issues? Installing drivers shouldn't be an issue though.

System Specs:
Motherboard
ASUS Sabertooth Z77
Processor
Intel i7-3770K
Memory
Corsair Vengeance Low Profile 16GB
Video Card(s)
MSI R7950 OC Edition
Hard Drive(s)
Western Digital Black Caviar 1TB HDD
Crucial M4 128GB SSD
Optical Drive(s)
Sony Combo Drive
Case
HAF X Red
Power Supply
Corsair TX650M
Operating System
Windows 7 Ultimate 64Bit
Reply With Quote
  #2 (permalink)  
Old September 9, 2012, 02:15 AM
Allstar
 
Join Date: Aug 2011
Location: Vancouver, BC
Posts: 738
Default

Shouldn't be a problem since both are PCI-E 16x. I would just uninstall the drivers, pull the card, put in the new card and reinstall the driver.
Reply With Quote
  #3 (permalink)  
Old September 9, 2012, 02:18 AM
Top Prospect
 
Join Date: Nov 2011
Posts: 222

My System Specs

Default

^Thanks.This will allow me to continue my work at least. Edit: I see that there is no pcie cable connected to this card it seems that it draws the power from the motherboard. Should i just plug and play when i put it in my new pc? I REALLY dont want to fry my motherboard,

Last edited by PcWizTech; September 9, 2012 at 04:31 AM.
Reply With Quote
  #4 (permalink)  
Old September 9, 2012, 05:04 AM
Bond007's Avatar
Hall Of Fame
 
Join Date: Jun 2009
Location: Nova Scotia
Posts: 3,119

My System Specs

Default

It is designed like that. Only more power hungry cards require the connectors. Motherboards are designed to put up to 75watts through the pcie slot itself. You should have no issues putting the card in until you get an rma/replacement.
__________________
Desktop: Antec Three Hundred, Z77-D3H, 3570K undervolt @4.1ghz with Zalman Optima Cooler, Corsair Vengeance 2x4gb@1866mhz, HD 6950(unlocked shaders and OC'd), Bitfenix Fury 750w, WD Black 1TB, Intel 530 120GB
Away from home light Gamer: Acer Aspire 15.6", A8-3500m undervolt and OC to 2Ghz, 2x4gb Corsair Vengeance, Crucial M500 240gb
Reply With Quote
  #5 (permalink)  
Old September 9, 2012, 05:05 AM
Top Prospect
 
Join Date: Nov 2011
Posts: 222

My System Specs

Default

Alright, I'm good for now. Thanks for the help everyone!
Reply With Quote
Reply


Thread Tools
Display Modes