Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old September 6, 2012, 01:31 PM
Rookie
 
Join Date: Sep 2012
Posts: 7
Default GTX 690 Fps Problems

I just recently bought an Asus GTX 690 to replace my 6950(x2) crossfire. Everything seemed to work fine with the driver uninstall and the transfer to Nvidia drivers. But I have been having one major problem since I've switched. It really doesn't seem that my fps in games has increased at all. In some cases my fps in games is even lower!

The main concern is my low fps in Guild Wars 2 and Counter Strike:Global Offensive. I average around 125-250 Fps with everything high and AA turned off. This is playable but compared to my friend that runs a 580 and gets constant 250-299(fps max is at 300) there has to be something wrong.

GW2 on the other hand can get as low as 20 fps. I Average around 60 but again. There are cases of people running a single 670 and getting constant 130 fps. I switched to the 304.79 beta Drivers because it increased fps a little for GW2. Note the driver switch did not affect any other games that I have noticed.

When I switched from AMD to Nvidia I did a full driver wipe and reinstalled windows 7.

GPU: Asus GTX 690
CPU: intel 2700k (Sandy bridge) OC'd to 4.5 GHrz
Mobo: Asus P8Z68-V PRO/GEN3
Memory: 12gb duel channel
PSU: Corsair TX850W

Any help or insight on this matter would be greatly appreciated.

[EDIT]: IN CS:GO I commonly crash after about 10 minutes of playing. I have to hard reset in order to fix the crash.

Last edited by SighSauce; September 6, 2012 at 01:47 PM.
Reply With Quote
  #2 (permalink)  
Old September 6, 2012, 01:52 PM
Top Prospect
 
Join Date: Aug 2012
Location: Saskatoon
Posts: 162
Default

Are you and your friend playing at the same resolutions? Head over to the Nvidia Control Panel (right-click the desktop) and check out your settings there. Make sure your games are up to date as well, and consider downloading GPU-Z to check that your card is running at the stated specs.
Reply With Quote
  #3 (permalink)  
Old September 6, 2012, 02:07 PM
Rookie
 
Join Date: Sep 2012
Posts: 7
Default

Quote:
Originally Posted by BryceBooth View Post
Are you and your friend playing at the same resolutions? Head over to the Nvidia Control Panel (right-click the desktop) and check out your settings there. Make sure your games are up to date as well, and consider downloading GPU-Z to check that your card is running at the stated specs.
We're both Running 1920x1080(native). All the games are up to date. And I have looked at GPU-Z And it seems to be running at all stated specs.

Ty for the quick reply. Any other Theories?
Reply With Quote
  #4 (permalink)  
Old September 6, 2012, 02:45 PM
SKYMTL's Avatar
HardwareCanuck Review Editor
 
Join Date: Feb 2007
Location: Montreal
Posts: 11,830
Default

Heat. Run two instances of GPU-Z, one on each core. If the cores are hitting above 80 degrees, it is very likely that the GPUs are reaching their Power Limit and clocking to their default (lower) speeds.

Also, ensure that the system "sees" two GPUs. It could very well be that it is only registering one card. To do this, go into Device Manager and ensure two GTX 690 instances are there.

Finally, go into the NVIDIA Control Panel and click on "Configure SLI, PhysX & Surround". Ensure SLI is set to "Maximize 3D Performance" and PhysX is set to CPU.
__________________
Reply With Quote
  #5 (permalink)  
Old September 6, 2012, 02:51 PM
Alpine's Avatar
Allstar
 
Join Date: Dec 2008
Location: Boucherville / South shore of MTL
Posts: 870

My System Specs

Default

NVM..
__________________
Main system
|I7 3930K|Asus P9X79 WS|Evga GTX 690 Signature|Samsung 256G Pro|Corsair H100|Dominator Platinium 16GB 2133Mhz|
Corsair AX1200|Corsair 540 AIR|Corsair SP2500|Corsair Vengeance 2000|
Server system
|I7 3820|Asus P9X79|12G G.Skill 1600Mhz|Noctua NH-D14|Corsair Force 3 120GB|LSI megaRAID 9261 8|RAID5 5X 3TB|Corsair AX650|Fractal Design Arc Midi|

Twitch
Reply With Quote
  #6 (permalink)  
Old September 6, 2012, 03:02 PM
Rookie
 
Join Date: Sep 2012
Posts: 7
Default

Quote:
Originally Posted by SKYMTL View Post
Heat. Run two instances of GPU-Z, one on each core. If the cores are hitting above 80 degrees, it is very likely that the GPUs are reaching their Power Limit and clocking to their default (lower) speeds.

Also, ensure that the system "sees" two GPUs. It could very well be that it is only registering one card. To do this, go into Device Manager and ensure two GTX 690 instances are there.

Finally, go into the NVIDIA Control Panel and click on "Configure SLI, PhysX & Surround". Ensure SLI is set to "Maximize 3D Performance" and PhysX is set to CPU.
I ran a Furmark stress test and both gpu's got to 82c under 100% load. While playing games and such though the highest they get is 65c. I have two Gpu's registering in device manager. And I went to the control panel. The SLI is set to "Maximized 3D Performance" But the PhysX was set to "Auto-Select(recommended)" I set it to "CPU" but did not see any performance differences.
Reply With Quote
  #7 (permalink)  
Old September 6, 2012, 03:03 PM
Rookie
 
Join Date: Sep 2012
Posts: 7
Default

Quote:
Originally Posted by Alpine View Post
NVM..
Hehe yes it is 3.0 ready :P
Reply With Quote
  #8 (permalink)  
Old September 6, 2012, 03:20 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,951

My System Specs

Default

The GTX690 is not really the right card for 1080p though...

Have you tried doing a driver wipe? Drive Sweeper does a pretty decent job. I'd check off both ATI and NVIDIA options, while running in safe mode. Then install the latest beta NVIDIA drivers.

Also check in the NVIDIA control panel that there's no v-sync stuff enabled. Maybe Adaptive V-Sync is on by default?
Reply With Quote
  #9 (permalink)  
Old September 6, 2012, 03:21 PM
Top Prospect
 
Join Date: Aug 2012
Location: Saskatoon
Posts: 162
Default

I've read that lowering the shadow detail can have a huge effect on Guild Wars performance, I cannot confirm this as I don't play that specific game, nor have an nVidia card. It could just be unoptimized drivers. You are running the GPU in the primary PCI-E x16?
Reply With Quote
  #10 (permalink)  
Old September 6, 2012, 04:13 PM
Dzzope's Avatar
Hall Of Fame
 
Join Date: Oct 2010
Location: Irishman in Kiev, wOOoo, I'm an alien...
Posts: 2,903

My System Specs

Default

Thats allot of card for your resolution... wow..

properly wiping out the drivers (or re-doing it as I've seen stuff appear after a second or third scan) would be a good place to start.. But really at your res even 1 core should be able max most/all games..
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
GTX 560 Ti problems. adamdavidson Troubleshooting 8 April 4, 2011 12:21 PM
PS3 problems... Cptn Vortex Off Topic 10 June 22, 2010 10:02 AM
new pc problems... tzetsin Troubleshooting 12 May 17, 2008 09:17 AM
Help Please (2 problems) AnthraxAdrian Troubleshooting 20 April 27, 2008 12:34 PM
Big Problems Feff Troubleshooting 9 January 23, 2008 04:24 PM