Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Video Cards (http://www.hardwarecanucks.com/forum/video-cards/)
-   -   GTX 690 Fps Problems (http://www.hardwarecanucks.com/forum/video-cards/56565-gtx-690-fps-problems.html)

SighSauce September 6, 2012 12:31 PM

GTX 690 Fps Problems
 
I just recently bought an Asus GTX 690 to replace my 6950(x2) crossfire. Everything seemed to work fine with the driver uninstall and the transfer to Nvidia drivers. But I have been having one major problem since I've switched. It really doesn't seem that my fps in games has increased at all. In some cases my fps in games is even lower!

The main concern is my low fps in Guild Wars 2 and Counter Strike:Global Offensive. I average around 125-250 Fps with everything high and AA turned off. This is playable but compared to my friend that runs a 580 and gets constant 250-299(fps max is at 300) there has to be something wrong.

GW2 on the other hand can get as low as 20 fps. I Average around 60 but again. There are cases of people running a single 670 and getting constant 130 fps. I switched to the 304.79 beta Drivers because it increased fps a little for GW2. Note the driver switch did not affect any other games that I have noticed.

When I switched from AMD to Nvidia I did a full driver wipe and reinstalled windows 7.

GPU: Asus GTX 690
CPU: intel 2700k (Sandy bridge) OC'd to 4.5 GHrz
Mobo: Asus P8Z68-V PRO/GEN3
Memory: 12gb duel channel
PSU: Corsair TX850W

Any help or insight on this matter would be greatly appreciated.

[EDIT]: IN CS:GO I commonly crash after about 10 minutes of playing. I have to hard reset in order to fix the crash.

BryceBooth September 6, 2012 12:52 PM

Are you and your friend playing at the same resolutions? Head over to the Nvidia Control Panel (right-click the desktop) and check out your settings there. Make sure your games are up to date as well, and consider downloading GPU-Z to check that your card is running at the stated specs.

SighSauce September 6, 2012 01:07 PM

Quote:

Originally Posted by BryceBooth (Post 653792)
Are you and your friend playing at the same resolutions? Head over to the Nvidia Control Panel (right-click the desktop) and check out your settings there. Make sure your games are up to date as well, and consider downloading GPU-Z to check that your card is running at the stated specs.

We're both Running 1920x1080(native). All the games are up to date. And I have looked at GPU-Z And it seems to be running at all stated specs.

Ty for the quick reply. Any other Theories?

SKYMTL September 6, 2012 01:45 PM

Heat. Run two instances of GPU-Z, one on each core. If the cores are hitting above 80 degrees, it is very likely that the GPUs are reaching their Power Limit and clocking to their default (lower) speeds.

Also, ensure that the system "sees" two GPUs. It could very well be that it is only registering one card. To do this, go into Device Manager and ensure two GTX 690 instances are there.

Finally, go into the NVIDIA Control Panel and click on "Configure SLI, PhysX & Surround". Ensure SLI is set to "Maximize 3D Performance" and PhysX is set to CPU.

Alpine September 6, 2012 01:51 PM

NVM..

SighSauce September 6, 2012 02:02 PM

Quote:

Originally Posted by SKYMTL (Post 653804)
Heat. Run two instances of GPU-Z, one on each core. If the cores are hitting above 80 degrees, it is very likely that the GPUs are reaching their Power Limit and clocking to their default (lower) speeds.

Also, ensure that the system "sees" two GPUs. It could very well be that it is only registering one card. To do this, go into Device Manager and ensure two GTX 690 instances are there.

Finally, go into the NVIDIA Control Panel and click on "Configure SLI, PhysX & Surround". Ensure SLI is set to "Maximize 3D Performance" and PhysX is set to CPU.

I ran a Furmark stress test and both gpu's got to 82c under 100% load. While playing games and such though the highest they get is 65c. I have two Gpu's registering in device manager. And I went to the control panel. The SLI is set to "Maximized 3D Performance" But the PhysX was set to "Auto-Select(recommended)" I set it to "CPU" but did not see any performance differences.

SighSauce September 6, 2012 02:03 PM

Quote:

Originally Posted by Alpine (Post 653805)
NVM..

Hehe yes it is 3.0 ready :P

JD September 6, 2012 02:20 PM

The GTX690 is not really the right card for 1080p though...

Have you tried doing a driver wipe? Drive Sweeper does a pretty decent job. I'd check off both ATI and NVIDIA options, while running in safe mode. Then install the latest beta NVIDIA drivers.

Also check in the NVIDIA control panel that there's no v-sync stuff enabled. Maybe Adaptive V-Sync is on by default?

BryceBooth September 6, 2012 02:21 PM

I've read that lowering the shadow detail can have a huge effect on Guild Wars performance, I cannot confirm this as I don't play that specific game, nor have an nVidia card. It could just be unoptimized drivers. You are running the GPU in the primary PCI-E x16?

Dzzope September 6, 2012 03:13 PM

Thats allot of card for your resolution... wow..

properly wiping out the drivers (or re-doing it as I've seen stuff appear after a second or third scan) would be a good place to start.. But really at your res even 1 core should be able max most/all games..


All times are GMT -7. The time now is 09:10 PM.