Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Video Cards (http://www.hardwarecanucks.com/forum/video-cards/)
-   -   No video signal (http://www.hardwarecanucks.com/forum/video-cards/54605-no-video-signal.html)

Greyhair June 8, 2012 06:16 PM

No video signal
 
Hi all.
Long time reader, first time poster.

Sorry if this is a little long.

I've had a 9800GT ultimate installed for a long time.
It's a great card, but it's a little loud.
Decided I'd do an upgrade, of sorts, to an asus GTX550ti, mostly for noise and temp reasons.

Uninstall all Nvidia drivers and Asus utilities. Shut down.
Remove old card.
Plug the new card in, no signal, can't even see bios. Fan is running on card.
Tried the analog output, no signal.

Take the card back to the shop, they plug it into a machine they had there, works fine.
Bring it back home, same thing. Plug my old one back in, no problem.
Grab a new power supply, same thing.

I've switched them in and out a few times to no avail.

Lots of gurus on here, what am I missing?

Some specs ( try not to laugh, she's old ):

Asus m2n-e motherboard
4 gig Corsair XMS ram
Corair HX520w Power supply ( 54 amps , 18amps each on 3 12v rails )
* temp replaced for testing purposes with a Cooler master GX650w ( 52 amps on a single rail ) *
Couple Hard drives
DVD Rom
Antec 900 Case ( 4 fans )

Any ideas?
Thanks for your time.
Cheers.

sswilson June 8, 2012 06:22 PM

Did you try a cmos reset? Might just need a poke to get it to recognise the new card.

Greyhair June 8, 2012 06:27 PM

would you suggest resetting it though bios, then power down and switch to the new card?

sswilson June 8, 2012 06:29 PM

I wouldn't bother with that, I'd just power down, put in the new card, reset the cmos (jumpers close to the battery) and then power back on.

Dzzope June 8, 2012 09:58 PM

It's possible that you may need a bios upgrade if clearing the CMOS doesn't work.

I had an older machine (socket 939) that I tried to put a 5770 in and had the same problem.. A bios update could have fixed it if it were available (other boards with same chipset had an update but not mine)
It's a possibility but not guaranteed..

Maybe try posting in asus forums about support for newer cards on that board?

P.S. your definitely plugging in the power to the GPU?

Best of luck getting it sorted out.

Greyhair June 8, 2012 11:09 PM

I'm thinking it's a board issue as well, just not sure why.
Thanks all.
I'll see what I can figure out.

LoTech June 10, 2012 06:43 AM

Greyhair, when the card is seated and power is attached does the fan spin? I would also doble check that the card is seated firmly and teh power connectors as well. By reinstalling the older card you have ruled out a bad pci slot. What is strange is that the windows( I assume) drivers do not display something for you.

LarkStarr June 10, 2012 09:14 AM

Dzzope might be correct, you might need a BIOS firmware update. Pop your old card back in and try to update it.

Greyhair June 16, 2012 11:33 AM

I may be the stubbornest :censored: I know, but I finally gave up on it.
The shop I bought it from was cool about it, and they gave me a refund.

Short of sacrificing a goat ( since I don't seem to have a goat around ),
I've tried everything possible, without any success.

So, if anyone has a similar rig to mine, you may have no luck with a 5 series card.
( although I've read of people with the sli version of the board having success )

Thanks for your time, and all the suggestions.

If nothing else, my case if super clean again, and I am far too familiar with my bios.
:whistle:
Time for some beer.

Have a good one.
Cheers.

ern88 June 17, 2012 07:18 PM

Try that card in another machine


All times are GMT -7. The time now is 01:33 PM.