Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old October 8, 2011, 03:10 AM
Amarthfea's Avatar
Top Prospect
 
Join Date: Jan 2011
Location: London, ON
Posts: 130

My System Specs

Default So, I think I broke my video card..

I was putting on a waterblock and and noticed some old thermal compound still left on it. So I thought i would clean it out, it was in a fine area and something broke of course.
a picture of course is mandatory so you have some idea of what the heck I'm talking about.



does anyone know what this piece does? I'm guess it does something or else it wouldn't be there
__________________
~Elysium, I behold your beauty...
Reply With Quote
  #2 (permalink)  
Old October 8, 2011, 05:19 AM
Technokat's Avatar
Allstar
F@H
 
Join Date: Apr 2009
Location: London Ontario
Posts: 517

My System Specs

Default

my guess is you are pooched, but thats just me. I am not technical by any means :P
__________________

Reply With Quote
  #3 (permalink)  
Old October 8, 2011, 06:27 AM
Top Prospect
 
Join Date: Sep 2009
Location: Canada
Posts: 240

My System Specs

Default

could be any of a number of things
however...being broken off was not one of the "good" options to be
Reply With Quote
  #4 (permalink)  
Old October 8, 2011, 07:27 AM
Arinoth's Avatar
Moderator
F@H
 
Join Date: May 2009
Location: Halifax
Posts: 8,586

My System Specs

Default

More then likely it was a surface mount diode, still anything that has broken off typically means you've pooched your card
Reply With Quote
  #5 (permalink)  
Old October 8, 2011, 08:42 AM
Allstar
F@H
 
Join Date: Apr 2009
Location: Kingston Ontario
Posts: 926
Default

I'd just slap it back together and see what happens... Maybe it wasn't anything important I dropped a mobo once and three thingies broke off... a small capacitor and two diodes. It still worked fine. Probably not worth the effort to try and get it repaired...
Reply With Quote
  #6 (permalink)  
Old October 8, 2011, 10:08 AM
Perineum's Avatar
Hall Of Fame
F@H
 
Join Date: Mar 2009
Location: Surrey, B.C.
Posts: 4,039

My System Specs

Default

I would need a much higher res picture to comment....
Reply With Quote
  #7 (permalink)  
Old October 12, 2011, 12:27 PM
dandelioneater's Avatar
Hall Of Fame
F@H
 
Join Date: Dec 2010
Location: Kelowna, BC
Posts: 1,114

My System Specs

Default

it might have been a film capacitor or little surface mount resistor that broke off. I'd just test out the card. it'll either work or it won't.
__________________
Reply With Quote
  #8 (permalink)  
Old October 12, 2011, 04:45 PM
Amarthfea's Avatar
Top Prospect
 
Join Date: Jan 2011
Location: London, ON
Posts: 130

My System Specs

Default

thanks everyone, i'm in the middle of putting the loop together with it in it anyways. if it works great! if not, well i have a spare 4870x2 and can swap the block onto that.
__________________
~Elysium, I behold your beauty...
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Video card and sound card in pci-e h0nam Video Cards 7 October 20, 2010 11:26 PM
[WTB] Sound card and wc video card hausner Buy/Sell & Trade 17 August 11, 2009 01:59 PM
Water line broke and then anouther line broke muse108dc Off Topic 3 March 28, 2009 07:34 AM
WTB: Video Card/Sound Card/Hard drive - Look here if u gotz some ! Flintblade Buy/Sell & Trade 4 December 4, 2008 09:27 PM
WTB PCI-E Video card with Video out Taichan Buy/Sell & Trade 0 June 9, 2008 08:17 PM