Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old July 20, 2011, 07:16 AM
Caldezar's Avatar
Hall Of Fame
F@H
 
Join Date: Aug 2008
Location: Burnaby
Posts: 1,686

My System Specs

Default What's with 'nVidia HD Audio' driver?

So, as some of you know, I ended up with an EVGA GTX 580 in my new build, rather than the original 2x 570's. Now, performance wise I'm happy with the 580, and will likely get a second when the timing is right and the sli issues I saw are fixed. However, I ran in to a few issues after switching to the 580...

When making the switch, I followed SOP and completely uninstalled the old drivers, installed the new GPU, then reinstalled drivers. Everything went smoothly... for about 5 minutes. Then I started to notice screen flickering, mouse input lag, and the occasional complete black-out of my monitor. (Screen would go completely black for a brief second, but the monitor wasn't in 'power-save' mode.)

At first I was choked because I figured it was a DOA GPU. However, after putting some use on the card, I determined something very odd; the issue ONLY occurs within a Windows environment. I could game for hours and never run in to the issue, but if I was downloading, surfing internet, or anything else that had me in the Windows environment, I would see the issue constantly.

Obviously I went through the standard reinstall of drivers, tried an older version of the drivers, etc. but nothing was working. At this point I started recalling stories I had heard about the 5970's artifacting and having issues if they ran too cool, and I wondered if there was something of a similar nature happening here. So I took to Google to see what I could find. I didn't get much, but I found someone with a similar issue that had someone suggest he disable or uninstall the nVidia HD Audio driver. There was, however, no response to the suggestion. I was a bit skeptical, but it was the only suggestion I'd seen so I thought I'd give it a whirl.

Lo and behold! It worked! I completely uninstalled the nVidia HD Audio drivers, and I've been flicker/black screen free for a few days now. WTF!?

Has anyone run in to this before? Or aware of issues with the HDAudio drivers? I'm especially baffled because I don't use HDMI. I use a DVI connection for video, so these drivers shouldn't be an issue. Tres bizarre....
Reply With Quote
  #2 (permalink)  
Old July 20, 2011, 07:34 AM
Banned
F@H
 
Join Date: Aug 2007
Location: mtl
Posts: 12,694
Default

well i've run into the no sound issue with the stupid nv hd audio installed,so i make sure to chose custom when installing,along with

fresh install or whatever they call it so it wipes the other stuff thats been there
Reply With Quote
  #3 (permalink)  
Old July 20, 2011, 07:52 AM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,576
Default

I've seen issues with nv audio conflicting with realtek audio and causing a no audio issue.
Reply With Quote
  #4 (permalink)  
Old July 20, 2011, 08:07 AM
francisw19's Avatar
Top Prospect
 
Join Date: Oct 2009
Location: Alberta
Posts: 246
Default

Yeah...these nVidia HD audio drivers are strange. I haven't had the issue the OP is describing and no issues with my sound card. But, I've noticed any time I install the nv audio drivers, the windows audio control panel says that "No audio devices are installed"...I dunno.
Reply With Quote
  #5 (permalink)  
Old July 20, 2011, 08:10 AM
Eldonko's Avatar
Hardware Canucks Reviewer
 
Join Date: Apr 2007
Location: Calgary, AB
Posts: 5,445
Default

I never install that, what's the point? Each board has it's own audio drivers, there is no need for installing stuff that is not necessary.
__________________
Donkeys kill more people annually than plane crashes or shark attacks.
Reply With Quote
  #6 (permalink)  
Old July 20, 2011, 08:16 AM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,576
Default

Quote:
Originally Posted by Eldonko View Post
I never install that, what's the point? Each board has it's own audio drivers, there is no need for installing stuff that is not necessary.
I think it has something to do with allowing the HDMI sound to be carried through.
Reply With Quote
  #7 (permalink)  
Old July 20, 2011, 08:26 AM
Eldonko's Avatar
Hardware Canucks Reviewer
 
Join Date: Apr 2007
Location: Calgary, AB
Posts: 5,445
Default

Yeah I've never done audio through hdmi from any of my computers before so it is pointless for me.
__________________
Donkeys kill more people annually than plane crashes or shark attacks.
Reply With Quote
  #8 (permalink)  
Old July 20, 2011, 09:45 AM
ZZLEE's Avatar
Hall Of Fame
F@H
 
Join Date: May 2009
Location: KANATA
Posts: 2,040

My System Specs

Default

Im using a 22 inch 60 hrtz monititor so its best fore me not to install 3D drivers also.
__________________
"EVGA hunted down the last dozen or so expats living in Karachi." SKY
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia 257.15 Beta Driver r0bc O/S's, Drivers & General Software 3 June 2, 2010 12:55 PM
what nvidia driver are you using for win7? Silvgearx O/S's, Drivers & General Software 13 January 4, 2010 07:23 PM
9800gtx+ sc/Nvidia driver issues? Wolfx25 Video Cards 12 April 26, 2009 03:26 PM
NVidia offers an explanation about driver holdup Babrbarossa O/S's, Drivers & General Software 20 April 22, 2008 03:16 PM
Nvidia driver 158.45 overclock warning ragenrok Overclocking, Tweaking and Benchmarking 7 June 17, 2007 06:49 PM