Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Video Cards (http://www.hardwarecanucks.com/forum/video-cards/)
-   -   Why do people get "display driver stopped working..." (http://www.hardwarecanucks.com/forum/video-cards/41210-why-do-people-get-display-driver-stopped-working.html)

ern88 February 28, 2011 03:10 PM

Why do people get "display driver stopped working..."
 
Why do people including myself get the "ATI display driver has stopped working but has recovered" What is causes this and is it a Hardware problem or some driver problem. And is there a solution?

Thanks

bf1 February 28, 2011 03:25 PM

i updated my drivers a couple days ago and it has seemed to stop so far lol, have you updated urs?

Mekaw February 28, 2011 03:30 PM

is your GPu overclocked? if it is, that's unstable overclock, other wise, it's driver issue

Spikemaul February 28, 2011 03:32 PM

Ever since I have been playing Black Ops My card's been crashing even at stock settings.

ern88 February 28, 2011 03:46 PM

I have been using the latest 11.2 drivers. My problem happens when watching embedded videos on Google chrome. Don't think it happened once when playing a game. Just wierd. But I know I am not the only person. A buddy of mine has the same issue as well with a different video card

Delavan February 28, 2011 04:56 PM

Quote:

Ever since I have been playing Black Ops My card's been crashing even at stock settings.
although I have no cure for that, there is a few of my buddies that have issues with Black ops crashing...
another one of my buds runs a GTX275 and he's fine..

ccm001 February 28, 2011 05:28 PM

There are people having problems with the 11.2 release - no surprise there :whistle:

Negative review here: AMD Catalyst 11.2 Windows 7 Driver Analysis - Final Thoughts :: TweakTown USA Edition

I had problems with random freezes and crashes, even had my video cad not being recognized sometimes when I would boot up my computer.

I had to (in safe mode) uninstall all traces of ATI drivers, then reinstall 11.1, now everything seems to be fine.

Not everyone is having issues, a look at the amd forums shows mixed results, but maybe that is what is cuasing your problems too. try uninstalling the 11.2 and installing 11.1 or the 11.1a hotfix release.

LaughingCrow February 28, 2011 07:07 PM

I get it occasionally with a GTX 460. Never figured out what causes it or how to fix it, although I tried some of the remedies. Seems to be a common enough problem in Vista or Win 7, yet sporatic. Usually while gaming but a couple of times just surfing.

jcmaz February 28, 2011 07:23 PM

Overclock failed?

kingnubian February 28, 2011 08:56 PM

I get that message occasionally with my EVGA GTX 570 & it's never been overclocked. Seems to pop up when I've had my pc on for a few days even though most of the time it's idle. Funny thing is I never get it during gameplay.


All times are GMT -7. The time now is 11:56 PM.