Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old December 29, 2010, 10:25 PM
Trial Member
 
Join Date: Dec 2010
Posts: 1
Default Major Crossfire Problems! HD5850

Hi guys,

Could you help me with my crossfire setup or lack-there-of.

My specs are the following;

eVGA X58 classified 3-way SLi
6GB Corsair Dominator GT
Sapphire HD5850 2x
2x 1tb Segate 7200.12
2x 32GB Corsair Nova SSDs.
Windows 7 Ultimate 64bit

I've installed the catalyst profiles, disabled catalyst AI.

3DMark vantage gave me a score of

P10698
CPU: 19585
GPU: 9292

From what I've read this is seriously off the mark :S I have no idea what the problem is as this is the first time I've tried setting it up.

Any ideas why??
Reply With Quote
  #2 (permalink)  
Old December 30, 2010, 10:33 AM
Top Prospect
 
Join Date: Aug 2009
Posts: 199

My System Specs

Default

If i remember correctly, you need to enable AI otherwise only one card is using and Xfire is OFF
Reply With Quote
  #3 (permalink)  
Old December 30, 2010, 01:58 PM
dustin1706's Avatar
Allstar
 
Join Date: May 2010
Location: Alberta
Posts: 631

My System Specs

Default

As long as you have a crossifre bridge between the cards and crossfire is set to enabled in CCC, it should be working. No need to tweak any other settings in CCC. The easiest way to be sure it is working is to use a program like MSI afterburner and set it up to monitor GPU usage and temperature on screen (OSD). That way, you can see if both GPUs are being utilized in games and in benchmarks.

I am assuming that you are running the latest drivers and latest version of CCC as well. Not that the older ones don't work, but I do like the new CCC much better.
__________________
Rig1 in "My System Specs"
Rig2: Q6600, P5DN-D, GTX650, 4GB HyperX, LG BD drive, TT armor case, ek supreme HF, 655 pump, XP
Dell XPS17 - i7 2820QM, 8GB ram, 1920x1080, BluRay, GT555m 3GB, 240gb Neutron GTX, 640GB Seagate, Win7 64
Server - i5 3450, Asus P8Z77-I Deluxe, 4GB DDR3, LSI MegaRAID 9240-8I, OCZ Vertex 4 120GB, 2x SG Barracuda 3TB(RAID1), 2x WD green 2TB(RAID1), Fractal Design Array R2, WHS 2011
Reply With Quote
  #4 (permalink)  
Old December 30, 2010, 02:13 PM
Top Prospect
 
Join Date: Jun 2009
Location: Toronto, ON
Posts: 61

My System Specs

Default

Quote:
Originally Posted by Ryoohki View Post
If i remember correctly, you need to enable AI otherwise only one card is using and Xfire is OFF
+1...Crossfire only works with AI enabled.
Reply With Quote
  #5 (permalink)  
Old December 30, 2010, 03:13 PM
Dr_BenD_over's Avatar
Fallen Folder
F@H
 
Join Date: Jul 2008
Location: Nova Scotia
Posts: 2,418

My System Specs

Default

Even with only one card active, that's low for a 5850. Double check your settings in the CCC. (AA AF and V-Sync off, Cat Ai ON)
__________________
All's well that's Haswell
Reply With Quote
  #6 (permalink)  
Old January 6, 2011, 12:44 PM
Rookie
 
Join Date: Jan 2011
Location: Maine
Posts: 13

My System Specs

Default

the fix has already been posted Disabling Cat AI disables optimizations that ATI uses but more importantly it completely disables crossfire. Meaning by turning Cat AI off you have effectively cost yourself about 10% performance wise in single gpu mode and if your running dual card you've lost Crossfire. To fix the issue simply turn Catalyst AI back on and your good to go.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
2x HD5850 CROSSFIRE or ATI Radeon 5970 2GB GDDR5 Ram Alexanderrazz Video Cards 10 June 28, 2010 06:13 AM
GTX480 + 8800GTX major problems Overclocker~4.1 Troubleshooting 8 June 23, 2010 09:10 PM
[WTB] HD5850, true120/venomous/nh-d14, wd black 1tb 0o0 Buy/Sell & Trade 12 May 10, 2010 05:37 AM
HD5850 HDMI issues Brando737 Video Cards 3 April 28, 2010 12:05 PM