Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old October 23, 2010, 05:53 PM
shayan288's Avatar
Allstar
F@H
 
Join Date: Oct 2008
Location: Vancouver, BC, Canada
Posts: 911
Default ATI Catalyst 10.10 Drivers

So they were released just the other day.
Just wondering if anyone has tried them yet.
If so, care to share your results?
I'm debating whether I should leave my 10.5 comfort zone with my 5970,
because everything after 10.5 has been absolute shit for me.
__________________
The 288

Q9550 E0 stepping @ 4Ghz
Gigabyte EP45 UD3P
G.Skill pc2 8500 1066mhz RAM
Corsair TX750 Watt Power Supply
Western Digital 500gb and Seagate 500gb in RAID 0
Western Digital 250gb
Antec 1200
OCZ Vendetta 2 LGA 775 CPU cooler with bolt thru kit
XFX HD5970
Steelseries 7G Mechanical Keyboard
Samsung 305T 30 Inch 2560x1600 LCD monitor
Altec Lansing 5.1 Surround Speakers, Sennheiser HD215's, G35's
Steelseries Xai Laser Mouse
Windows 7 Ultimate x64
Reply With Quote
  #2 (permalink)  
Old October 23, 2010, 06:01 PM
BrianHanna's Avatar
Hall Of Fame
F@H
 
Join Date: Jan 2009
Location: toronto
Posts: 1,049
Default

Quote:
Originally Posted by shayan288 View Post
So they were released just the other day.
Just wondering if anyone has tried them yet.
If so, care to share your results?
I'm debating whether I should leave my 10.5 comfort zone with my 5970,
because everything after 10.5 has been absolute shit for me.
im on 10.9, didnt know 10.10 came out, ill check it out
__________________
Asus p6x58d-e / i7 930 @ 4ghz / G.skill 1600mhz 2x3gb 9-9-9-24 / Corsair TX750 / XFX HD 6850 1GB x2 @ 870/1070/ Coolermaster HAF 932 / Noctua nh12-up / Western Digital 500g Caviar black /Western Digital 1TB Caviar black 60Gb/ Seagate 7200.11 500g / OCZ Vertex 3 SSD / Samsung 2253BW / G5 / MX518 /

Reply With Quote
  #3 (permalink)  
Old October 23, 2010, 06:10 PM
shayan288's Avatar
Allstar
F@H
 
Join Date: Oct 2008
Location: Vancouver, BC, Canada
Posts: 911
Default

Also, would it be necessary for one to use driver sweeper in safemode and all that stuff, just for going from 10.5 to 10.10?
__________________
The 288

Q9550 E0 stepping @ 4Ghz
Gigabyte EP45 UD3P
G.Skill pc2 8500 1066mhz RAM
Corsair TX750 Watt Power Supply
Western Digital 500gb and Seagate 500gb in RAID 0
Western Digital 250gb
Antec 1200
OCZ Vendetta 2 LGA 775 CPU cooler with bolt thru kit
XFX HD5970
Steelseries 7G Mechanical Keyboard
Samsung 305T 30 Inch 2560x1600 LCD monitor
Altec Lansing 5.1 Surround Speakers, Sennheiser HD215's, G35's
Steelseries Xai Laser Mouse
Windows 7 Ultimate x64
Reply With Quote
  #4 (permalink)  
Old October 23, 2010, 06:34 PM
Delavan's Avatar
Hall Of Fame
 
Join Date: May 2007
Location: Mtl
Posts: 1,149
Default

To be honest, I went from 10.5 (when I first got my HD5870) and upgraded to the next Catalyst version without cleanup every time AMD came up with a new version of Catalyst, no issues. I know that it's always better to driversweep...but I never do, unless I come across a driver issue...which I didn't have with my HD5870 YET...crossing fingers!

I just installed Cat 10.10 and the ATI STREAM package (renamed to AMD Catalyst™ Accelerated Parallel Processing (APP)) (OPEN CL and DIRECT COMPUTE 5.0 enabled)

Anyway, no issues yet. Temperatures are the same, FPS seems maybe a little higher, something like 5 fps extra in BFBC2 at the same settings...

I haven't tested any other games yet, and of all the games mentioned in the "improvement section" of the driver's read me file..I don't have any installed to compare...
__________________
i7 4770K @ 4.5GHz / Corsair H100i / Maximus VI HERO / 8GB Corsair Vengeance Red LP 1.5V 1866 / N560GTX Ti Twin FROZR II OC / Corsair Performance Pro 128GB SSD / Intel 520 120GB SSD / WD Black 640 GB storage

ROG G53SX laptop: i7 2630QM / 12GB DDR3 / GTX560m 2GB / 750GB 7200rpm (14 000 3Dmarks06)

Last edited by Delavan; October 23, 2010 at 06:39 PM.
Reply With Quote
  #5 (permalink)  
Old October 23, 2010, 07:47 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,882

My System Specs

Default

Drivers working fine here too. Also opted for the OpenCL drivers just for kicks. Not that I have a single app that uses it though
Reply With Quote
  #6 (permalink)  
Old October 23, 2010, 09:28 PM
shayan288's Avatar
Allstar
F@H
 
Join Date: Oct 2008
Location: Vancouver, BC, Canada
Posts: 911
Default

Does anyone here have a 5970, and the game Dead Rising 2?
__________________
The 288

Q9550 E0 stepping @ 4Ghz
Gigabyte EP45 UD3P
G.Skill pc2 8500 1066mhz RAM
Corsair TX750 Watt Power Supply
Western Digital 500gb and Seagate 500gb in RAID 0
Western Digital 250gb
Antec 1200
OCZ Vendetta 2 LGA 775 CPU cooler with bolt thru kit
XFX HD5970
Steelseries 7G Mechanical Keyboard
Samsung 305T 30 Inch 2560x1600 LCD monitor
Altec Lansing 5.1 Surround Speakers, Sennheiser HD215's, G35's
Steelseries Xai Laser Mouse
Windows 7 Ultimate x64
Reply With Quote
  #7 (permalink)  
Old October 23, 2010, 10:07 PM
shayan288's Avatar
Allstar
F@H
 
Join Date: Oct 2008
Location: Vancouver, BC, Canada
Posts: 911
Default

AHHHHHHHHHH!!! This same damn thing happens to me whenever I try to install any ATI driver. Its sooo annoying! In the Catalyst install manager thing, there is a note saying WARNING: screen may flicker or go blank during this. And then it does go blank and nothing happens. I thought of leaving it alone for a while and I came back 3 hours later, and nothing changes. It happens so many times. Only a few times it didnt happen, and I doubt that the installation was successful. :'(
__________________
The 288

Q9550 E0 stepping @ 4Ghz
Gigabyte EP45 UD3P
G.Skill pc2 8500 1066mhz RAM
Corsair TX750 Watt Power Supply
Western Digital 500gb and Seagate 500gb in RAID 0
Western Digital 250gb
Antec 1200
OCZ Vendetta 2 LGA 775 CPU cooler with bolt thru kit
XFX HD5970
Steelseries 7G Mechanical Keyboard
Samsung 305T 30 Inch 2560x1600 LCD monitor
Altec Lansing 5.1 Surround Speakers, Sennheiser HD215's, G35's
Steelseries Xai Laser Mouse
Windows 7 Ultimate x64
Reply With Quote
  #8 (permalink)  
Old October 23, 2010, 10:16 PM
EdHilario's Avatar
Rookie
 
Join Date: Oct 2010
Location: http://edhilario.ca in Markham
Posts: 28

My System Specs

Default

Gonna try these drivers out right now. Thanks for the heads up.
__________________
Exterior & Interior Modification & Care
detailing - moidifications - installations - maintenance
http://edhilario.ca | edhilario.ca@gmail.com
Reply With Quote
  #9 (permalink)  
Old October 24, 2010, 11:00 PM
Rookie
 
Join Date: Oct 2008
Location: Windsor, Ontario
Posts: 30
Default

I heard some people were having problems with a pink tinge, will stay away for now
__________________
Workstation:
Intel 930 @ 4.0 w/ TRUE // ASUS P6T DLX // 12GB OCZ Gold DDR1600
Sapphire 6970 Xfire @ 950 core / 1400 mem
Crucial M4 128gb // 4TB Storage // Thermaltake Toughpower 1200W // Corsair 800D // 3x Samsung 225BW

Server:
Intel 920 @ 4.0 (Corsair A70) // X58 Sabertooth // Sapphire 5450 // Antec 750W //
Promise SATA300TX4 // Norco 450B
12GB Ram // 26TB Storage
Reply With Quote
  #10 (permalink)  
Old October 25, 2010, 10:27 AM
Hall Of Fame
F@H
 
Join Date: Nov 2008
Location: Ottawa, ON
Posts: 1,226

My System Specs

Default

No change for me with the Radeon 4870 (tried Folding and Dragon Age: Origins). I went from 10.9 to 10.10. Maybe they're not doing anything aggressive for my older GPU (as I saw nothing significant to that series of card).
__________________
"The computer programmer says they should drive the car around the block and see if the tire fixes itself." [src]
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Catalyst 9.10 WHQL Drivers Released FiXT Press Releases & Tech News 14 October 23, 2009 06:30 AM
ATI Catalyst 9.9 Drivers Released FiXT Press Releases & Tech News 0 September 14, 2009 10:11 AM
ATI Catalyst 8.10 Drivers Released MAC Press Releases & Tech News 6 October 16, 2008 09:14 PM
ATI Catalyst 7.11 Drivers Released SKYMTL Video Cards 1 November 21, 2007 05:22 PM
Catalyst 7.7 Drivers Now Available from ATI BALISTX Video Cards 7 August 23, 2007 10:11 PM