Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Video Cards (http://www.hardwarecanucks.com/forum/video-cards/)
-   -   ATI Catalyst 10.10 Drivers (http://www.hardwarecanucks.com/forum/video-cards/37358-ati-catalyst-10-10-drivers.html)

shayan288 October 23, 2010 05:53 PM

ATI Catalyst 10.10 Drivers
 
So they were released just the other day.
Just wondering if anyone has tried them yet.
If so, care to share your results?
I'm debating whether I should leave my 10.5 comfort zone with my 5970,
because everything after 10.5 has been absolute shit for me.

BrianHanna October 23, 2010 06:01 PM

Quote:

Originally Posted by shayan288 (Post 441876)
So they were released just the other day.
Just wondering if anyone has tried them yet.
If so, care to share your results?
I'm debating whether I should leave my 10.5 comfort zone with my 5970,
because everything after 10.5 has been absolute shit for me.

im on 10.9, didnt know 10.10 came out, ill check it out

shayan288 October 23, 2010 06:10 PM

Also, would it be necessary for one to use driver sweeper in safemode and all that stuff, just for going from 10.5 to 10.10?

Delavan October 23, 2010 06:34 PM

To be honest, I went from 10.5 (when I first got my HD5870) and upgraded to the next Catalyst version without cleanup every time AMD came up with a new version of Catalyst, no issues. I know that it's always better to driversweep...but I never do, unless I come across a driver issue...which I didn't have with my HD5870 YET...crossing fingers!

I just installed Cat 10.10 and the ATI STREAM package (renamed to AMD Catalyst™ Accelerated Parallel Processing (APP)) (OPEN CL and DIRECT COMPUTE 5.0 enabled)

Anyway, no issues yet. Temperatures are the same, FPS seems maybe a little higher, something like 5 fps extra in BFBC2 at the same settings...

I haven't tested any other games yet, and of all the games mentioned in the "improvement section" of the driver's read me file..I don't have any installed to compare...

JD October 23, 2010 07:47 PM

Drivers working fine here too. Also opted for the OpenCL drivers just for kicks. Not that I have a single app that uses it though :whistle:

shayan288 October 23, 2010 09:28 PM

Does anyone here have a 5970, and the game Dead Rising 2?

shayan288 October 23, 2010 10:07 PM

AHHHHHHHHHH!!! This same damn thing happens to me whenever I try to install any ATI driver. Its sooo annoying! In the Catalyst install manager thing, there is a note saying WARNING: screen may flicker or go blank during this. And then it does go blank and nothing happens. I thought of leaving it alone for a while and I came back 3 hours later, and nothing changes. It happens so many times. Only a few times it didnt happen, and I doubt that the installation was successful. :'(

EdHilario October 23, 2010 10:16 PM

Gonna try these drivers out right now. Thanks for the heads up.

darren700 October 24, 2010 11:00 PM

I heard some people were having problems with a pink tinge, will stay away for now

frontier204 October 25, 2010 10:27 AM

No change for me with the Radeon 4870 (tried Folding and Dragon Age: Origins). I went from 10.9 to 10.10. Maybe they're not doing anything aggressive for my older GPU (as I saw nothing significant to that series of card).


All times are GMT -7. The time now is 03:09 PM.