Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old October 3, 2010, 12:12 AM
shayan288's Avatar
Allstar
F@H
 
Join Date: Oct 2008
Location: Vancouver, BC, Canada
Posts: 911
Default 5970 woes

Hey all,

I had been a Nvidia user all my life,
and I had finally decided that I wanted more power than my 460,
and switch the the HD5970. I was expecting to max every with a steady 60 FPS at least !

I must say that I am pretty dissapointed. Almost every game i have played, has given me shitty framerate,
except for crysis warhead, and bad company 2.

I had just picked up dead rising 2, and right when I played it, I decided that I needed to post about this.
I am getting bloody 8800gt speeds on this game. (same with gta 4; which I was getting less than 20 fps average). In dead rising 2. I am averaging at 18FPS on max with max AA and blur on. With max, with AA off and blur off, I get an average of 28 FPS.

Its killing me guys. Any suggestions on how to fix this madness? Is this just what ATI is like?
I am currently on 10.9 drivers.
CPU is a q9550 @ 4ghz, with 4gb of ram.
__________________
The 288

Q9550 E0 stepping @ 4Ghz
Gigabyte EP45 UD3P
G.Skill pc2 8500 1066mhz RAM
Corsair TX750 Watt Power Supply
Western Digital 500gb and Seagate 500gb in RAID 0
Western Digital 250gb
Antec 1200
OCZ Vendetta 2 LGA 775 CPU cooler with bolt thru kit
XFX HD5970
Steelseries 7G Mechanical Keyboard
Samsung 305T 30 Inch 2560x1600 LCD monitor
Altec Lansing 5.1 Surround Speakers, Sennheiser HD215's, G35's
Steelseries Xai Laser Mouse
Windows 7 Ultimate x64
Reply With Quote
  #2 (permalink)  
Old October 3, 2010, 05:14 AM
Avid6eek's Avatar
Top Prospect
 
Join Date: Jul 2009
Location: Schenectady, NY
Posts: 72
Default

Did you uninstall the nVidia drivers from your system prior to installing the ATI card? Did you install ATI's video drivers and the CrossFire application profiles?

The 5970 is the fastest graphics card on the market. I run two 5870's in CrossFire (2560x1600, 8xAA/AF) and the perfromance is absolutely great. Most games still run 60-100fps. Something is definetly wrong with your system setup/config.
Reply With Quote
  #3 (permalink)  
Old October 3, 2010, 06:42 AM
Top Prospect
 
Join Date: May 2008
Location: North York, ON
Posts: 98

My System Specs

Default

You must not have removed all drivers from your previous install.

Use Driver Sweeper - install Driver Sweeper, uninstall all your current drivers in Windows, then reboot into safe mode and use the Driver Sweeper to clean all Nvidia and ATI drivers.

Reboot back into Windows and then install drivers again.

Win.

http://www.guru3d.com/category/driversweeper/
__________________
Desktop: Asus Maximus V Gene | 3570K @ 4.2Ghz | 4x4GB G.Skill DDR3-1600 16GBXL 9-9-9-24 | Patriot PYRO SE 240GB SSD | Gigabyte 650ti Boost | Seasonic X-460FL 80PLUS Gold Modular Fanless Power Supply

http://feedback.ebay.ca/ws/eBayISAPI...onthelam7&iid=
http://heatware.com/eval.php?id=44147
Reply With Quote
  #4 (permalink)  
Old October 3, 2010, 06:49 AM
bvsbutthd101's Avatar
MVP
 
Join Date: Jun 2010
Posts: 389

My System Specs

Default

Quote:
Originally Posted by shayan288 View Post
Hey all,

I had been a Nvidia user all my life,
and I had finally decided that I wanted more power than my 460,
and switch the the HD5970. I was expecting to max every with a steady 60 FPS at least !

I must say that I am pretty dissapointed. Almost every game i have played, has given me shitty framerate,
except for crysis warhead, and bad company 2.

I had just picked up dead rising 2, and right when I played it, I decided that I needed to post about this.
I am getting bloody 8800gt speeds on this game. (same with gta 4; which I was getting less than 20 fps average). In dead rising 2. I am averaging at 18FPS on max with max AA and blur on. With max, with AA off and blur off, I get an average of 28 FPS.

Its killing me guys. Any suggestions on how to fix this madness? Is this just what ATI is like?
I am currently on 10.9 drivers.
CPU is a q9550 @ 4ghz, with 4gb of ram.
If your getting good frames in crysis and BFBC2 there's no reason for low frames in dead rising 2
Reply With Quote
  #5 (permalink)  
Old October 3, 2010, 07:09 AM
bautisj's Avatar
Rookie
 
Join Date: Sep 2010
Location: Scarborough, ON
Posts: 27

My System Specs

Default

Try using 10.5 Drivers I've heard that's the most decent driver atm
__________________
Intel Core i7 2600k
ASUS P8Z68-V Pro Z68
16GB Corsair Vengeance Blue
EVGA 570HD
OCZ Vertex 3 120GB
1TB WD Black
NZXT Phantom White (Full Fan Upgrade)
Silverstone Strider 850w (GOLD)
Windows 7 Ultimate
Reply With Quote
  #6 (permalink)  
Old October 3, 2010, 07:31 AM
martin_metal_88's Avatar
Hall Of Fame
F@H
 
Join Date: Apr 2009
Location: Quebec City
Posts: 4,175

My System Specs

Default

Tryo downclocking the CPU a bit also, if it's on the limit of stability a GPU that is much more powerfull can cause some issue at this level.
__________________
Ask for more

Martin_metal_88
Colenzo : See system spec!

Odysseus : I7 860 @ 3.6Ghz || GA P55-UD5 || G.skill Ripjaws F3-16000 2000Mhz 2X2GB || Coolermaster ATCS 840 || Silverstone Strider plus 850W || WD 640 black - WD 1TB green - Samsung F3 2TB || MSI 5670 1GB Cyclone ||Coolermaster Hyper 212 + ||

Reply With Quote
  #7 (permalink)  
Old October 3, 2010, 10:38 AM
shayan288's Avatar
Allstar
F@H
 
Join Date: Oct 2008
Location: Vancouver, BC, Canada
Posts: 911
Default

Hi all.

Thanks so much for your help.

I am currently uninstalling all the drivers (including my ATI ones) in control panel.
(i had used driver sweeper before but not in safe mode and I hadn't uninstalled in control panel yet)
After I boot into safe mode, I will open my driver sweeper and clean EVERYTHING, right?
And after that, I should get 10.5? or 10.9 again?

Also what is the crossfire application profiles thing that Avid was talking about?

Thanks in advance!
__________________
The 288

Q9550 E0 stepping @ 4Ghz
Gigabyte EP45 UD3P
G.Skill pc2 8500 1066mhz RAM
Corsair TX750 Watt Power Supply
Western Digital 500gb and Seagate 500gb in RAID 0
Western Digital 250gb
Antec 1200
OCZ Vendetta 2 LGA 775 CPU cooler with bolt thru kit
XFX HD5970
Steelseries 7G Mechanical Keyboard
Samsung 305T 30 Inch 2560x1600 LCD monitor
Altec Lansing 5.1 Surround Speakers, Sennheiser HD215's, G35's
Steelseries Xai Laser Mouse
Windows 7 Ultimate x64
Reply With Quote
  #8 (permalink)  
Old October 3, 2010, 11:02 AM
Top Prospect
 
Join Date: May 2008
Location: North York, ON
Posts: 98

My System Specs

Default

In Driver Sweeper and Safe Mode, I'd say only video drivers, nvidia and ati.
__________________
Desktop: Asus Maximus V Gene | 3570K @ 4.2Ghz | 4x4GB G.Skill DDR3-1600 16GBXL 9-9-9-24 | Patriot PYRO SE 240GB SSD | Gigabyte 650ti Boost | Seasonic X-460FL 80PLUS Gold Modular Fanless Power Supply

http://feedback.ebay.ca/ws/eBayISAPI...onthelam7&iid=
http://heatware.com/eval.php?id=44147
Reply With Quote
  #9 (permalink)  
Old October 3, 2010, 11:51 AM
Lpfan4ever's Avatar
Hall Of Fame
F@H
 
Join Date: Sep 2008
Location: Calgary
Posts: 2,727

My System Specs

Default

Try the 10.5's. With those I get the best performance with my 4870x2, and I believe others can attest to that as well.
__________________
Quote:
Originally Posted by encorp
I don't know, maybe if you get a big enough compacticator you can put it in your butt and name yourself "sexbuttplug"...
Code:
<martin_metal_88> I think I am gonna sell my server
...
<firebane> i will offer pereniums mom
<firebane> slightly used
<Keltron> slightly is an understatement
<LPfan4ever> Who're you kidding...slightly?
<martin_metal_88> peri's mom, slightly used? lol...

Reply With Quote
  #10 (permalink)  
Old October 3, 2010, 01:43 PM
Avid6eek's Avatar
Top Prospect
 
Join Date: Jul 2009
Location: Schenectady, NY
Posts: 72
Default

When you go to download the drivers from AMD's website you will see links for the driver download, and if you scroll down further you will see the Crossfire profiles. These profiles are needed so that your games will support both GPUs.

Download verion 10.9. The 5000 series cards have benefited from alot of performance improvements and bug fixes since 10.5.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
New build woes Sleal Troubleshooting 11 June 28, 2009 04:25 PM
e5200 Woes curtispan Overclocking, Tweaking and Benchmarking 13 June 27, 2009 09:22 PM
Gaming woes Wolfx25 Troubleshooting 22 June 15, 2009 10:39 AM
GPU2 woes.. lemonlime HardwareCanucks F@H Team 7 May 5, 2009 06:33 AM
More nvidia woes? Jonwall Rumor Mill 36 February 15, 2009 08:07 AM