Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old September 19, 2010, 06:10 AM
Delavan's Avatar
Hall Of Fame
 
Join Date: May 2007
Location: Mtl
Posts: 1,149
Default HD5770 owners INFORM ME!

Hi,

I bought a XFX HD5770 for my daughter. It's a HD577AZNFC. It looks exactly like the reference model, but with only one crossfire tab. Anyway, no big deal. I just installed it with the Catalyst 10.9 drivers.

The 2D clocks of the 5770 (in GPU-Z) are at 400mhz CORE and 1200mhz MEMORY. I thought I would get 157mhz/300mhz, like on on my HD5870...is it just the way the 5770 is? Or is that a driver issue?

In short, is powerplay's supposed to downclock the Core/Memeory at 157/300?
__________________
i7 4770K @ 4.5GHz / Corsair H100i / Maximus VI HERO / 8GB Corsair Vengeance Red LP 1.5V 1866 / N560GTX Ti Twin FROZR II OC / Corsair Performance Pro 128GB SSD / Intel 520 120GB SSD / WD Black 640 GB storage

ROG G53SX laptop: i7 2630QM / 12GB DDR3 / GTX560m 2GB / 750GB 7200rpm (14 000 3Dmarks06)
Reply With Quote
  #2 (permalink)  
Old September 19, 2010, 07:31 AM
MVP
F@H
 
Join Date: Feb 2010
Location: Quebec
Posts: 367

My System Specs

Default

IIRC, this is the "fix" they have found to prevent the screens to flicker when using multiple display with the overclocking feature enabled.
Reply With Quote
  #3 (permalink)  
Old September 19, 2010, 09:05 AM
Delavan's Avatar
Hall Of Fame
 
Join Date: May 2007
Location: Mtl
Posts: 1,149
Default

Oh,
I see. So, if I'm using only one monitor (and always will in this case) I could run lower 2D clocks without issues?

If it's the case, which is the best driver before that "FIX"?
__________________
i7 4770K @ 4.5GHz / Corsair H100i / Maximus VI HERO / 8GB Corsair Vengeance Red LP 1.5V 1866 / N560GTX Ti Twin FROZR II OC / Corsair Performance Pro 128GB SSD / Intel 520 120GB SSD / WD Black 640 GB storage

ROG G53SX laptop: i7 2630QM / 12GB DDR3 / GTX560m 2GB / 750GB 7200rpm (14 000 3Dmarks06)
Reply With Quote
  #4 (permalink)  
Old September 19, 2010, 10:21 AM
Delavan's Avatar
Hall Of Fame
 
Join Date: May 2007
Location: Mtl
Posts: 1,149
Default

Alright,

Case closed! Seems like it's BIOs settings that are set like that. I won't bother flashing the BIOS on this...
__________________
i7 4770K @ 4.5GHz / Corsair H100i / Maximus VI HERO / 8GB Corsair Vengeance Red LP 1.5V 1866 / N560GTX Ti Twin FROZR II OC / Corsair Performance Pro 128GB SSD / Intel 520 120GB SSD / WD Black 640 GB storage

ROG G53SX laptop: i7 2630QM / 12GB DDR3 / GTX560m 2GB / 750GB 7200rpm (14 000 3Dmarks06)
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
[WTB] XFX ATI HD5770 1GB Anima Buy/Sell & Trade 9 August 27, 2010 03:42 PM
[WTB] . zoob Buy/Sell & Trade 4 July 29, 2010 08:17 AM
Wolfdale1333 and HD5770 xktox CPU's and Motherboards 6 June 23, 2010 07:07 PM
PowerColor Launches HD5770 Eyefinity 5 Card FiXT Press Releases & Tech News 6 March 22, 2010 02:01 PM
ASUS Revises Their HD5770 With a New Cooler Soultribunal Press Releases & Tech News 8 December 17, 2009 06:36 AM