Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old April 26, 2010, 03:18 PM
Top Prospect
 
Join Date: Jan 2009
Posts: 74

My System Specs

Default Sapphire 5870 and power supply buzzing

I just got a 5870 and I get coil whines like crazy on my Corsair HX620. I am running a Phenom II 940 @ 3.6ghz with 1 hdd only. My 260gtx was making my power supply whine but not that much. The 5870 is really louder. I heard this is normal but not sure. Anyone else have problem ? I almost got a Gtx 470 and I am happy I did not.... it would of exploded my power supply. LOL
Reply With Quote
  #2 (permalink)  
Old April 26, 2010, 03:36 PM
Arinoth's Avatar
Moderator
F@H
 
Join Date: May 2009
Location: Richmond Hill
Posts: 8,539

My System Specs

Default

If this was happening with a previous graphics card, one that consumes less power then the 5870, then i would suspect that something is wrong with your power supply. Try running booting the system bare bones to see if you get the whine, i suspect your psu is having issues supplying enough current on the 12V rail
Reply With Quote
  #3 (permalink)  
Old April 26, 2010, 03:46 PM
fishingfanatic's Avatar
Hall Of Fame
 
Join Date: Mar 2010
Location: Hamilton Ont
Posts: 1,221

My System Specs

Smile 5870 and psu buzzing

I think the previous comment sounds accurate, but I couldn't speak with any expertise because my technical skills are still lacking. However, when you get this sorted, please let us know.
Reply With Quote
  #4 (permalink)  
Old April 26, 2010, 04:21 PM
Banned
F@H
 
Join Date: Sep 2009
Location: Montreal, QC
Posts: 5,415

My System Specs

Default

Coil whine is basically just a manufacturing thing, and you happen to be unlucky enough to have a PSU that exhibits a severe case of it. It's not bad for your hardware, but if it's really annoying, contact Corsair and they'll take care of you.
Reply With Quote
  #5 (permalink)  
Old April 26, 2010, 05:03 PM
Top Prospect
 
Join Date: Jan 2009
Posts: 74

My System Specs

Default

Ya I guess. I RMA the same power supply and their was still coil whine. I read that people rma 2-3 of them and whine/buzzing persists. I guess they just work that way sometimes. My friend might give me his tx750 and I will try it then. thx guys
Reply With Quote
  #6 (permalink)  
Old April 26, 2010, 10:51 PM
Top Prospect
 
Join Date: Jan 2009
Posts: 74

My System Specs

Default

Sry what I meant is that I've RMAed the power supply before when I had my 260gtx and it was making coil noise and it changed nothing. Coil whine got more extreme with 5870. I also noticed buzzing when I scroll some web pages. I might RMA the Corsair hx620 and sell the new one and just get another power supply.
Reply With Quote
  #7 (permalink)  
Old April 26, 2010, 11:15 PM
Banned
F@H
 
Join Date: Sep 2009
Location: Montreal, QC
Posts: 5,415

My System Specs

Default

Are you sure the noise is coming from the PSU and not the video card or the motherboard?
Reply With Quote
  #8 (permalink)  
Old April 26, 2010, 11:24 PM
Top Prospect
 
Join Date: Jan 2009
Posts: 74

My System Specs

Default

I put my ear next to power supply and it was that. It can get pretty loud. Whining sound.
Reply With Quote
  #9 (permalink)  
Old April 27, 2010, 12:49 PM
Top Prospect
 
Join Date: Jan 2009
Posts: 74

My System Specs

Default

Ok I just noticed all my video playback is a little grainy and sometimes slow. I did driver sweep to remove nvidia drivers. Could bad power supply cause bad video play? I use VLC and media player and run w7 64 bit.
I am using 10.4 preview drivers.
Reply With Quote
  #10 (permalink)  
Old April 27, 2010, 12:58 PM
Top Prospect
 
Join Date: Jan 2009
Posts: 74

My System Specs

Default

I fixed the minor video lag by changing power scheme to High Performance. Still a little bit grainy.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
[WTB] power supply 650+ power supply j-ronde Buy/Sell & Trade 1 March 31, 2009 09:45 AM