Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old March 26, 2010, 09:13 PM
Trial Member
 
Join Date: Mar 2010
Posts: 1
Default Why would a 8600gt work on my PC and a HD 5670 wouldn't? What could be the reason?

Today my new card arrived: HD 5670. I installed it on my computer and turned it on. My monitor does receive a signal from the HD 5670, but the computer gets stuck on the "Press f2 to enter setup" screen. After resetting it gets stuck in the same screen but now it shows my CPU speed being 2.00GHz instead of 2.80GHz (wtf?).

My motherboard: AM2NF6G-VSTA (ASRock).

It says that the motherboard has 1 PCI-e slot (which in fact is 8x) and idk whether it is 1.0, 1.1 or 2.0 (though it's highly unlikely it is 2.0). However, I've read a lot of times that 2.0 cards are backward compatible with 1.x slots... or I am mistaken?

Also one year ago I installed a DDR2 9500gt (PCI-e 2.0) and it worked.
Reply With Quote
  #2 (permalink)  
Old March 27, 2010, 12:11 AM
MVP
 
Join Date: Dec 2009
Posts: 299

My System Specs

Default

my powercolor 5670 is pci-e 2.1, which works with 2.0(who knows with what you've got). maybe thats why or maybe has something to do with th ddr5
Reply With Quote
  #3 (permalink)  
Old March 27, 2010, 08:59 AM
Banned
F@H
 
Join Date: Aug 2007
Location: mtl
Posts: 12,694
Default

may be compatibility may be not. did you reset it or reseat it?


my bud has a pci-e comp from a 'few' years back. dude bought a new card and works fine, he had to upgrade psu tough, wich i dont think is necessarily teh case here :)
Reply With Quote
  #4 (permalink)  
Old March 27, 2010, 09:08 AM
shaw
Guest
 
Posts: n/a
Default

Did you uninstall the nvidia drivers 1st? Used DriverCleaner then? And installed the Ati drivers next?
Reply With Quote
  #5 (permalink)  
Old March 27, 2010, 09:11 AM
Banned
F@H
 
Join Date: Aug 2007
Location: mtl
Posts: 12,694
Default

i think he cant boot with it, from what i gathered
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Work only computer phantom_jo O/S's, Drivers & General Software 5 February 24, 2010 02:53 PM
New Rig (Main home school work, photoshop, gaming) computer tl9015 New Builds 9 January 30, 2010 09:12 PM
5670 at NCIx MarkOne Video Cards 5 January 18, 2010 10:22 PM
AMD ATI 5670 Pictured and Detailed FiXT Press Releases & Tech News 3 December 2, 2009 04:31 PM
Wouldn't the ISP's just love this LionRed Off Topic 33 November 3, 2009 09:04 AM