Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old March 19, 2010, 02:24 PM
Top Prospect
 
Join Date: Oct 2009
Posts: 186
Default Catalyst 10 series: Can't run OGL applications at all

Ever since I made the jump to 10.2, 10.3 leaked and 10.3 preview, I can't seem to run OpenGL games and applications at all. I get this "LoadLibrary failed with error 126: The specified module could not be found." I went back to 9.8s, and it worked. I tried uninstalling, using various different driver cleaners, and installing the 10 series again. Nothing works. I've got a 4870x2.

Any ideas?
Reply With Quote
  #2 (permalink)  
Old March 19, 2010, 10:47 PM
Hall Of Fame
 
Join Date: Oct 2007
Posts: 1,561
Default

all I can say is I got a 4890 on 10.2 and OGL works just fine
Reply With Quote
  #3 (permalink)  
Old March 20, 2010, 01:45 AM
IRQ Conflict's Avatar
Hall Of Fame
 
Join Date: Mar 2009
Location: Drayton Valley, AB
Posts: 1,454

My System Specs

Default

I take it you used Driver Sweeper? And are familiar with the way to use it?
Reply With Quote
  #4 (permalink)  
Old March 20, 2010, 03:04 AM
Banned
F@H
 
Join Date: Aug 2007
Location: mtl
Posts: 12,694
Default

Quote:
Originally Posted by IRQ Conflict View Post
I take it you used Driver Sweeper? And are familiar with the way to use it?
+1 + in safe mode, if needed
Reply With Quote
  #5 (permalink)  
Old March 28, 2010, 03:34 PM
Top Prospect
 
Join Date: Oct 2009
Posts: 186
Default

OK guys, the problem isn't getting anywhere close to being found.

I uninstalled the drivers, rebooted into safemode, ran Driver Sweeper and Driver Cleaner DOTnet, booted back into windows and installed the 10.3b's that was released a few days ago.

I still can't run any OGL programs. Is it possible to download a separate OGL driver suite for ATI?
Reply With Quote
  #6 (permalink)  
Old March 28, 2010, 04:12 PM
Hall Of Fame
 
Join Date: Oct 2007
Posts: 1,561
Default

what game are you trying to run in openGL?
Reply With Quote
  #7 (permalink)  
Old March 28, 2010, 04:17 PM
Top Prospect
 
Join Date: Oct 2009
Posts: 186
Default

Quote:
Originally Posted by LarkStarr View Post
what game are you trying to run in openGL?
Not just games. Any application that runs OGL. The same error message pops up during launch. This error 126 means that something is missing, but I can't figure out what.
Reply With Quote
  #8 (permalink)  
Old March 28, 2010, 05:15 PM
Top Prospect
 
Join Date: Oct 2009
Posts: 186
Default

I don't get it.

I go back to 9.12's, and everything works. I can run any OpenGL program/app I throw at. OK.

Then I uninstall, also using DriverClearnerDotNet under Safe Mode, reboot, install the 10.3b again, and restart.

Now the same problem. OGL doesn't work.

..........
Reply With Quote
  #9 (permalink)  
Old March 28, 2010, 06:37 PM
Top Prospect
 
Join Date: Oct 2009
Posts: 186
Default

Since Catalyst 9 works fine with OGL, I thought I'd installing the 9.12s, and install the OGL 4.0 on top of them.

I installed the 9.12, ran a OGL benchmark in a window, which fully worked. Then leaving the benchmark on, I proceeded to install the OGL 4.0's, and while the drivers were installing, the screen flickered (normal), and the benchmark stopped...

So it's definately the new drivers that's messing with my OGL..

Argh! Madness!
Reply With Quote
  #10 (permalink)  
Old March 29, 2010, 10:30 PM
Top Prospect
 
Join Date: Oct 2009
Posts: 186
Default

nudge
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Multi-Threaded Applications CMetaphor CPU's and Motherboards 21 January 13, 2010 12:27 PM
Windows 7 DirectCompute Brings GPU Accelerated Applications With NVIDIA GPUs FiXT Press Releases & Tech News 0 October 22, 2009 10:20 AM
APB Beta applications MpG Gaming 1 October 13, 2009 07:13 PM
Force applications to use certain audo device? MrFoxx Audio 2 August 6, 2009 01:00 PM
Catalyst 8.12 + Vista64 + 3 Series + Ram = Error FiXT O/S's, Drivers & General Software 28 January 21, 2009 09:57 AM