Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old February 6, 2010, 02:24 PM
Top Prospect
 
Join Date: Jan 2010
Location: Ontario/Transplant from California
Posts: 101
Default Need some driver help please. HD 5770

I just bought a Sapphire HD 5770 card and want to install it in a new system. I'm not sure if I should install the disc that came with the card, install the 10.1 catalyst from the Sapphire site or install the 10.1 drivers from the ATI site. I would like a custom install so I can pick what I want instead of a full install of all the crap that might be there. Is there a preferred driver for this card for Win 7 64 pro?
Thanks for the help.
Jim
__________________
ASUS P7P55D-E Pro - Intel i7 860 - Zalman CNPS 10X Quiet - 4gb G.Skill Ripjaws DDR3 1333 CL7-7-7-21 1.5V - Intel 520 Series 240 GB SSD - WD Caviar Black 1Tb - Corsair TX750W - Sapphire Radeon HD 5770 1 Gb GDDR5 - DVD Drives X2 LG GH24LS50 - Coolermaster CM690 II Advanced - Win 7 Pro 64
Reply With Quote
  #2 (permalink)  
Old February 6, 2010, 03:09 PM
crowTrobot's Avatar
Top Prospect
 
Join Date: Nov 2009
Location: Scarborough, Ontario
Posts: 88

My System Specs

Default

I just go for whatever the manufacturer provides for download on their site.
Reply With Quote
  #3 (permalink)  
Old February 6, 2010, 04:55 PM
cozmosland's Avatar
Top Prospect
 
Join Date: Dec 2009
Posts: 232
Default

i think they would all be the same thing
Reply With Quote
  #4 (permalink)  
Old February 6, 2010, 08:46 PM
zc1 zc1 is offline
Top Prospect
 
Join Date: Jan 2010
Location: Edmonton, Alberta
Posts: 68
Default

I Just installed the 5750s. Ran the software on the disc, then ran the Catalyst Control Centre, which takes you to the AMD website to download updates. Just about to install the updates, now.

Edit: Almost forgot to come back and give an update. Install went fine...probably could have just installed the drivers from the ATI website and been good to go.

Last edited by zc1; February 6, 2010 at 09:28 PM. Reason: Updating regarding progress
Reply With Quote
  #5 (permalink)  
Old February 6, 2010, 10:38 PM
Raserei408's Avatar
MVP
 
Join Date: Dec 2009
Location: South of the border
Posts: 495
Default

Quote:
Originally Posted by cozmosland View Post
i think they would all be the same thing
You'd think they would.
Actually, the manufacturers package the GPUs with outdated drivers. I think the 57xx cards use the Beta drivers which are now outdated.
__________________
"If dancing is sure to result in failure then you must dance anyway."
Lo Mein said that, and I think he knows a little more about dancing than I do pal, because he invented it! Then he perfected it so that no man could best him in the club of honor.
Then he used his prize money to buy two of every whore on Earth. Then he herded them all onto a boat, then they all beat the crap out of every single one of him.
Reply With Quote
  #6 (permalink)  
Old February 9, 2010, 03:00 PM
CraigRT's Avatar
Top Prospect
 
Join Date: Feb 2010
Location: London, ON
Posts: 55
Default

Quote:
Originally Posted by Raserei408 View Post
You'd think they would.
Actually, the manufacturers package the GPUs with outdated drivers. I think the 57xx cards use the Beta drivers which are now outdated.
For sure, I've been downloading drivers off the mfr websites since the nV detonator days back for TNT/TNT2 and beyond. Never bother with the disc for drivers themselves.
__________________
i7 860 + Hyper 212
P55A-UD4P F14
8GB Mushkin Silverline
Powercolor 5870
Velociraptor 150
Seagate LP 2TB
Corsair AX750
Silverstone FT01B-W (HWC review case)

HEATWARE 45-0-0

My Cannondale <3
Reply With Quote
  #7 (permalink)  
Old February 9, 2010, 04:25 PM
Top Prospect
 
Join Date: Jan 2010
Location: Ontario/Transplant from California
Posts: 101
Default

I downloaded the 10.1 suite from the AMD site and things looked good except for the sudden crash and the screen goes bright white! I'm not a pro at this but in all the years I've messed with computers ATI drivers have been a problem. Looks like things haven't changed! Does anybody have a driver version they like for this card (Sapphire HD 5770) The one that came with the card was 9.11. Also is it better to remove the driver completely (if it can be done without corrupting my OS).
Thanks
Jim
__________________
ASUS P7P55D-E Pro - Intel i7 860 - Zalman CNPS 10X Quiet - 4gb G.Skill Ripjaws DDR3 1333 CL7-7-7-21 1.5V - Intel 520 Series 240 GB SSD - WD Caviar Black 1Tb - Corsair TX750W - Sapphire Radeon HD 5770 1 Gb GDDR5 - DVD Drives X2 LG GH24LS50 - Coolermaster CM690 II Advanced - Win 7 Pro 64
Reply With Quote
  #8 (permalink)  
Old February 9, 2010, 07:22 PM
zc1 zc1 is offline
Top Prospect
 
Join Date: Jan 2010
Location: Edmonton, Alberta
Posts: 68
Default

Similar thing (though opposite -- black, not white) happened with one of the driver packages during my install. I just gave it a couple of minutes to make sure it was done fooling around, then reset the system and ran it again. The second time around it blacked out for just a few seconds, then refreshed and everything was good.
Reply With Quote
  #9 (permalink)  
Old February 9, 2010, 07:46 PM
Raserei408's Avatar
MVP
 
Join Date: Dec 2009
Location: South of the border
Posts: 495
Default

If this is related to the "GSOD" (though I thought they were only in 58xx cards) they recently released a hotfix driver to correct the issue.
__________________
"If dancing is sure to result in failure then you must dance anyway."
Lo Mein said that, and I think he knows a little more about dancing than I do pal, because he invented it! Then he perfected it so that no man could best him in the club of honor.
Then he used his prize money to buy two of every whore on Earth. Then he herded them all onto a boat, then they all beat the crap out of every single one of him.
Reply With Quote
  #10 (permalink)  
Old February 9, 2010, 08:02 PM
Top Prospect
 
Join Date: Jan 2010
Location: Ontario/Transplant from California
Posts: 101
Default

I've looked on the AMD site but couldn't find anything. The 58XX driver is different.
Jim
__________________
ASUS P7P55D-E Pro - Intel i7 860 - Zalman CNPS 10X Quiet - 4gb G.Skill Ripjaws DDR3 1333 CL7-7-7-21 1.5V - Intel 520 Series 240 GB SSD - WD Caviar Black 1Tb - Corsair TX750W - Sapphire Radeon HD 5770 1 Gb GDDR5 - DVD Drives X2 LG GH24LS50 - Coolermaster CM690 II Advanced - Win 7 Pro 64
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Asus 5770 card Olorin Video Cards 36 January 4, 2010 07:47 AM
Quick: 4890 or 5770? CroSsFiRe2009 Video Cards 12 December 29, 2009 07:32 PM
XFX 5770 Unknownm Video Cards 10 December 28, 2009 10:48 PM
Radeon 5770 V2 models Fudd Rucker Video Cards 0 December 17, 2009 01:04 PM
Temperatures: HD 5770 vs HD 5850? jwebby Video Cards 11 October 23, 2009 04:49 PM