Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old December 19, 2009, 05:08 PM
Rookie
 
Join Date: Oct 2008
Posts: 9
Default Unstable Video Card (Sapphire HD3870)

Hi guys, I just upgraded my video card to a Sapphire HD3870 and now I cannot do anything that involves 3d.

The card is a hand me down from my little brother (he gets my old clothes, I get his old GPUs). He is a gamer and has been using it for quite a while with no problems at all.

Now that it is in my machine it crashes as soon as anything 3d starts. it idles at 45C and the best 3d I've got it to run is Furmark for 57 seconds in a 640 x 480 window. The temp crept steadily up to 71C and the it crashed.

When it crashes the computer just freezes (colours don't change, nothing goes black, everything just stops) and I hear the fan go crazy (even though the temps reported from furmark seem fine).

I have all the most recent drivers and the card runs ok for regular computer use (internet and the like). On occasion the screen does go black for a couple seconds and then a window appears telling me the device stopped responding and that it has been restarted and everything works fine. A little annoying, a little disconcerting, but nothing that significantly impacts my use.

Does anyone have any idea how to fix this?

Thanks a bunch,

Sloth

PS. Everything else on my system is very stable and runs at decent temps. I run a E8400, 4 gig ram, Windows XP (32-bit) SP3
Reply With Quote
  #2 (permalink)  
Old December 19, 2009, 05:17 PM
sswilson's Avatar
Moderator
F@H
 
Join Date: Dec 2006
Location: Moncton NB
Posts: 14,797

My System Specs

Default

Do you have any software that allows you to manually set the fan speed? I've had several older sapphire cards which needed the fanspeed to be set higher than the auto settings.
__________________
MSI Z87I Gaming AC / i7 4770K / 2X 8G Gskill 1866 Sniper / XFX XTR 750 / EVGA GTX 680 SC+ 2GB / Intel DC S3700 200G / Seagate Barracuda 1TB
Inwin 904 / Swiftech MCP655-b / Alphacool NexXxos XT45 120 Rad / 2X Scythe GT AP-15 / EK Supreme HF / Dell UltraSharp U2412M

Asrock AM1H-ITX / AM1 Athlon 5350 / 2X4G Gskill PC3-14900 / Intel 6235 Wi-Fi / 90W Targus Power Brick / 250G Samsung 840 Series SSD / Mini-Box M350 / 1X 22" Dell IPS / 1X 22" HP
Reply With Quote
  #3 (permalink)  
Old December 19, 2009, 05:44 PM
Rookie
 
Join Date: Oct 2008
Posts: 9
Default

What would you suggest???
Reply With Quote
  #4 (permalink)  
Old December 19, 2009, 05:53 PM
sswilson's Avatar
Moderator
F@H
 
Join Date: Dec 2006
Location: Moncton NB
Posts: 14,797

My System Specs

Default

Riva tuner, or depending on the card you might have the option in ATI's CCC.
__________________
MSI Z87I Gaming AC / i7 4770K / 2X 8G Gskill 1866 Sniper / XFX XTR 750 / EVGA GTX 680 SC+ 2GB / Intel DC S3700 200G / Seagate Barracuda 1TB
Inwin 904 / Swiftech MCP655-b / Alphacool NexXxos XT45 120 Rad / 2X Scythe GT AP-15 / EK Supreme HF / Dell UltraSharp U2412M

Asrock AM1H-ITX / AM1 Athlon 5350 / 2X4G Gskill PC3-14900 / Intel 6235 Wi-Fi / 90W Targus Power Brick / 250G Samsung 840 Series SSD / Mini-Box M350 / 1X 22" Dell IPS / 1X 22" HP
Reply With Quote
  #5 (permalink)  
Old December 19, 2009, 06:05 PM
Arinoth's Avatar
Moderator
F@H
 
Join Date: May 2009
Location: Halifax
Posts: 8,607

My System Specs

Default

What is the rest of your system (including and rather importantly your power supply). You could be maxing the load of your power supply and may need a new one.
Reply With Quote
  #6 (permalink)  
Old December 19, 2009, 06:07 PM
Rookie
 
Join Date: Oct 2008
Posts: 9
Default

I've underclocked it to 600 mzh, using the catalyst control centre. After 10 minutes of running furmark at 1280 x 1024 in a window, the temp has stabilized at 79C under full load at an average of 51 fps. The fan is going pretty loud. I guess it is a fan issue on an old card.

Unsatisfactory, but I don't know if there is much else I can do.

Thanks to anybody who gave thought to this.

Sloth
Reply With Quote
  #7 (permalink)  
Old December 19, 2009, 06:08 PM
Rookie
 
Join Date: Oct 2008
Posts: 9
Default

I have a 500W power supply that is a year old. I don't think it is a power issue, but I don't know much about power supplies. Oh, and a P5Q Pro mobo.
Reply With Quote
  #8 (permalink)  
Old December 19, 2009, 07:30 PM
sswilson's Avatar
Moderator
F@H
 
Join Date: Dec 2006
Location: Moncton NB
Posts: 14,797

My System Specs

Default

depending on the card, some of the power regulation cct on sapphire cards are strictly to reference, and power supply can greatly affect it (regs can't clean dirty power coming from power supply). you may find that a higher end power supply resolves the issue.
__________________
MSI Z87I Gaming AC / i7 4770K / 2X 8G Gskill 1866 Sniper / XFX XTR 750 / EVGA GTX 680 SC+ 2GB / Intel DC S3700 200G / Seagate Barracuda 1TB
Inwin 904 / Swiftech MCP655-b / Alphacool NexXxos XT45 120 Rad / 2X Scythe GT AP-15 / EK Supreme HF / Dell UltraSharp U2412M

Asrock AM1H-ITX / AM1 Athlon 5350 / 2X4G Gskill PC3-14900 / Intel 6235 Wi-Fi / 90W Targus Power Brick / 250G Samsung 840 Series SSD / Mini-Box M350 / 1X 22" Dell IPS / 1X 22" HP
Reply With Quote
  #9 (permalink)  
Old December 27, 2009, 10:13 AM
Rookie
 
Join Date: Oct 2009
Posts: 11
Default

well i got a 3870 Sapphire light in my wifes comp and have never had any problems other then it wanting to set up sound from the card (long long story) and there is no fan control speed on that card atleast not in ccc but i was told you can set up a profile and put what fan speed you want on it but that's all i can help out with you should be able to run most anything i play call of duty modern warfare 2 on that rig
Reply With Quote
  #10 (permalink)  
Old December 27, 2009, 10:58 AM
jcmaz's Avatar
Hall Of Fame
F@H
 
Join Date: Feb 2009
Location: Vancouver, BC
Posts: 2,455

My System Specs

Default

Quote:
Originally Posted by KaosMage View Post
well i got a 3870 Sapphire light in my wifes comp and have never had any problems other then it wanting to set up sound from the card (long long story) and there is no fan control speed on that card atleast not in ccc but i was told you can set up a profile and put what fan speed you want on it but that's all i can help out with you should be able to run most anything i play call of duty modern warfare 2 on that rig
Please use paragraphs and spaces and DO NOT bold the whole thing, just the ones you want to highlight.

Rivatuner might help set fan speed. RivaTuner
__________________
“Wise men speak because they have something to say; Fools because they have to say something.”

-Plato
Reply With Quote
Reply


Tags
gpu , stability , temperature , temps , video card

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sapphire Launching HD 5750 Vapor-X Video Card FiXT Press Releases & Tech News 8 October 30, 2009 09:16 PM
[FS] Sapphire 4870 512mb video card. 10% discount for HWC folders. chrisk Buy/Sell & Trade 12 November 29, 2008 10:33 PM