Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old April 23, 2009, 10:12 PM
Top Prospect
 
Join Date: Dec 2008
Posts: 76
Default 9800gtx+ sc/Nvidia driver issues?

Hey everybody,

Recently I noticed a drop in framerates and even outright freezing in some games. I'm using a Evga 9800gtx+ sc edition. I had a similar problem back when I first got my card, however when I used rivatuner to turn up the fan speed the problem went away. Just recently these problems returned and the fan speed would no longer help. I noticed this just after I installed the latest Nvidia drivers, released April 2nd I think. I was wondering if anybody else had a similar problem?

Thanks!
__________________
Antec 900
Intel Core i5 @ 2.66GHz
Asus P7P55D motherboard
EVGA 9800 GTX+ Superclocked
4GB of Patriot Viper II DDR3 RAM
2X320 GB Western Digital @ 7200 RPM
Plextor DVD +/- RW
Corsair TX 750 W power supply
Windows 7-64
Reply With Quote
  #2 (permalink)  
Old April 23, 2009, 10:33 PM
Jake_HT's Avatar
Hall Of Fame
F@H
 
Join Date: May 2008
Location: Calgary, AB
Posts: 1,985

My System Specs

Default

How are the temperatures on the card while you're gaming? Maybe it's time for a dust cleaning?
__________________
http://jakeht.deviantart.com/
Reply With Quote
  #3 (permalink)  
Old April 23, 2009, 11:47 PM
Realityshift's Avatar
Hall Of Fame
F@H
 
Join Date: Feb 2009
Location: Fort McMurray, AB
Posts: 2,486
Default

I have one of those cards but I have been running SLI since the new drivers so I guess I havent noticed =( I might pull the 9800GTX out and test to see if I notice a change.

+1 to what jake says it could be time for some dust cleaning, these cards tend to do some strange stuff when they get warm.
__________________
The Builders Hammer
Asrock P67 Fatal1ty, Intel i5 2500K @ 5.1ghz, 16gb HyperX 1600 CL8, Evga GTX 580 SC SLIed and water-cooled, HX850, Crucial M4 64gb, 640 black, 1tb + 3x 2tb greens, Haf X.


BF BC2: Bishop_SHIFT, Steam: Realityshift84, Xbox Live - SHIFTEDone84 ... Come play.
Reply With Quote
  #4 (permalink)  
Old April 24, 2009, 08:00 AM
werty316's Avatar
MVP
F@H
 
Join Date: Apr 2007
Posts: 427
Default

No problems here with my 9800GTX+ running the latest WHQL display drivers(182.50)

Check your GPU temps.
Check for dust accumulation on the GPU's cooler.
__________________
If you can see Chuck Norris, he can see you. If you can't see Chuck Norris you may be only seconds away from death.
Reply With Quote
  #5 (permalink)  
Old April 24, 2009, 08:18 PM
Top Prospect
 
Join Date: Dec 2008
Posts: 76
Default

Well this is an excellent little problem that has arisen. So I gave my pc the canned air treatment. First boot up after that it locks up when I open firefox. Oooooya.

Edit: and the processor speed is now @ 3.17 intead of 3.16. Don't know how that happened.

EditX2: Ok, so I turned off the power supply, and when I turned the pc back on after this it somehow worked. Still having trouble with the graphic card. Is there a driver archive on nvidia?
__________________
Antec 900
Intel Core i5 @ 2.66GHz
Asus P7P55D motherboard
EVGA 9800 GTX+ Superclocked
4GB of Patriot Viper II DDR3 RAM
2X320 GB Western Digital @ 7200 RPM
Plextor DVD +/- RW
Corsair TX 750 W power supply
Windows 7-64

Last edited by Wolfx25; April 24, 2009 at 08:52 PM.
Reply With Quote
  #6 (permalink)  
Old April 24, 2009, 08:49 PM
Realityshift's Avatar
Hall Of Fame
F@H
 
Join Date: Feb 2009
Location: Fort McMurray, AB
Posts: 2,486
Default

I had that issue when my ram wasnt passing memtest, soon as something started to utilize ram everything froze =(
__________________
The Builders Hammer
Asrock P67 Fatal1ty, Intel i5 2500K @ 5.1ghz, 16gb HyperX 1600 CL8, Evga GTX 580 SC SLIed and water-cooled, HX850, Crucial M4 64gb, 640 black, 1tb + 3x 2tb greens, Haf X.


BF BC2: Bishop_SHIFT, Steam: Realityshift84, Xbox Live - SHIFTEDone84 ... Come play.
Reply With Quote
  #7 (permalink)  
Old April 24, 2009, 09:12 PM
mchutch's Avatar
MVP
 
Join Date: Jan 2008
Location: NW Ontario
Posts: 433

My System Specs

Default

After compressed air treatment? I'd check all the cables and make sure there tight. If only gfx troubling now, scrub and re-install the newest WHQL forceware drivers. in Vista I read you should install > uninstall > install the same driver to completely get rid of remnants, but I myself use driver cleaner pro.
Reply With Quote
  #8 (permalink)  
Old April 24, 2009, 10:23 PM
Top Prospect
 
Join Date: Dec 2008
Posts: 76
Default

K I just decided to reinstall everything, chipset drivers, actual drivers, sound drivers, the lot. Hopefully this solves the issue, and all that will be left to do is reconfigure RivaTuner.

EDIT: reinstalled the drivers, but I'm still getting chop and lag in some games, mainly source and trackmania. Far cry 2 played ok, with the odd artifact. What could possibly be causing this? Could the video card it's self simply be bad?
__________________
Antec 900
Intel Core i5 @ 2.66GHz
Asus P7P55D motherboard
EVGA 9800 GTX+ Superclocked
4GB of Patriot Viper II DDR3 RAM
2X320 GB Western Digital @ 7200 RPM
Plextor DVD +/- RW
Corsair TX 750 W power supply
Windows 7-64

Last edited by Wolfx25; April 24, 2009 at 10:53 PM.
Reply With Quote
  #9 (permalink)  
Old April 24, 2009, 11:16 PM
Realityshift's Avatar
Hall Of Fame
F@H
 
Join Date: Feb 2009
Location: Fort McMurray, AB
Posts: 2,486
Default

Dont use rivatuner, precision works awesome for overclocking these cards and setting up fan speeds and what not.

What are you running your fans at? and what is your card overclocked to? Theres only 2 games that my single 9800GTXs cant play with high graphics and 40+ fps and thats crysis and crysis WH.
__________________
The Builders Hammer
Asrock P67 Fatal1ty, Intel i5 2500K @ 5.1ghz, 16gb HyperX 1600 CL8, Evga GTX 580 SC SLIed and water-cooled, HX850, Crucial M4 64gb, 640 black, 1tb + 3x 2tb greens, Haf X.


BF BC2: Bishop_SHIFT, Steam: Realityshift84, Xbox Live - SHIFTEDone84 ... Come play.
Reply With Quote
  #10 (permalink)  
Old April 24, 2009, 11:23 PM
Top Prospect
 
Join Date: Dec 2008
Posts: 76
Default

My fan speeds are usually running at 85-95% speed, and the card is OC'ed to whatever the "stock" settings are for the Superclocked edition. I had a problem similar to this before, but once I started turning up the fan speed it went away. It seems like the main issues are on source games.
__________________
Antec 900
Intel Core i5 @ 2.66GHz
Asus P7P55D motherboard
EVGA 9800 GTX+ Superclocked
4GB of Patriot Viper II DDR3 RAM
2X320 GB Western Digital @ 7200 RPM
Plextor DVD +/- RW
Corsair TX 750 W power supply
Windows 7-64
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
[WTB] Nvidia 9800GTX element291 Buy/Sell & Trade 2 January 13, 2009 04:05 PM
NVIDIA CUDA driver and Windows Home Server Xilikon Video Cards 1 October 9, 2008 01:40 PM
Nvidia 9800GTX+ planned for 229$ Jackquelegs Video Cards 4 June 19, 2008 02:57 PM
NVidia offers an explanation about driver holdup Babrbarossa O/S's, Drivers & General Software 20 April 22, 2008 03:16 PM
Nvidia driver 158.45 overclock warning ragenrok Overclocking, Tweaking and Benchmarking 7 June 17, 2007 06:49 PM