Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old March 2, 2009, 02:43 PM
cwestwell's Avatar
Allstar
F@H
 
Join Date: May 2008
Location: NWT
Posts: 675
Default Mixing Manufactures in CF

I just want to confirm this...I have not found any info saying this is terrible on-line yet but I thought I would post to the masters and see if anyone knows of any issues with this.

I am looking to add another 4870X2 to my system I currently am running a Diamond stock card and was looking to add a stock Powercolor or XFX card does anyone know of any issues with this or have personally had any grief mixing manufactures..I know they are likely the same card and board just re-branded but I am suspicious of Diamond on this one...
__________________
_______________________________________________

E8600 420x10 |Thermalright 120 Black | Maximus Formula | ATI 4870X2 | 4GB Buffalo FireStiX PC8500 | Corsair HX1000 | Lian Li V2010B | Vista Ultimate 64bit


Q6600 334x9 |Thermaltake Blu Orb | ASUS P5Q-PRO| ATI 2900XT | 6GB Corsair XMS2 PC6400 | Corsair HX520 | Lian Li V600B | Vista Home Premium 64bit

Reply With Quote
  #2 (permalink)  
Old March 2, 2009, 03:15 PM
Eldonko's Avatar
Hardware Canucks Reviewer
 
Join Date: Apr 2007
Location: Calgary, AB
Posts: 5,442
Default

Ive mixed and it worked fine.
__________________
Donkeys kill more people annually than plane crashes or shark attacks.
Reply With Quote
  #3 (permalink)  
Old March 2, 2009, 03:47 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,815

My System Specs

Default

Yup perfectly fine. I run HIS and Diamond HD4850s.

I even run them at different clocks...
Reply With Quote
  #4 (permalink)  
Old March 2, 2009, 04:38 PM
..'Ant'..'s Avatar
Top Prospect
 
Join Date: Nov 2007
Location: Laval,QC
Posts: 129

My System Specs

Default

Should be fine as long its the same card.
__________________

Reply With Quote
  #5 (permalink)  
Old March 2, 2009, 06:07 PM
Banned
F@H
 
Join Date: Jun 2007
Location: Edmonton
Posts: 1,628
Default

We do have another thread here with a user with 4780 1gb cards that are not working, and I have seen a few other issues, seemingly all related to XFX cards.

As all 4800-series cards are recognized as "4800-series", there seems to be sone issues with Vista itself when mixing cards.

This is contrary to what ATI had previously with Crossfire, and even then, they do say that all 4850/4670/4870 etc, etc, should work in pairs, but for some reason this is not working fully.

So, if you plan to get dual cards, try to get the same brand as well, to avoid any issues.
Reply With Quote
  #6 (permalink)  
Old March 2, 2009, 06:40 PM
JD's Avatar
JD JD is offline
Moderator
F@H
 
Join Date: Jul 2007
Location: Toronto, ON
Posts: 6,815

My System Specs

Default

Quote:
Originally Posted by cadaveca View Post
We do have another thread here with a user with 4780 1gb cards that are not working, and I have seen a few other issues, seemingly all related to XFX cards.

As all 4800-series cards are recognized as "4800-series", there seems to be sone issues with Vista itself when mixing cards.

This is contrary to what ATI had previously with Crossfire, and even then, they do say that all 4850/4670/4870 etc, etc, should work in pairs, but for some reason this is not working fully.

So, if you plan to get dual cards, try to get the same brand as well, to avoid any issues.
Couldn't you just flash the BIOS and make the other card have the same manufacturer ID? Assuming they are both reference models of course. Or manually edit the BIOS accordingly if they are non-reference cards.
Reply With Quote
  #7 (permalink)  
Old March 2, 2009, 07:26 PM
Banned
F@H
 
Join Date: Jun 2007
Location: Edmonton
Posts: 1,628
Default

Well, we got digital PWM and analogue, and of course, because the digi is software controlled, the bios is a bit different, so I think as long as you stay within the same PCB, it's all good, but that thread with dude with XFX card and HIS card, both seemingly reference Digi-PWM, I'm a little leary...


I have dual analogue PWM cards, and have had no issues in getting Crossfire to work.


I will say though...getting another 4870x2? NOT a good idea(I had numerous issues when I bought two at release, turns out it is my board, but stil..). After 2 gpus, the scaling drops HARD, unless you are running 2560x1600, and even then, it might be better to await the 5xxx-gen cards...even a single 4870 has very few issues running most games @ 1920x1080...
Reply With Quote
  #8 (permalink)  
Old March 3, 2009, 07:09 AM
cwestwell's Avatar
Allstar
F@H
 
Join Date: May 2008
Location: NWT
Posts: 675
Default

Cool thanks everyone...just the answers I was looking for. I assumed this would be fine as long as it was the same PCB but it is good to here many people have had this work...I am especially intrigued by Jdrom's running the 2 card at different speeds that's awesome.
__________________
_______________________________________________

E8600 420x10 |Thermalright 120 Black | Maximus Formula | ATI 4870X2 | 4GB Buffalo FireStiX PC8500 | Corsair HX1000 | Lian Li V2010B | Vista Ultimate 64bit


Q6600 334x9 |Thermaltake Blu Orb | ASUS P5Q-PRO| ATI 2900XT | 6GB Corsair XMS2 PC6400 | Corsair HX520 | Lian Li V600B | Vista Home Premium 64bit

Reply With Quote
  #9 (permalink)  
Old March 3, 2009, 10:35 AM
Jackquelegs's Avatar
Hall Of Fame
F@H
 
Join Date: Jan 2008
Location: Burnaby, BC
Posts: 2,590

My System Specs

Default

I'm mixing a Palit dual sonic 4870 with sapphire 4870. It refuses to work under vista64, but works fine in XP64
__________________
Iapetos
Intel Core i7 930 D0 4.2ghz, Corsair XMS3 6X2GB DDR3-1600 CL 8-8-8-24, Xfire HD5870, Intel X-25M 34nm 80gb, Enermax Revolution85+ 1050W, Xonar D2X

Zephyranthes
E8400 4.0ghz, XFX 780i, Mushkin XP2 PC-6400, Antec Earthwatts 750W

Reply With Quote
  #10 (permalink)  
Old March 3, 2009, 10:44 AM
Banned
F@H
 
Join Date: Jun 2007
Location: Edmonton
Posts: 1,628
Default

with the palit cards, and the dual bios, I'm not surprised there are issues.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mixing ram? Cadence RAM 14 December 9, 2008 02:40 PM