Go Back   Hardware Canucks > HARDWARE > Video Cards

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old December 19, 2008, 03:47 AM
Rookie
 
Join Date: Dec 2008
Posts: 3
Default 4870x2 artifacts in some games

Sorry for my English
Here is my system
GIGABYTE GA-EP45-UD3R/ P45+
INTEL Q9550 CORE2QUAD 2.83GHZ S775
ZALMAN CPU COOLER 775/AM2/754/939/940
A-DATA 2x2GB DDRII Over Clock Extreme Edition DDR2 1066+
WD CAVIAR SE16 750GB SATA2 7200RPM 16MB
ASUS 4870X2 DUAL GPU PCIE 2048M GDDR5
Fortron EPSILON 700W (80PLUS) ATX12V v2.2, EPS 12V 2.91

I see some blue artifacts on screen in games like Frontlines, Brothers in arms and in 3dmark vantage
When i disable Catalyst a.i. blue artifacts disapears, but with Catalyst a.i. disabled i also disabling secind gpu core (i reed it on google). I would like to receive so coments, maybe its bad card.




Reply With Quote
  #2 (permalink)  
Old December 19, 2008, 05:45 AM
Babrbarossa's Avatar
Hall Of Fame
F@H
 
Join Date: Dec 2006
Location: New Brunswick
Posts: 3,673

My System Specs

Default

Hi- welcome to the forum! Have you installed the latest drivers? Have you overclocked the card?
Reply With Quote
  #3 (permalink)  
Old December 19, 2008, 03:21 PM
belgolas's Avatar
Hall Of Fame
F@H
 
Join Date: May 2007
Location: St. Thomas Ontario close to london
Posts: 3,925

My System Specs

Default

First thing is to check temps. I know for L4D I had to disable CAT AI because textures were flashing but crysis is fine.
__________________

Sponsor a child!
Fight poverty.

Qoute by Perineum
"ID10T. I just BETCHA he's got 9 toolbars on his web browser right now."
Reply With Quote
  #4 (permalink)  
Old December 21, 2008, 10:51 PM
Rookie
 
Join Date: Dec 2008
Posts: 3
Default

My card is not oveclocked, drivers 8.12, temp under load is 80-84 c.
Reply With Quote
  #5 (permalink)  
Old December 22, 2008, 05:01 AM
morphine's Avatar
Top Prospect
 
Join Date: Jun 2007
Location: Mississauga
Posts: 171
Default

I had a similar issue with a Sapphire 4870X2.

With Catalyst AI turned on, the card would artifact and then lockup, in everything (various games, benchmark utilities).

With Catalyst AI turned off (disabling the second GPU), the card was fine.

I had to RMA it back to Sapphire.
Reply With Quote
  #6 (permalink)  
Old December 22, 2008, 05:44 AM
Chilly's Avatar
Hall Of Fame
F@H
 
Join Date: Sep 2007
Location: Ontario
Posts: 2,593
Default

Sounds like one of the GPU's might be defective. I say try rolling back to the 8.11, there was some issues with the 8.12 series, not sure if it affected the 4870X2's but its worth a try. Failing that, I'd RMA it.

Remove and clean out the 8.12's
Install 8.11 catalyst drivers
Test again
If still artifacting, RMA it.
Reply With Quote
  #7 (permalink)  
Old December 23, 2008, 01:45 AM
Rookie
 
Join Date: Dec 2008
Posts: 3
Default

But it artifacting only in some games like: brothers in arms, left for dead, frontlines. Crysis and dead space looks fine vith catalyst A.I. enabled. I have tried 8.11, same problem.
Reply With Quote
  #8 (permalink)  
Old December 23, 2008, 08:40 AM
Cranky's Avatar
Top Prospect
 
Join Date: Nov 2008
Location: Windsor Ontario
Posts: 149
Default

It really doesn't matter that it is only artifacting in certain games, just follow Chilly's advice. With your heat well, and checked it's pretty much all you can do at this point.
__________________
Asus P5K Deluxe / Intel Core2Quad Q9550@8x425@3400mhz(1.225v) / Arctic Cooling Freezer 7 Pro / 4Gigs DDR2 1066mhz(5-5-5-15) Corsair Dominator / Diamond HD4870x2 / Asus Xonar / WD Raptor 74gb / Hitachi 160GB / Antec Quattro 850w / Logitech Z-680 5.1 / Dell Ultrasharp 24" / 2 LG Optical Drives / Vista Ultimate 32bit / A tower that's been drilled, cut, and bent to fit all of my fans
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: NDS lite package, PS3 games+accessories, PC games+accessories... 56k BEWARE snaggletooth Buy/Sell & Trade 9 November 25, 2009 09:21 PM
4870X2 renoracer Buy/Sell & Trade 16 September 19, 2008 03:41 PM
Water cooled my 8800GTX, getting artifacts now... help ragenrok Water Cooling 5 September 11, 2008 10:50 PM
4870x2??? triumph Video Cards 1 July 26, 2008 10:11 AM
Artifacts in ATI tool? magictorch Troubleshooting 7 February 25, 2008 12:33 PM