Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Troubleshooting (http://www.hardwarecanucks.com/forum/troubleshooting/)
-   -   BIOSHOCK PC - An Unstable P.O.C. ? (http://www.hardwarecanucks.com/forum/troubleshooting/8973-bioshock-pc-unstable-p-o-c.html)

DarKStar July 30, 2008 04:08 PM

BIOSHOCK PC - An Unstable P.O.C. ?
 
Recently built my 2 new systems from scratch,

ASUS M2N SLI Deluxe
AMD Athlon 64 x2 5600 2.8Ghz 2MB L2 (Windsor F3)
CORSAIR DHX 4GB 4-4-4-12 Dual Channel kit
SoundBlaster X-Fi Fatality Professional Gamer series
320GB SATA2 Seagate 16MB NCQ
BFG 8800GT OC 512MB

I am running Windows XP SP3 and VISTA 32 SP1 dual boot, all are fresh installs

All motherboard drivers are installed, up to date, everything is setup well.

I've put my system through memtest burnin, passed with flying colors - CPU burnin tests pass, hard disks pass, BFG 8800GT pass.

I haven't had much time to install other games, but the first one I installed was BIOSHOCK, in VISTA. everything maxed out, it's running smooth as silk, however on occasion it will pause for a fraction of a second and continue, might happen once every 10-20 minutes - I know it's NOT a graphic card issue but game itself. My card runs decent temps, it's NOT overheating - now this is frustrating me, I would be paying for 30 minutes or so and all of a sudden the game drops back to desktop with an error instruction 5x582378 gibberish tried writing to memory 0x872368 gibberish that cannot be found BS ;) Now WTF is going on here ? I have 4GB of RAM, I have ALL the latest patches in VISTA, yes it is recognizing my 4GB it says 4GB, and yes only little over 3 are useable. I have my pagefile set to system managed, yes, on the same partition as VISTA. Sometimes I don't save game, and when it does that I have to start over to my previous saved game. I would be playing a while and same thing. Anybody else have this problem ? It's a shame because the game runs extremely well and when it does crash I immediately check temps and everything is fine ! No I am not running anything else in the background - this happens no matter was res I play in. 2K doesn'T give a CRAP about its customers, and that's the price to pay for actually buying games, game was on special, disc is fine, original is used, and yes I patched the game to version 1.1, same thing.

BTW, slightly O/T here, but I'm stuck in the game, the freezer part, I melted ALL the ice I can find, and going in circles, the gates at both end won't open!

Squeetard July 30, 2008 04:50 PM

Have you updated Bioshock to 1.1? Get the patch.

Also, go find yourself a crack, Countless people had these issues with the legal version while the people running cracked copies had none. An issue with the copy protection. Securom I think.

sswilson July 30, 2008 04:54 PM

Quote:

Originally Posted by Squeetard (Post 74463)
Have you updated Bioshock to 1.1? Get the patch.

Also, go find yourself a crack, Countless people had these issues with the legal version while the people running cracked copies had none. An issue with the copy protection. Securom I think.

Why am I not surprised?????? :angry2:

Squeetard July 30, 2008 04:59 PM

Yah, I played this game a year ago. i recall the forums swamped with angry people. I got mine from Steam and had no issues. Just the people with disks.

I also recall getting stuck in the ice room too, can't remember how though. Google 'bioshock walkthrough' and you'll get help.

DarKStar July 30, 2008 05:01 PM

Quote:

Originally Posted by Squeetard (Post 74463)
Have you updated Bioshock to 1.1? Get the patch.

;-) Yes I did mention that in my post - in fact the very last line in my post.
Updated to 1.1 - it was unstable in 1.0 and is unstable in 1.1 ! :biggrin:

Quote:

Also, go find yourself a crack, Countless people had these issues with the legal version while the people running cracked copies had none. An issue with the copy protection. Securom I think.
I have other original games that use SECUROM and have had no issues. I thought that was the opposite, people using poor cracks who have issues. Don't worry I already tried that - same issue.

I can't wait to install my other games in VISTA - I would hate to think that games in VISTA are unstable :)

DarKStar July 30, 2008 05:10 PM

Quote:

Originally Posted by Squeetard (Post 74472)
Yah, I played this game a year ago. i recall the forums swamped with angry people. I got mine from Steam and had no issues. Just the people with disks.

I also recall getting stuck in the ice room too, can't remember how though. Google 'bioshock walkthrough' and you'll get help.

lol so much for actually PAYING software - It makes me so angry that companies talk about piracy and when you actually encourage them by buying their decent games, they **** you up !

Oh well, the game cost me $25 at FS was on special. It's the retail version, and I don't think it's a securom issue as I have used other securom titles in the past no issues at all - I have many UbiSoft titles which use SecuRom - And people having issues with the protection are usually startup problems - My game starts, and I can play for a while.

This will be my last 2k games purchase ;) Since apparently this is a known problem and 2K is ignoring its customers left and right with the same bullshit "check your pagefile", they think that all their customers are dumb.

Other than that, BIOSHOCK PC is ridden with bugs and scripting glitches. I can't believe how that game passed QC! The first scripting bug is at the beginning of the first level where you need to locate a Dr. in surgery room KILL the MF and take his keys. Well if you follow him and kill him in the water sometimes his body disappears and you are STUCK because you cannot get his damn key - you need to start over and kill him away from the water. There are tons of other glitches like that - it's too bad because the graphics are amazing !

sswilson July 30, 2008 05:11 PM

Even though the discussion of a crack is based on making the game work properly rather than a way to pirate the game disk, it's starting to get close to crossing the line.

Please respect the fact that HWC does not allow discussions on this topic (especially once folks start alluding to where such hacks/cracks can be found).

DarKStar July 30, 2008 05:25 PM

Yes I never brought this up, but had to mention the fact it was tried, in response to Squeetard's suggestion of using a said crack - To be honest, if I PAY for a game and it's not working because of a copy protection issue and the game company does NOT refund my money or help me, I wouldn't have ANY guilt in using said "thing" if it made my software run as I'm sure many others here would, until certain game companies get their act together (being very polite here) and test their software before "throwing" it out to buyers.

Squeetard July 30, 2008 08:27 PM

About all I can suggest then is to try different driver versions for your Vid and sound. I know the latest soundblasters are junk/


All times are GMT -7. The time now is 03:14 PM.