Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old November 19, 2013, 06:33 PM
Rookie
 
Join Date: Oct 2008
Posts: 33
Default I think the video card is dead

So my brother came to me with an unusual problem with his PC. It's an older one just used to surf, email, etc., sort of like the public pc at his place.

Athlon x2 5000+
MSI K9A2
Diamond Radeon 6850

The problem is that the card only displays a black screen for all resolutions except for 640x480. I know this for sure since the card displays the boot tests, bios, win xp safe mode with no issues.

So at this point, I've tried:

- removing the device from device manager in safe mode, this allows me to get back to normal win xp desktop.
- changing the resolution to anything higher than 640x480 at this point results in the black screen.
- I've also tried to boot Ubuntu live mode off a usb, the same problem happens as soon as it gets to a point where monitor resolution is changed to something higher than 640x480.
- after all that I dug out my old radeon 4850 and installed it, windows and ubuntu all boot up to the correct resolutions with no problems.

My best guess at this point is that something failed in the video card but it's not a catastrophic failure. Any ideas on what else I can try before I advise my brother to just buy another card?

Edit: I forgot to mention that I had also tried 2 other PSUs. They all work with the 4850 but the 6850 exhibits the same symptoms.

Last edited by kirik; November 19, 2013 at 06:47 PM.
Reply With Quote
  #2 (permalink)  
Old November 19, 2013, 06:43 PM
Bond007's Avatar
Hall Of Fame
 
Join Date: Jun 2009
Location: Nova Scotia
Posts: 3,070

My System Specs

Default

Can you get into windows at 640x480? If so check the card temps. Really it's anyone's guess at this point.

Edit: did you try different video outputs on the card?
__________________
Desktop: Antec Three Hundred, Z77-D3H, 3570K undervolt @4.1ghz with Zalman Optima Cooler, Corsair Vengeance 2x4gb@1866mhz, HD 6950(unlocked shaders and OC'd), Bitfenix Fury 750w, WD Black 1TB, Intel 530 120GB
Away from home light Gamer: Acer Aspire 15.6", A8-3500m undervolt and OC to 2Ghz, 2x4gb Corsair Vengeance, Crucial M500 240gb
Reply With Quote
  #3 (permalink)  
Old November 19, 2013, 06:45 PM
Rookie
 
Join Date: Oct 2008
Posts: 33
Default

Yep, I can get into windows just fine. I just cleaned out the fan and heatsink and repasted so I reasonably sure that isn't an issue.
Reply With Quote
  #4 (permalink)  
Old November 20, 2013, 07:29 AM
Dzzope's Avatar
Hall Of Fame
 
Join Date: Oct 2010
Location: Irishman in Kiev, wOOoo, I'm an alien...
Posts: 2,834

My System Specs

Default

Checked the monitor? Try a different one / it on something else (using the same input and cable)
__________________
Random quotes:

AKG: "So please don't piss on people and claim its raining. "
Soullessone21: "Their the only fat bitches I ever want in my wife :)"
Reply With Quote
  #5 (permalink)  
Old November 20, 2013, 08:59 AM
Rookie
 
Join Date: Oct 2008
Posts: 33
Default

Yep, tried 3 monitors and it all does the same thing. Also tried different connections / cables.
Reply With Quote
  #6 (permalink)  
Old November 20, 2013, 09:07 AM
trodas's Avatar
MVP
 
Join Date: Feb 2008
Location: Czech republic
Posts: 352

My System Specs

Default

Probably dead caps, as the graphic card cannot power itself anymore. Unless your bro can determine the good replacements, oder them, desolder the existing ones and solder the new ones in, not doing any mistakes, then it is likely to be better to get a new card.

It is odd that I say it (because I was resuscitating even Radeon R9100 graphic card, lol Radeon R9100 recap ), but it is best bet for someone who is not skilled with hardware repairs. Besides, you can use notably cheaper card for the intended usage.
__________________
"It is dangerous to be right in matters on which the established authorities are wrong." - Voltaire
...just keep folding, just keep folding... :) my config
Reply With Quote
  #7 (permalink)  
Old November 20, 2013, 09:56 AM
Shadowmeph's Avatar
Hall Of Fame
F@H
 
Join Date: Oct 2007
Posts: 3,407

My System Specs

Default

I agree if trying different monitors and a different cables didn't work look for swollen caps on the card caps are pretty cheap .
I fixed one of my older 19" monitors by replacing two caps if it wasn't for the people on this site I probably would have tossed the thing.
Reply With Quote
  #8 (permalink)  
Old November 20, 2013, 12:00 PM
Bond007's Avatar
Hall Of Fame
 
Join Date: Jun 2009
Location: Nova Scotia
Posts: 3,070

My System Specs

Default

Quote:
Originally Posted by Shadowmeph View Post
I agree if trying different monitors and a different cables didn't work look for swollen caps on the card caps are pretty cheap .
I fixed one of my older 19" monitors by replacing two caps if it wasn't for the people on this site I probably would have tossed the thing.

Just to add one point: different monitors / different cable / and different outputs on the graphics card.
__________________
Desktop: Antec Three Hundred, Z77-D3H, 3570K undervolt @4.1ghz with Zalman Optima Cooler, Corsair Vengeance 2x4gb@1866mhz, HD 6950(unlocked shaders and OC'd), Bitfenix Fury 750w, WD Black 1TB, Intel 530 120GB
Away from home light Gamer: Acer Aspire 15.6", A8-3500m undervolt and OC to 2Ghz, 2x4gb Corsair Vengeance, Crucial M500 240gb
Reply With Quote
  #9 (permalink)  
Old November 20, 2013, 12:21 PM
Rookie
 
Join Date: Oct 2008
Posts: 33
Default

Thanks for the input! I'll pull the heatsink and shroud off tonight and see if there are any bad caps or physically damaged components.
Reply With Quote
  #10 (permalink)  
Old November 20, 2013, 03:09 PM
trodas's Avatar
MVP
 
Join Date: Feb 2008
Location: Czech republic
Posts: 352

My System Specs

Default

Take some close up photos, please. So we know, what we are dealing with.
__________________
"It is dangerous to be right in matters on which the established authorities are wrong." - Voltaire
...just keep folding, just keep folding... :) my config
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dead video card? hansy1401 Video Cards 1 September 18, 2012 05:13 PM
Dead video card? Bake it! Squeetard Video Cards 26 June 20, 2009 05:36 PM
WTB: Video Card/Sound Card/Hard drive - Look here if u gotz some ! Flintblade Buy/Sell & Trade 4 December 4, 2008 10:27 PM
Video card dead? DVI cable issue? Matty D Troubleshooting 10 March 15, 2008 01:54 PM