Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old November 9, 2013, 05:24 PM
Rookie
 
Join Date: Oct 2012
Location: Edmundston,NB
Posts: 8

My System Specs

Angry 4870x2 slow down my I5 2500K

HELP PLZ?!

since i change my old reliable 9800 GTX+ for a HD 4870x2 my computer is SO SLOW when playing game like World of warcraft,i always do Atl tab to go use Chrome for info on quest and the computer just been killed...

As soon as i quit the game,my PC return to normal.also any graphic setting in wow it's jaggy..

Dont say it's my new TX-850M i tryied it with old reliable(9800GTX+) and everything was fine.



What can it be????
Reply With Quote
  #2 (permalink)  
Old November 9, 2013, 05:27 PM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,596
Default

Your GPU is not slowing down your CPU. You need to be far more specific in details .
Reply With Quote
  #3 (permalink)  
Old November 9, 2013, 05:31 PM
Rookie
 
Join Date: Oct 2012
Location: Edmundston,NB
Posts: 8

My System Specs

Default

how do we put you entire System spec like people do often here, :S i don't recall

don't know if it can help,sorry i'm not english in first language
Reply With Quote
  #4 (permalink)  
Old November 9, 2013, 05:34 PM
Rookie
 
Join Date: Oct 2012
Location: Edmundston,NB
Posts: 8

My System Specs

Default

when i play World of warcraft,my computer become So slow,in and out of the game,normaly i do alt tab to go check thing on the net,but it slowed my computer so much.....could it be Catalyst or a bad setting i have a little Patch when playing says Crossfire x enable......is it me or a single x2 is not Crossfire???



BTW same thing in Skyrim,for the records.
Reply With Quote
  #5 (permalink)  
Old November 9, 2013, 05:36 PM
Rookie
 
Join Date: Oct 2012
Location: Edmundston,NB
Posts: 8

My System Specs

Default

when not gaming everything is ok...
Reply With Quote
  #6 (permalink)  
Old November 9, 2013, 05:36 PM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,596
Default

WoW has always sucked for alt-tabbing as do a bunch of other games. Run it in Windowed mode to fix this issue.
Reply With Quote
  #7 (permalink)  
Old November 9, 2013, 05:37 PM
Rookie
 
Join Date: Oct 2012
Location: Edmundston,NB
Posts: 8

My System Specs

Default

why does it ok on my 9800GTX+ then?????
Reply With Quote
  #8 (permalink)  
Old November 9, 2013, 05:39 PM
Rookie
 
Join Date: Oct 2012
Location: Edmundston,NB
Posts: 8

My System Specs

Default

I heard some nasty stuff about AMD driver,hope i'm not right,cause 9800GTX+ will return :(
Reply With Quote
  #9 (permalink)  
Old November 9, 2013, 05:41 PM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,596
Default

Please learn to use the edit button..

You can't compare how one card runs to another. There is so many differences it makes a huge difference.
Reply With Quote
  #10 (permalink)  
Old November 9, 2013, 05:44 PM
Rookie
 
Join Date: Oct 2012
Location: Edmundston,NB
Posts: 8

My System Specs

Default

sorry for not editing

it's just not normal that this one give me more problem than a suposedly slower 9800 GTX+......probably a driver issue somewhere,i heard Nasty stuff about Catalyst(BTW using Windows 7 64-Bit)

If anyone hear about anything like it Please post

Thanks for your help!
Reply With Quote
Reply


Tags
4870x2 slow cpu

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow ssd clshades Troubleshooting 12 December 18, 2011 10:29 AM
HWC slow ? ZZLEE Suggestions & Feedback 20 May 21, 2011 03:14 PM
HWC slow ? ZZLEE Suggestions & Feedback 1 May 20, 2011 02:27 PM
[FS] XFX 4870x2 with Arctic Cooling 4870x2 Cooler bombdigiti Buy/Sell & Trade 11 February 12, 2011 10:16 AM