Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #21 (permalink)  
Old May 10, 2013, 11:18 AM
rjbarker's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Courtenay, B.C
Posts: 5,932

My System Specs

Default

According to Purolator Tracking my RIVE Mobo has been delivered, but not to the address I put on the RMA Label, but to this address (still in Richmond on No 6 Rd mind you)..

Nedco
4455 No 6 Rd, Richmond, BC V6V 1P8

Any info why this address and not what was specified on RMA Address Label ?

Cost me $40 to ship this Board, lets see how quickly I get a working Board back ??
__________________
Introducing me n my OCD to Watercooling, is like taking an Alcoholic to an "all you can drink" Beach Bar in Mexico

.
Reply With Quote
  #22 (permalink)  
Old May 10, 2013, 11:39 AM
lowfat's Avatar
Moderator
 
Join Date: Feb 2007
Location: Grande Prairie, AB
Posts: 7,911

My System Specs

Default

Do you have NCIX VIP? If not you should use some NCIX points to get it. Returns for RMA's are paid for w/ VIP.

I'd call NCIX or Purolator to confirm it went to the right place.
Reply With Quote
  #23 (permalink)  
Old May 10, 2013, 02:00 PM
rjbarker's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Courtenay, B.C
Posts: 5,932

My System Specs

Default

I'm now at $500 for a faulty Mobo ($45 to ship the thing back) "to the correct address clearly marked both on the box and on my Purolator Slip) address...NCIX/Netlink Computer Inc 13720 Mayfield Place Richmond BC V6V 2E4....with"RMA" all over the box.

Purolator Tracking states it was signed by Bernard at
Nedco
4455 No 6 Rd, Richmond, BC V6V 1P8

Found there number online, called them, they know nothing about it....hhhmmmm (perhaps a good thing I insured it for $400).

Anyhow, contacted Purolator and yes indeed it was delivered to the wrong address...exellent...now I have n RMA # from NCIX and a Case# from Purolator.
__________________
Introducing me n my OCD to Watercooling, is like taking an Alcoholic to an "all you can drink" Beach Bar in Mexico

.
Reply With Quote
  #24 (permalink)  
Old May 13, 2013, 03:30 PM
rjbarker's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Courtenay, B.C
Posts: 5,932

My System Specs

Default

So the "wrong address" was a typo by Purolator on my Tracking number. The RIVE is indeed in the hands of NCIX, now just want a proper working board back so I can this Rig put back together and BIOS showing full 16 GB of RAM ;)
__________________
Introducing me n my OCD to Watercooling, is like taking an Alcoholic to an "all you can drink" Beach Bar in Mexico

.
Reply With Quote
  #25 (permalink)  
Old May 14, 2013, 01:09 PM
Slik's Avatar
Hall Of Fame
 
Join Date: Sep 2009
Location: Sault Ste Marie On.
Posts: 1,065

My System Specs

Default

I sure hope I don't have similar problems with my RIVE. We're about to start my installs later tonight. We shall see soon enough. Fingers crossed.
__________________
Corsair Air 540 -i7 4930k @ 4.4ghz. Liquid cooled-4x4gb G Skill Trident X DDR3@ 2400mhz- Two EVGA Titans SLI - Xonar Phoebus Sound Card-Dell 3008 30" Monitor-Razer Tiamat Headphones-Butt Kicker Gamer-TrackIR 5
Reply With Quote
  #26 (permalink)  
Old May 14, 2013, 01:37 PM
rjbarker's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Courtenay, B.C
Posts: 5,932

My System Specs

Default

Seems the missing RAM is somewhat common with the Boards. Still waiting to hear what NCIX finds, praying its not bent CPU Socket Pins, make sure to get your builder Killswitch to take some High Res pics of the Socket Pins before you drop the CPU int he there.
__________________
Introducing me n my OCD to Watercooling, is like taking an Alcoholic to an "all you can drink" Beach Bar in Mexico

.
Reply With Quote
  #27 (permalink)  
Old May 14, 2013, 01:45 PM
rjbarker's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Courtenay, B.C
Posts: 5,932

My System Specs

Default

The Board itself seems great, tons if options in the Bios, easiest way to Flash Bios I have ever seen!!!
Everything worked great, posted 1st power up no problem, installed W7 no problem.

The only problem was one Memory Slot wasn't detecting the 4GB stick in there.

It's just one of those things you come across from time to time when building. If I find out from NCIX the Board is fine, Ill be RMA'ing the CPU, as my next fault troubleshooting suspect, would be Memory Controlller CPU.
__________________
Introducing me n my OCD to Watercooling, is like taking an Alcoholic to an "all you can drink" Beach Bar in Mexico

.
Reply With Quote
  #28 (permalink)  
Old May 14, 2013, 04:47 PM
rjbarker's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Courtenay, B.C
Posts: 5,932

My System Specs

Default

So, just heard back from NCIX, they are shipping me a replacement Board. The Memory Slot C1 was indeed borked. Glad I didnt waste more than 4 hrs with further troubleshooting.
__________________
Introducing me n my OCD to Watercooling, is like taking an Alcoholic to an "all you can drink" Beach Bar in Mexico

.
Reply With Quote
  #29 (permalink)  
Old May 16, 2013, 07:25 AM
stoanee's Avatar
Hall Of Fame
F@H
 
Join Date: Jun 2007
Location: Lacombe Alberta
Posts: 3,246

My System Specs

Default

Sent my board off yesterday, took pics of cpu pins in case I need to defend myself. Here is hoping all goes well. Good thing I bought a gaming laptop.
__________________
heatware
Reply With Quote
  #30 (permalink)  
Old May 16, 2013, 07:36 AM
rjbarker's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Courtenay, B.C
Posts: 5,932

My System Specs

Default

^^^ Yeah I debated on putting my X58 System back together last Thursday (when I shipped back the RIVE), but packaged up all those parts nicely in original boxes, so fvck it, Rig is still sitting disassembled on the diningroom table!!

Getting a "tad" annoyed with NCIX now:
1. They received the RIVE last Friday.
2. Monday they sent me a message confirming they had it.
3. Tuesday they sent me a message in the AM confirming that the Memory Slot was fvcked and all they needed was my Shipping Address as my replacement Board was ready to be Shipped!!! (yay)
4. Wednesday - Fvck all...new Board NOT shipped (Dont know why they didnt ship it this day)!!

Now, I go back to work next week (on the ship), so REALLY am hoping to have this Board in my hands by tomorrow Friday latest (gives me at least 1 weekend to play - if the damn thing works). So, lets really hope they ship it today so I have it tomorrow!!!!

So, I'm up to almost $500 ($43 to ship it back to NCIX from Van Isle via Purolator) and I still dont have a working Board....

Anyone know if NCIX sends RMA replacement Boards with refurbished or new?
__________________
Introducing me n my OCD to Watercooling, is like taking an Alcoholic to an "all you can drink" Beach Bar in Mexico

.
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Asus RIVE and W7 UEFI Install rjbarker O/S's, Drivers & General Software 9 May 6, 2013 08:37 PM
No physix drivers installed after I installed them? Help!! bushwickbill Video Cards 8 February 14, 2013 07:23 AM
Koolance block now avail for RIVE X79 Eldonko Water Cooling 1 November 30, 2011 03:15 PM
two 1GB+one 2GB= 3.12GB? laplapmax RAM 8 February 15, 2011 09:17 PM
4Gb shown, but 12Gb installed? 3.0charlie Troubleshooting 12 July 17, 2009 06:24 AM