Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old May 1, 2013, 02:01 PM
schweppes's Avatar
Rookie
 
Join Date: Jan 2011
Location: Montreal
Posts: 29
Default SSD failure?

Hi all. First off, specs.
Ocz vertex 2 120gb
Also have two caviar black hdds ( not so important )
i7 950, not over clocked
12gb patriot vengeance memory (1600 but only running at 1333 because of voltage Issues I believe)
Sliver stone 1000w psu
Corsair h50 cooler
Gtx 580 from pny.
Windows 8

I am worried my ssd may have died. But I am hoping the problem is less severe than that.
First I noticed a few programs crashing. Specifically battlefield 3. This may or may not have been related to the problem. Not long afterward, a day or so, I came back to my PC, which I often leave running, to find it on the boot screen with the words "please insert boot media" or something along those lines. I checked bios, and my SSD was not listed in the drive boot sequence. I do a hard reset and it appears again. It's fine for maybe a day, when my computer freezes up on me entirely. The same sequence of events then occur. Now, I can log onto windows for about 5 seconds before it freezes. I tried plugging the drive into another computer to update the firmware, but it even made the other computer freeze up. That computer is newer so I do not want to use it for these purposes, as I was forced to hard reset the machine. So I made a bootable USB disk with the toolset from ocz. Even from that menu, the disk continues to "disappear." It happens quickly, I cannot update the firmware or even use the program to format the drive.
On the ssd itself, there is a red light that appears next to the green one when it stops working. To my understanding, this is not necessarily the red light of death, but could also signify data readability issues.
I would buy a new ssd if needed , but am worried I will have to buy a new copy of windows too.
How do I fix this friends? Thank you kindly for reading this long question.

Last edited by schweppes; May 1, 2013 at 03:01 PM. Reason: More info
Reply With Quote
  #2 (permalink)  
Old May 1, 2013, 02:37 PM
AkG's Avatar
AkG AkG is offline
Hardware Canucks Reviewer
 
Join Date: Oct 2007
Posts: 4,396
Default

First things first.

Download
Token Restore and Adv Token Manager
Token Restore: Your windows activation backup and restore solution
Josh Cell Softwares: Advanced Tokens Manager - The Activation Backup Solution

run BOTH. Save both OFF the drive ASAP.

This will not only give your windows key...but when you reinstall it on the SAME hardware....you wont have to re-intilize it....just run either and restore your tokens (sometimes only 1 or the other will work...but only run ONE. and only run the other if the first doesnt work) ;)

If you need a new copy of the OS...either phone Windows and for a couple bucks they will send you a new CD...or you can search for Digital River links to your OS. You own a legit SN so I personaly see nothing wrong with doing this...BUT YMMV as it not 100% legit to do so.

IF you want to clone the drive. Use acronis and make a '.tib' file....and store if OFF the drive.

Next. Download and install the latest firmware and / or make sure you are using it. It fixed some of the issues which can cause the problem you are having. IF you are running the latest. Move on to the next step. If you are not....give it a week and see if the problem re-appears. In either case....

Next. Phone OCZ. See if you have any warranty left. IF you do...RMA it. Your drive is mostly dead....and temporarily bricking itself was a known issue with the SF1200 controller series. IE the dreaded "sandforce cold start bug". BUT it was mostly fixed via firmware...so you may just have lucked out. The firmware fixed the cold start bug after after sleep mode problem.

IF it happens again, the best way to 'unstick' it...is unplug it and leave it on a shelf for 24hrs. THEN plug it back in. Sometimes this works. Sometimes its dead-dead and no long just 'mostly dead'. Either way...backup your data ASAP...and start thinking about replacing it.
__________________
"If you ever start taking things too seriously, just remember that we are talking monkeys on an organic spaceship flying through the universe." -JR

“if your opponent has a conscience, then follow Gandhi. But if you enemy has no conscience, like Hitler, then follow Bonhoeffer.” - Dr. MLK jr
Reply With Quote
  #3 (permalink)  
Old May 1, 2013, 03:07 PM
schweppes's Avatar
Rookie
 
Join Date: Jan 2011
Location: Montreal
Posts: 29
Default

I'm not even sure that I can run windows long enough to either run or even download those programs, but will try ASAP. Will download from other pc mentioned to save time.
Also, I have been unable to update the firmware, because as soon as it starts running from the bootable USB, it "disappears" immediately. It will show for a moment, but then it's gone. I know it's running 1.25, and I believe the latest firmware is 1.33.

Is it possible that the 24 hr shelfing will work without updating the firmware ?
Reply With Quote
  #4 (permalink)  
Old May 1, 2013, 03:12 PM
schweppes's Avatar
Rookie
 
Join Date: Jan 2011
Location: Montreal
Posts: 29
Default

Luckily, I just built that second pc for my mom and have the windows 8 install disk from thAt.
But, Also to add to this mess, my copy of windows 8 was an upgrade from windows 7. I have the windows 8 key, but I'm not sure if I can find the windows 7 oem one that I built my pc with. Could this cause problems ?
Reply With Quote
  #5 (permalink)  
Old May 1, 2013, 03:44 PM
schweppes's Avatar
Rookie
 
Join Date: Jan 2011
Location: Montreal
Posts: 29
Default

last question, is there any way to update the firmware? whenever I try to use the disk, it freezes or disappears. even from BIOS, it read as sata:3m-ocz-vertex in the sequence menu, and then after going back to those setting after changing others, it simply said "Hard drive"
I will RMA ( I think I have 6 mnths left in my 3 yr warranty ) but can I even format the drive first?

Last edited by schweppes; May 1, 2013 at 03:50 PM.
Reply With Quote
  #6 (permalink)  
Old May 2, 2013, 05:58 AM
schweppes's Avatar
Rookie
 
Join Date: Jan 2011
Location: Montreal
Posts: 29
Default

Thanks akg for the solid response
Reply With Quote
  #7 (permalink)  
Old May 2, 2013, 07:24 AM
AkG's Avatar
AkG AkG is offline
Hardware Canucks Reviewer
 
Join Date: Oct 2007
Posts: 4,396
Default

No problem.

Ok firstly, you will need to run the firmware update from INSIDE a system. It will not work from USB and could perma-brick the SSD!

Personally, what I do is when I install the OS on a new system I make a full backup and label it 'bare metal backup for XXXX'. Then I install my drivers and software and make another backup. THEN I routinely make backups. Next time around this will help you as you wont have to reintsall the OS as often! IF Win 8 was an upgrade you probably will have to install Windows 7, then 8 over it.

If it is dropping out of the bios. Unplug and leave on a shelf for 24hrs. Then clear your cmos /rest your bios. THEN plug it back in. These steps should -hopefully - get it back long enough to update the firmware (this assumes it is the cold bug and not just a controller failing or other hardware on the pcb dieing). I would then do a secure erase on it. That way even if you have to RMA...none of your data is left to worry about. ;)

If
__________________
"If you ever start taking things too seriously, just remember that we are talking monkeys on an organic spaceship flying through the universe." -JR

“if your opponent has a conscience, then follow Gandhi. But if you enemy has no conscience, like Hitler, then follow Bonhoeffer.” - Dr. MLK jr
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible PSU failure? PerryC Troubleshooting 8 February 26, 2012 12:37 PM
My SSD failure Chris Storage 7 February 14, 2012 09:12 PM
SSD failure? TimTheEnchanter Troubleshooting 18 April 27, 2011 05:35 PM
HDD failure or Motherboard failure? Polygon Troubleshooting 3 December 4, 2010 09:48 PM
WC failure martin_metal_88 Water Cooling 32 April 27, 2009 07:06 AM