Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Troubleshooting (http://www.hardwarecanucks.com/forum/troubleshooting/)
-   -   Computer just randomly stopped detecting camera (http://www.hardwarecanucks.com/forum/troubleshooting/59959-computer-just-randomly-stopped-detecting-camera.html)

BobbyLou February 28, 2013 09:03 PM

Computer just randomly stopped detecting camera
 
So my main windows 7 machine just decided to randomly stop detecting my snap and shoot camera. When I plug it in via USB it says it can't find a driver, which is strange, since I have used it probably over 100 times without ever installing a driver. I just plug it in via usb and use the normal autoplay function that lets you access the SD card folder to import the pics.


Checked the manufacture website and as expected, there was no driver download available. I've tried different USB ports as well. I checked device manager and it had the little yellow caution sign over the camera, tryed to install the driver from there, but nothing was found by Windows.

*Update

I noticed when the computer tries to find the "driver" it says "searching for pre configured folders" then it fails

Also, I checked the Canon site and it says that the camera is PTP, so it is plug and play. The OS should be able to supply the driver once plugged in but for some reason it has stopped.

chubaka February 28, 2013 09:56 PM

Sometimes it might be a faulty cable. Happen to my usb ethernet.

BobbyLou February 28, 2013 10:14 PM

Tried a different cable and a different canon camera, had exactly the same problem. Definitely has something to do with the computer.

Dzzope March 1, 2013 12:43 AM

I found with xp sometimes the usb devices get muddled up (not detected or not running smoothly) after time / lots of devices or even using different usb ports..

Try removing all your USB devices and re-installing them(as in remove the drivers in device manager).
This used to solve it for me but I also found once it started happening it would re-occur fairly soon after..
Re-load of the os if you can't solve it any other way.

BobbyLou March 1, 2013 01:52 AM

Yeah, I just reinstalled OS and it works again. Guess it was just one of those strange windows things.


All times are GMT -7. The time now is 08:15 PM.