Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Troubleshooting (http://www.hardwarecanucks.com/forum/troubleshooting/)
-   -   Router setting for webserver in a VM (http://www.hardwarecanucks.com/forum/troubleshooting/59159-router-setting-webserver-vm.html)

moocow January 15, 2013 03:11 PM

Router setting for webserver in a VM
 
I got a Glassfish server on a local server inside a VM. I can get to the VM from my own computer using the VM's static IP. The VM is using a bridge network adapter so it has its own IP on the local network. When I try getting to it using the external IP, it doesn't work. I tested the external IP and point it to port 80 and it would hit the router's login page. So the external IP does work. I put my VM's IP and port on the port forward list but that doesn't seem to help. Any ideas?

KaptCrunch January 15, 2013 03:41 PM

you try java forum

moocow January 15, 2013 03:50 PM

I already Googled it a bunch of times but no luck so far, and that included the Java Forum.

JD January 15, 2013 04:21 PM

Try forwarding say 8080 (outside) to 80 (inside). It seems you have the remote web interface enabled on your router which is taking over port 80.

moocow January 15, 2013 04:39 PM

Inside is 8080 as well so the Port Forward entry is source net = null, source port = 8080, IP address = server's internal IP, port to = 8080. I already disable remote web gui and any remote access on the router.

UPDATE: Well it turns out that DD WRT has a port forwarding bug. I switched over to Tomato RAF and the problem looks resolved.

grinder January 16, 2013 07:50 AM

some routers do not allow LAN traffic to reach forwarded ports linked to the WAN side. I'm glad you got it fixed so soon... it's can be a frustrating thing to troubleshoot.

Note that my PFsense router, and every dual WAN router I have worked with has the same issue.

:)


All times are GMT -7. The time now is 11:06 AM.