Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old December 16, 2012, 09:33 AM
Hall Of Fame
F@H
 
Join Date: Nov 2008
Location: Ottawa, ON
Posts: 1,226

My System Specs

Default Temporary screen corruption on Laptop

Hi all,

Today I woke up my Samsung QX411 from sleep mode to be treated to this, which luckily went away now Can someone enlighten me as to what this is and what I can do about it?

(If the picture doesn't load for you, what I see is horizontally, left 1/3 of the screen looks normal, the middle 1/3 of the screen is pure white (well as white as the display can render), and the right 1/3 of the screen is a bunch of vertical bars.

I first saw it in the Windows 8 OS, and it survived a "cold" boot. Obviously it's not OS because that's the BIOS screen being corrupted. One cold boot later, the display switched to another funky configuration, with the left and right side of the screen being the same, and the white still there:

When I tried to boot the OS into the state I had above, Windows 8 gave me one of those sad face BSODs, but obviously I couldn't read the error with the screen so messed up.

For now, as my joke in my sig states, I used the little shutdown button on the bottom of the laptop, and problems magically disappeared after the "full" shutdown + a visit to the BIOS screen + another shutdown. Also, Windows 8 boots normally again...

So what went wrong with this laptop, and what tests should I subject it to, if anything?

----------------------------------------------
The configuration of the laptop is as follows:
Chassis: Samsung QX411 1366x768 14.1" screen
CPU: Core i5 2410M
RAM: 4GB (1x 4GB)
GPU: Intel HD Graphics + GeForce 525M (Optimus)
HDD: Seagate Momentus XT 320GB

(no peripherals were plugged into the laptop at the time)
__________________
"The computer programmer says they should drive the car around the block and see if the tire fixes itself." [src]
Reply With Quote
  #2 (permalink)  
Old December 16, 2012, 09:35 AM
Hall Of Fame
F@H
 
Join Date: Nov 2008
Location: Ottawa, ON
Posts: 1,226

My System Specs

Default

UPDATE: The laptop also sleeps properly again...
Digging into the event logs, the only note that anything happened was a VPU recover on the Intel graphics. "Display driver igfx stopped responding and has successfully recovered."
__________________
"The computer programmer says they should drive the car around the block and see if the tire fixes itself." [src]
Reply With Quote
  #3 (permalink)  
Old December 16, 2012, 09:14 PM
KaptCrunch's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Ontario
Posts: 2,939
Default

video is overheating
Reply With Quote
  #4 (permalink)  
Old December 16, 2012, 10:15 PM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,598
Default

Hook a external monitor up and if the corruption goes away then you got a panel issue. Most gpu issues can be replicated across to the secondary monitor.
Reply With Quote
  #5 (permalink)  
Old December 17, 2012, 12:32 PM
KaptCrunch's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Ontario
Posts: 2,939
Default

Quote:
Originally Posted by enaberif View Post
Hook a external monitor up and if the corruption goes away then you got a panel issue. Most gpu issues can be replicated across to the secondary monitor.
A+ on elimination fault
Reply With Quote
  #6 (permalink)  
Old December 17, 2012, 01:25 PM
Hall Of Fame
F@H
 
Join Date: Nov 2008
Location: Ottawa, ON
Posts: 1,226

My System Specs

Default

Thanks! The laptop is back to normal for now, but I'll remember the secondary monitor if it happens again.
It's able to pass ~4 hours of MSI Kombustor forced on the IGP, so I guess it's not that close to dying out yet...
__________________
"The computer programmer says they should drive the car around the block and see if the tire fixes itself." [src]
Reply With Quote
  #7 (permalink)  
Old December 17, 2012, 01:46 PM
Hall Of Fame
F@H
 
Join Date: Nov 2008
Location: Ottawa, ON
Posts: 1,226

My System Specs

Default

I jinxed myself

The corruption came back for a few minutes and went away. It was ONLY visible on the laptop's display.

With either a VGA cable or an HDMI cable connected to an external monitor (which ran at the same resolution as the laptop's display) there was no corruption at all. Also with the external monitor, I ran MSI Afterburner on both the nVidia GPU and the IGP and there was no artifacts. (I confirmed it was running on IGP and GPU by looking at GPU-Z and the frame rate difference between the IGP running Kombustor and the GPU running Kombustor.)

Is this a dying panel / connection to panel?
__________________
"The computer programmer says they should drive the car around the block and see if the tire fixes itself." [src]
Reply With Quote
  #8 (permalink)  
Old December 17, 2012, 02:34 PM
enaberif's Avatar
Hall Of Fame
 
Join Date: Dec 2006
Location: Calgahree, AB
Posts: 10,598
Default

That is generally a panel issue acting up. It can be at times cable or inverter but rarely.
Reply With Quote
  #9 (permalink)  
Old December 17, 2012, 03:54 PM
Hall Of Fame
F@H
 
Join Date: Nov 2008
Location: Ottawa, ON
Posts: 1,226

My System Specs

Default

Double-confirmed... it's the panel.
I just ripped the laptop apart (with no damage to plastic parts by using big zipties as prying tools). I got the protective cover off the panel and I can reproduce the issue by applying physical pressure to the bottom centre of the panel. (See pic)

Edit: Tugging on the wire makes a different type of corruption on the display (more like what would happen if you had a messed up VGA cable).
__________________
"The computer programmer says they should drive the car around the block and see if the tire fixes itself." [src]
Reply With Quote
  #10 (permalink)  
Old December 17, 2012, 04:40 PM
KaptCrunch's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Ontario
Posts: 2,939
Default

replace ribbon
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Laptop screen goes crazy, help ADay2Long Troubleshooting 1 March 15, 2011 10:41 PM
screen res controlled by actual screen or laptop supaflyx3 Mobile Computing 3 July 29, 2010 08:36 PM
Matte screen laptop Rison Mobile Computing 4 February 8, 2010 04:47 PM
Anyway to use a laptop screen as a second monitor? BobbyLou Mobile Computing 4 December 31, 2009 11:32 AM
[WTB] Laptop w/17" screen 3.0charlie Buy/Sell & Trade 1 September 27, 2009 02:48 PM