Go Back   Hardware Canucks > PC BUILDERS & TWEAKERS CORNER > Troubleshooting

    
Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old August 31, 2012, 10:48 PM
Galcobar's Avatar
MVP
 
Join Date: Dec 2009
Location: Richmond, B.C.
Posts: 437

My System Specs

Default nForce drivers won't install, 32/64 bit confusion

Bit of a puzzler.

I can't get the chipset drivers for my motherboard to uninstall, because according to it I'm running a 32-bit uninstaller on a 64-bit system, and because according to the installer I'm not running a 64-bit system.

For clarification:
OS is W7 Professional 64-bit, motherboard is an Asus P5N-E SLI running the nForce 650 SLI chipset. The latest drivers from Nvidia are 15.57, available in both 32-bit (XP, Vista, 7) and 64-bit (XP Pro, Vista, 7) flavours.

I've found there's a significant difference in read/write speeds between the stock Windows drivers and the Nvidia drivers. I tested various configurations when I first moved to W7 and determined the Nvidia 15.57 drivers with no queuing produced the fastest read results. Tonight I decided to use the driver update utility in Windows, to see if there had been any improvements.

For some damned reason, W7 decided to update to Nvidia 10.6.0.18 drivers from 2010 -- and they're 32-bit, nvstor.sys instead of nvstor64.sys.

Using Device Manager to uninstall the device drivers does nothing except prompt a restart. The system continues to use the nForce drivers and won't even revert to the stock Microsoft driver. DriverSweeper and CCleaner make no difference, and the drivers aren't listed for Uninstall Programs.

Tried using Device Manager to manually pick the nvstor64.sys driver, both from the System32 folder and from an unzipper Nvidia installer, and discovered that Windows thinks the driver is up to date.

When I run the Nvidia installer program, I get a fatal error because I'm trying to run a 32-bit uninstaller on a 64-bit operating system. I hit OK, and the installer then snags, complaining that I'm attempting to install 64-bit drivers to an incompatible system. Running the 32-bit Nvidia installer, I get the error in reverse.

Last edited by Galcobar; August 31, 2012 at 11:04 PM.
Reply With Quote
  #2 (permalink)  
Old August 31, 2012, 11:10 PM
Galcobar's Avatar
MVP
 
Join Date: Dec 2009
Location: Richmond, B.C.
Posts: 437

My System Specs

Default

Okay, after a bit more work managed to get the Driver Manager update to select the right file, nvstor64.sys version 11.1.0.43 from the 15.57 chipset driver package. So, my IDE ATA controller is running the correct driver, though ATTO complains my ExpressPCI driver is not compatible -- not a problem since I have no PCI storage devices, but it didn't happen before.

Yet, the damned thing still won't let me install the rest of the driver package. Still getting the 32-bit uninstaller and incompatible installer errors.
Reply With Quote
  #3 (permalink)  
Old August 31, 2012, 11:52 PM
Dzzope's Avatar
Hall Of Fame
 
Join Date: Oct 2010
Location: Irishman in Kiev, wOOoo, I'm an alien...
Posts: 2,682

My System Specs

Default

Start in safe mode.. un-install then MANUALLY install the drivers..
Reply With Quote
  #4 (permalink)  
Old September 1, 2012, 04:24 PM
Galcobar's Avatar
MVP
 
Join Date: Dec 2009
Location: Richmond, B.C.
Posts: 437

My System Specs

Default

Sadly, that did not fix the issue -- though it did allow me to install the Ethernet driver.
Reply With Quote
  #5 (permalink)  
Old September 1, 2012, 04:30 PM
KaptCrunch's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Ontario
Posts: 2,922
Default

what happened to roll-back option in device manager to revert back to orginale

note that P5N-E SLI is a 32bit MB with 64bit cpu

Last edited by KaptCrunch; September 1, 2012 at 04:43 PM.
Reply With Quote
  #6 (permalink)  
Old September 1, 2012, 04:51 PM
KaptCrunch's Avatar
Hall Of Fame
 
Join Date: Feb 2008
Location: Ontario
Posts: 2,922
Default

best is get info off chips and load one by one for this MB and get jmicron drivers
Attached Images
 
Reply With Quote
Reply


Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do YOU install drivers? Deviant Video Cards 14 July 17, 2010 09:26 AM
ATI drivers won't install SneakySnake O/S's, Drivers & General Software 8 November 23, 2009 05:06 AM
I am geting BSOD when ever I install Xonar dx drivers Shadowmeph O/S's, Drivers & General Software 3 June 6, 2009 05:40 PM
WHich Vid drivers and how do I install them Shadowmeph O/S's, Drivers & General Software 0 March 14, 2008 10:56 PM
If I update drivers or install the ATI tool tray.... Canadianguy Video Cards 7 July 28, 2007 12:34 PM