Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Troubleshooting (http://www.hardwarecanucks.com/forum/troubleshooting/)
-   -   nForce drivers won't install, 32/64 bit confusion (http://www.hardwarecanucks.com/forum/troubleshooting/56455-nforce-drivers-wont-install-32-64-bit-confusion.html)

Galcobar August 31, 2012 10:48 PM

nForce drivers won't install, 32/64 bit confusion
 
Bit of a puzzler.

I can't get the chipset drivers for my motherboard to uninstall, because according to it I'm running a 32-bit uninstaller on a 64-bit system, and because according to the installer I'm not running a 64-bit system.

For clarification:
OS is W7 Professional 64-bit, motherboard is an Asus P5N-E SLI running the nForce 650 SLI chipset. The latest drivers from Nvidia are 15.57, available in both 32-bit (XP, Vista, 7) and 64-bit (XP Pro, Vista, 7) flavours.

I've found there's a significant difference in read/write speeds between the stock Windows drivers and the Nvidia drivers. I tested various configurations when I first moved to W7 and determined the Nvidia 15.57 drivers with no queuing produced the fastest read results. Tonight I decided to use the driver update utility in Windows, to see if there had been any improvements.

For some damned reason, W7 decided to update to Nvidia 10.6.0.18 drivers from 2010 -- and they're 32-bit, nvstor.sys instead of nvstor64.sys.

Using Device Manager to uninstall the device drivers does nothing except prompt a restart. The system continues to use the nForce drivers and won't even revert to the stock Microsoft driver. DriverSweeper and CCleaner make no difference, and the drivers aren't listed for Uninstall Programs.

Tried using Device Manager to manually pick the nvstor64.sys driver, both from the System32 folder and from an unzipper Nvidia installer, and discovered that Windows thinks the driver is up to date.

When I run the Nvidia installer program, I get a fatal error because I'm trying to run a 32-bit uninstaller on a 64-bit operating system. I hit OK, and the installer then snags, complaining that I'm attempting to install 64-bit drivers to an incompatible system. Running the 32-bit Nvidia installer, I get the error in reverse.

Galcobar August 31, 2012 11:10 PM

Okay, after a bit more work managed to get the Driver Manager update to select the right file, nvstor64.sys version 11.1.0.43 from the 15.57 chipset driver package. So, my IDE ATA controller is running the correct driver, though ATTO complains my ExpressPCI driver is not compatible -- not a problem since I have no PCI storage devices, but it didn't happen before.

Yet, the damned thing still won't let me install the rest of the driver package. Still getting the 32-bit uninstaller and incompatible installer errors.

Dzzope August 31, 2012 11:52 PM

Start in safe mode.. un-install then MANUALLY install the drivers..

Galcobar September 1, 2012 04:24 PM

Sadly, that did not fix the issue -- though it did allow me to install the Ethernet driver.

KaptCrunch September 1, 2012 04:30 PM

what happened to roll-back option in device manager to revert back to orginale

note that P5N-E SLI is a 32bit MB with 64bit cpu

KaptCrunch September 1, 2012 04:51 PM

1 Attachment(s)
best is get info off chips and load one by one for this MB and get jmicron drivers


All times are GMT -7. The time now is 12:09 AM.