Hardware Canucks

Hardware Canucks (http://www.hardwarecanucks.com/forum/)
-   Troubleshooting (http://www.hardwarecanucks.com/forum/troubleshooting/)
-   -   Help! Computer won't turn on! (http://www.hardwarecanucks.com/forum/troubleshooting/56024-help-computer-wont-turn.html)

rhspeed206 August 10, 2012 04:31 AM

Help! Computer won't turn on!
 
I have a CORSAIR Enthusiast Series TX750 V2 750W ATX 12V 80 PLUS BRONZE Certified Active PFC High Performance Power Supply and today was working fine but until I turn the computer off, it won't turn back on even the flickers behind the power supply won't work. Could it be the motherboard or should I unplug and reconnect everything! Help me.

computer specs

Asrock z68 pro 3 gen 3 intel LGA 1155 motherboard
Intel i7 2600k
16gb ram Corsair Vengeance
m4 crucial 128gb ssd
Amd Firepro v5900 graphics card
Western Digital Caviar Blue 500gb 7200 rpm SATA 6.0GB/ 3.5 internal hard drive

Rasparthe August 10, 2012 06:21 AM

That motherboard should have LED lights that turn on when the power supply is on, are they lit? If they are not lit then either the power supply is not connected to the motherboard at all or the power supply has died. Stupid question of course, but you have the switch on the back of the power supply turned to the on position right?

Ravenor August 10, 2012 06:43 AM

is it possibly plugged into a powerbar that has a separate on/off that is switched off? How old is the TX750? You may want to open the case and re-seat all of the motherboard connectors to make sure something didn't come loose.

rhspeed206 August 10, 2012 08:05 AM

I just tested the power supply alone and it works, YAY!!, but now I'm thinking is it the motherboard?? I'm going to reconnect the motherboard and see what happens

rhspeed206 August 10, 2012 08:37 AM

I reconnected everything and nothing works. Its frustrating me, can anyone tell me whats going on?

moocow August 10, 2012 10:08 AM

There are literally dozens of reasons why a board won't turn on. But if it was working fine but then suddenly didn't, I would say possible CPU or motherboard. Did you put the power supply in another computer to test? If so, can you use it to test other components? If you're really short on time, then just buy another board, RMA the current one, and sell it here when it comes back from RMA. Yes, you will lose some money but save some down time.

bigFOIG August 11, 2012 03:38 AM

Check if the power button cable is plugged in all the way. It's one of this tiny wire usually located at the bottom right of your motherboard. Or if your motherboard has a power button directly on the board, try that.

stoanee August 11, 2012 04:51 AM

Read this, it may help...

ASUSTeK Computer Inc.-Forum- ****************************Bad BIOS Flash and Dead Board Testing. ***** ALL Boards *****

rhspeed206 August 14, 2012 07:57 PM


I tried to clear cmos with a jumper for 5 seconds but the lights came on for 3 seconds but then shut off completely. Oh and this post should I try this method for ten minutes or is this method too old for my motherboard asrock z68 pro3 gen3

rhspeed206 August 19, 2012 01:56 AM

Problem solved!!, I took out the CMOS Battery for between 4 or 5 minutes and the motherboard is restored and put the bios to ACHI instead of IDE, one more question should I enable or disable the Hard drive smart? I have a Crucial 128gb SSD and 320GB Hard Drive, Thank you everyone for your help:biggrin:.


All times are GMT -7. The time now is 11:01 PM.